]> git.pld-linux.org Git - packages/blender.git/blobdiff - blender.spec
- release 3 (by relup.sh)
[packages/blender.git] / blender.spec
index af442f4f10e56a4bc7eebc862c1afc75f925e6c4..d10738c7cfac41a2077f4c9daf8b546db6f8a003 100644 (file)
@@ -4,49 +4,60 @@
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
-Version:       2.46
-Release:       1
+Version:       2.82a
+Release:       3
 License:       GPL
 Group:         X11/Applications/Graphics
-Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: e90543a5ca5db8b04498ab0abe7bbd2c
-Source1:       %{name}.desktop
-Source2:       %{name}.png
-Source4:       %{name}-wrapper
-Source5:       %{name}.manpage
-Patch0:                %{name}-po_and_locale_names.patch
-Patch1:                %{name}-noxml-yafray.patch
+Source0:       http://download.blender.org/source/%{name}-%{version}.tar.xz
+# Source0-md5: 3e9d669185b83d5d2cb1b38dcf64d5ec
+Patch0:                %{name}-2.76-droid.patch
+Patch1:                format-security.patch
 URL:           http://www.blender.org/
+BuildRequires: OpenAL-devel
+BuildRequires: OpenColorIO-devel
 BuildRequires: OpenEXR-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel
-BuildRequires: gcc >= 5:3.4.0
-BuildRequires: ffmpeg-devel
+BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenImageIO-devel
+BuildRequires: SDL2-devel
+BuildRequires: boost-devel
+BuildRequires: cmake
+BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
+BuildRequires: fftw3-devel
 BuildRequires: freealut-devel
 BuildRequires: freetype-devel
 BuildRequires: ftgl-devel
-BuildRequires: gettext-devel
-#BuildRequires:        esound-devel
+BuildRequires: gcc >= 5:3.4.0
+BuildRequires: gettext-tools
+BuildRequires: glew-devel
+BuildRequires: jack-audio-connection-kit-devel
+BuildRequires: jemalloc-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
+BuildRequires: libsndfile-devel
+BuildRequires: libspnav-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
 BuildRequires: libvorbis-devel
+BuildRequires: openjpeg2-devel
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: python-devel >= 1:2.3
+BuildRequires: pugixml-devel
+BuildRequires: python3
+BuildRequires: python3-devel
+BuildRequires: python3-numpy-devel
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.385
-BuildRequires: scons
 BuildRequires: sed >= 4.0
-#BuildRequires:        smpeg-devel
+BuildRequires: xorg-lib-libXi-devel
 BuildRequires: zlib-devel
 Requires(post,postun): desktop-file-utils
 Requires:      OpenGL
 Requires:      freetype
-Requires:      python-modules
+Requires:      python3-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _noautoreqdep   libGL.so.1 libGLU.so.1
+%define                _noautoreqdep   libGL.so.1 libGLU.so.1
 
 %description
 Blender is a free and fully functional 3D modeling, rendering,
@@ -62,65 +73,63 @@ Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
 %patch0 -p1
 %patch1 -p1
 
-rm -f missing
-rm -f user-config.py
-rm -rf bin/.blender/locale
-
-RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
-RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      release/bin/blender-thumbnailer.py \
+      release/scripts/addons/io_curve_svg/svg_util_test.py \
+      release/scripts/addons/io_scene_fbx/fbx2json.py \
+      release/scripts/addons/io_scene_fbx/json2fbx.py \
+      release/scripts/addons/sun_position/geo.py \
+      release/scripts/modules/bl_i18n_utils/merge_po.py \
+      release/scripts/modules/bl_i18n_utils/utils_rtl.py \
+      release/scripts/modules/blend_render_info.py
 
-cat > user-config.py <<END
-CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
-CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
-LDFLAGS           = [$RPMLDFLAGS]
-TARGET_CC         = '%{__cc}'
-TARGET_CXX        = '%{__cxx}'
-
-BF_PYTHON_VERSION = '%{py_ver}'
+%build
+install -d build
+cd build
+%cmake \
+       -DCMAKE_SKIP_RPATH:BOOL=ON \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_JACK:BOOL=ON \
+       -DWITH_JACK_DYNLOAD:BOOL=ON \
+       -DWITH_CODEC_SNDFILE:BOOL=ON \
+       -DWITH_IMAGE_OPENJPEG:BOOL=ON \
+       -DWITH_OPENCOLLADA:BOOL=ON \
+       -DWITH_OPENCOLORIO:BOOL=ON \
+       -DWITH_CYCLES:BOOL=ON \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_MOD_OCEANSIM:BOOL=ON \
+       -DOPENCOLLADA=%{_includedir} \
+       -DWITH_PYTHON:BOOL=ON \
+       -DPYTHON_VERSION:STRING=%{py3_ver} \
+       -DWITH_PYTHON_INSTALL:BOOL=OFF \
+       -DWITH_CODEC_FFMPEG:BOOL=ON \
+       -DWITH_GAMEENGINE:BOOL=ON \
+       -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
+       -DWITH_INSTALL_PORTABLE:BOOL=OFF \
+       -DWITH_PYTHON_SAFETY:BOOL=ON \
+       -DWITH_PLAYER:BOOL=ON \
+       -DWITH_MEM_JEMALLOC:BOOL=ON \
+       -DWITH_SYSTEM_GLEW:BOOL=ON \
+       -DBOOST_ROOT=%{_prefix} \
+       -DWITH_INPUT_NDOF:BOOL=ON \
+       -DWITH_SDL:BOOL=ON \
+       -DWITH_SDL_DYNLOAD:BOOL=ON \
+       ..
+
+%{__make} V=1
 
-BF_FFMPEG         = '/usr'
-BF_FFMPEG_INC     = '%{_includedir}/ffmpeg'
-BF_FFMPEG_LIBPATH = '%{_libdir}'
-BF_FFMPEG_LIB     = 'avformat avcodec swscale avutil'
+%install
+rm -rf $RPM_BUILD_ROOT
 
-LCGDIR            = 'lib/linux2'
-BF_BUILDDIR       = 'build/linux2'
-BF_INSTALLDIR     = 'install/linux2'
-END
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
 
-%build
-%scons BF_OPENGL_LIBPATH=%{_x_libraries}
-%{__make} -C po OCGDIR=..
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install -d release/plugins/include
-install source/blender/blenpluginapi/*.h release/plugins/include
-chmod +x release/plugins/bmake
-%{__make} -C release/plugins/
+./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
 
-%install
-rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
-       $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
-
-install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
-install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
-#install blenderplayer $RPM_BUILD_ROOT%{_bindir}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install -d $RPM_BUILD_ROOT%{_datadir}/blender
-cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
-install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
-cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
-
-%find_lang %{name}
+#%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -131,13 +140,14 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 %update_desktop_database_postun
 
-%files -f %{name}.lang
+%files
 %defattr(644,root,root,755)
-%doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
-%doc release/text/{blender.html,release*.txt}
-%attr(755,root,root) %{_bindir}/*
+# -f %{name}.lang
+%doc doc/license/bf-members.txt doc/guides/*.txt
+%attr(755,root,root) %{_bindir}/blender
+%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
 %attr(755,root,root) %{_datadir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}
 %{_desktopdir}/*.desktop
-%{_pixmapsdir}/*.png
+%{_iconsdir}/hicolor/scalable/apps/blender.svg
+%{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
 %{_mandir}/man1/*
This page took 1.334262 seconds and 4 git commands to generate.