]> git.pld-linux.org Git - packages/blender.git/blobdiff - blender.spec
- rebuild with python 3.8
[packages/blender.git] / blender.spec
index e184c0fc897a8373de419fb6ed9f89918cc2827f..cb20f8251977c62917ed9489e817efbd6e3c0928 100644 (file)
@@ -1,51 +1,62 @@
 # TODO:
 # - enable internalization support (BR libftgl)
-# - enable OpenAL support
 # - libsolid/libqhull/libode BR ?
-# - package python scripts
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
-Version:       2.45
+Version:       2.80
 Release:       2
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 1358ca481b7f2b8eadd3327ebbd563ef
-Source1:       %{name}.desktop
-Source2:       %{name}.png
-Source4:       %{name}-wrapper
-Source5:       %{name}.manpage
-Patch0:                %{name}-po_and_locale_names.patch
-Patch1:                %{name}-noxml-yafray.patch
+# Source0-md5: 30dedaf688741d0d5d6fa1e3c331610c
+Patch0:                %{name}-2.76-droid.patch
+Patch1:                format-security.patch
 URL:           http://www.blender.org/
+BuildRequires: OpenAL-devel
+BuildRequires: OpenColorIO-devel
 BuildRequires: OpenEXR-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel
-BuildRequires: gcc >= 5:3.4.0
+BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenImageIO-devel
+BuildRequires: SDL2-devel
+BuildRequires: boost-devel
+BuildRequires: cmake
+BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
+BuildRequires: fftw3-devel
 BuildRequires: freealut-devel
 BuildRequires: freetype-devel
 BuildRequires: ftgl-devel
-BuildRequires: gettext-devel
-#BuildRequires:        esound-devel
+BuildRequires: gcc >= 5:3.4.0
+BuildRequires: gettext-tools
+BuildRequires: glew-devel
+BuildRequires: jack-audio-connection-kit-devel
+BuildRequires: jemalloc-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
+BuildRequires: libsndfile-devel
+BuildRequires: libspnav-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
 BuildRequires: libvorbis-devel
+BuildRequires: openjpeg2-devel
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: python-devel >= 1:2.3
-BuildRequires: scons
+BuildRequires: python3
+BuildRequires: python3-devel
+BuildRequires: python3-numpy-devel
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.385
 BuildRequires: sed >= 4.0
-#BuildRequires:        smpeg-devel
+BuildRequires: xorg-lib-libXi-devel
 BuildRequires: zlib-devel
+Requires(post,postun): desktop-file-utils
 Requires:      OpenGL
 Requires:      freetype
 Requires:      python-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _noautoreqdep   libGL.so.1 libGLU.so.1
+%define                _noautoreqdep   libGL.so.1 libGLU.so.1
 
 %description
 Blender is a free and fully functional 3D modeling, rendering,
@@ -60,70 +71,72 @@ Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
 %setup -q
 %patch0 -p1
 %patch1 -p1
-mv -f po/pt_{br,BR}.po
 
-rm -f missing
-rm -f user-config.py
+%build
+install -d build
+cd build
+%cmake \
+       -DCMAKE_SKIP_RPATH:BOOL=ON \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_JACK:BOOL=ON \
+       -DWITH_JACK_DYNLOAD:BOOL=ON \
+       -DWITH_CODEC_SNDFILE:BOOL=ON \
+       -DWITH_IMAGE_OPENJPEG:BOOL=ON \
+       -DWITH_OPENCOLLADA:BOOL=ON \
+       -DWITH_OPENCOLORIO:BOOL=ON \
+       -DWITH_CYCLES:BOOL=ON \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_MOD_OCEANSIM:BOOL=ON \
+       -DOPENCOLLADA=%{_includedir} \
+       -DWITH_PYTHON:BOOL=ON \
+       -DPYTHON_VERSION:STRING=%{py3_ver} \
+       -DWITH_PYTHON_INSTALL:BOOL=OFF \
+       -DWITH_CODEC_FFMPEG:BOOL=ON \
+       -DWITH_GAMEENGINE:BOOL=ON \
+       -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
+       -DWITH_INSTALL_PORTABLE:BOOL=OFF \
+       -DWITH_PYTHON_SAFETY:BOOL=ON \
+       -DWITH_PLAYER:BOOL=ON \
+       -DWITH_MEM_JEMALLOC:BOOL=ON \
+       -DWITH_SYSTEM_GLEW:BOOL=ON \
+       -DBOOST_ROOT=%{_prefix} \
+       -DWITH_INPUT_NDOF:BOOL=ON \
+       -DWITH_SDL:BOOL=ON \
+       -DWITH_SDL_DYNLOAD:BOOL=ON \
+       ..
 
-RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
-RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
+%{__make} V=1
 
-cat > user-config.py <<END
-CCFLAGS           = [$RPMCFLAGS]
-CXXFLAGS          = [$RPMCFLAGS]
-LDFLAGS           = [$RPMLDFLAGS]
-TARGET_CC         = '%{__cc}'
-TARGET_CXX        = '%{__cxx}'
+%install
+rm -rf $RPM_BUILD_ROOT
 
-BF_PYTHON_VERSION = '%{py_ver}'
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
 
-LCGDIR            = 'lib/linux2'
-BF_BUILDDIR       = 'build/linux2'
-BF_INSTALLDIR     = 'install/linux2'
-END
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-%build
-scons BF_OPENGL_LIBPATH=%{_x_libraries}
-%{__make} -C po OCGDIR=..
+./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
 
-install -d release/plugins/include
-install source/blender/blenpluginapi/*.h release/plugins/include
-chmod +x release/plugins/bmake
-%{__make} -C release/plugins/
+#%find_lang %{name}
 
-%install
+%clean
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
-       $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
 
-install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
-install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
-#install blenderplayer $RPM_BUILD_ROOT%{_bindir}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install -d $RPM_BUILD_ROOT%{_datadir}/blender
-cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
-install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
-cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
+%post
+%update_desktop_database_post
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%postun
+%update_desktop_database_postun
 
 %files
 %defattr(644,root,root,755)
-%doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
-%doc release/text/{blender.html,release*.txt}
-%attr(755,root,root) %{_bindir}/*
+# -f %{name}.lang
+%doc doc/license/bf-members.txt doc/guides/*.txt
+%attr(755,root,root) %{_bindir}/blender
+%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
 %attr(755,root,root) %{_datadir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}
 %{_desktopdir}/*.desktop
-%{_pixmapsdir}/*.png
+%{_iconsdir}/hicolor/scalable/apps/blender.svg
+%{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
 %{_mandir}/man1/*
This page took 0.586497 seconds and 4 git commands to generate.