]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- rebuild with python 3.8
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.80
8 Release:        2
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  30dedaf688741d0d5d6fa1e3c331610c
13 Patch0:         %{name}-2.76-droid.patch
14 Patch1:         format-security.patch
15 URL:            http://www.blender.org/
16 BuildRequires:  OpenAL-devel
17 BuildRequires:  OpenColorIO-devel
18 BuildRequires:  OpenEXR-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  OpenImageIO-devel
22 BuildRequires:  SDL2-devel
23 BuildRequires:  boost-devel
24 BuildRequires:  cmake
25 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
26 BuildRequires:  fftw3-devel
27 BuildRequires:  freealut-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  ftgl-devel
30 BuildRequires:  gcc >= 5:3.4.0
31 BuildRequires:  gettext-tools
32 BuildRequires:  glew-devel
33 BuildRequires:  jack-audio-connection-kit-devel
34 BuildRequires:  jemalloc-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libsndfile-devel
38 BuildRequires:  libspnav-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  openjpeg2-devel
44 BuildRequires:  openssl-devel >= 0.9.7d
45 BuildRequires:  python3
46 BuildRequires:  python3-devel
47 BuildRequires:  python3-numpy-devel
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  rpmbuild(macros) >= 1.385
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  xorg-lib-libXi-devel
52 BuildRequires:  zlib-devel
53 Requires(post,postun):  desktop-file-utils
54 Requires:       OpenGL
55 Requires:       freetype
56 Requires:       python-modules
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
60
61 %description
62 Blender is a free and fully functional 3D modeling, rendering,
63 animation and game creation package for Unix, Windows and BeOS
64 systems.
65
66 %description -l pl.UTF-8
67 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
68 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74
75 %build
76 install -d build
77 cd build
78 %cmake \
79         -DCMAKE_SKIP_RPATH:BOOL=ON \
80         -DBUILD_SHARED_LIBS:BOOL=OFF \
81         -DWITH_FFTW3:BOOL=ON \
82         -DWITH_JACK:BOOL=ON \
83         -DWITH_JACK_DYNLOAD:BOOL=ON \
84         -DWITH_CODEC_SNDFILE:BOOL=ON \
85         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
86         -DWITH_OPENCOLLADA:BOOL=ON \
87         -DWITH_OPENCOLORIO:BOOL=ON \
88         -DWITH_CYCLES:BOOL=ON \
89         -DWITH_FFTW3:BOOL=ON \
90         -DWITH_MOD_OCEANSIM:BOOL=ON \
91         -DOPENCOLLADA=%{_includedir} \
92         -DWITH_PYTHON:BOOL=ON \
93         -DPYTHON_VERSION:STRING=%{py3_ver} \
94         -DWITH_PYTHON_INSTALL:BOOL=OFF \
95         -DWITH_CODEC_FFMPEG:BOOL=ON \
96         -DWITH_GAMEENGINE:BOOL=ON \
97         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
98         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
99         -DWITH_PYTHON_SAFETY:BOOL=ON \
100         -DWITH_PLAYER:BOOL=ON \
101         -DWITH_MEM_JEMALLOC:BOOL=ON \
102         -DWITH_SYSTEM_GLEW:BOOL=ON \
103         -DBOOST_ROOT=%{_prefix} \
104         -DWITH_INPUT_NDOF:BOOL=ON \
105         -DWITH_SDL:BOOL=ON \
106         -DWITH_SDL_DYNLOAD:BOOL=ON \
107         ..
108
109 %{__make} V=1
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
115
116 %{__make} -C build install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 ./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
120
121 #%find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %update_desktop_database_post
128
129 %postun
130 %update_desktop_database_postun
131
132 %files
133 %defattr(644,root,root,755)
134 # -f %{name}.lang
135 %doc doc/license/bf-members.txt doc/guides/*.txt
136 %attr(755,root,root) %{_bindir}/blender
137 %attr(755,root,root) %{_bindir}/blender-thumbnailer.py
138 %attr(755,root,root) %{_datadir}/%{name}
139 %{_desktopdir}/*.desktop
140 %{_iconsdir}/hicolor/scalable/apps/blender.svg
141 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
142 %{_mandir}/man1/*
This page took 0.079585 seconds and 3 git commands to generate.