]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- x32 builds with default setting again
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.82a
8 Release:        2
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.xz
12 # Source0-md5:  3e9d669185b83d5d2cb1b38dcf64d5ec
13 Patch0:         %{name}-2.76-droid.patch
14 Patch1:         format-security.patch
15 URL:            http://www.blender.org/
16 BuildRequires:  OpenAL-devel
17 BuildRequires:  OpenColorIO-devel
18 BuildRequires:  OpenEXR-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  OpenImageIO-devel
22 BuildRequires:  SDL2-devel
23 BuildRequires:  boost-devel
24 BuildRequires:  cmake
25 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
26 BuildRequires:  fftw3-devel
27 BuildRequires:  freealut-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  ftgl-devel
30 BuildRequires:  gcc >= 5:3.4.0
31 BuildRequires:  gettext-tools
32 BuildRequires:  glew-devel
33 BuildRequires:  jack-audio-connection-kit-devel
34 BuildRequires:  jemalloc-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libsndfile-devel
38 BuildRequires:  libspnav-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  openjpeg2-devel
44 BuildRequires:  openssl-devel >= 0.9.7d
45 BuildRequires:  pugixml-devel
46 BuildRequires:  python3
47 BuildRequires:  python3-devel
48 BuildRequires:  python3-numpy-devel
49 BuildRequires:  rpm-pythonprov
50 BuildRequires:  rpmbuild(macros) >= 1.385
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  xorg-lib-libXi-devel
53 BuildRequires:  zlib-devel
54 Requires(post,postun):  desktop-file-utils
55 Requires:       OpenGL
56 Requires:       freetype
57 Requires:       python3-modules
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
61
62 %description
63 Blender is a free and fully functional 3D modeling, rendering,
64 animation and game creation package for Unix, Windows and BeOS
65 systems.
66
67 %description -l pl.UTF-8
68 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
69 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75
76 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
77       release/bin/blender-thumbnailer.py \
78       release/scripts/addons/io_curve_svg/svg_util_test.py \
79       release/scripts/addons/io_scene_fbx/fbx2json.py \
80       release/scripts/addons/io_scene_fbx/json2fbx.py \
81       release/scripts/addons/sun_position/geo.py \
82       release/scripts/modules/bl_i18n_utils/merge_po.py \
83       release/scripts/modules/bl_i18n_utils/utils_rtl.py \
84       release/scripts/modules/blend_render_info.py
85
86 %build
87 install -d build
88 cd build
89 %cmake \
90         -DCMAKE_SKIP_RPATH:BOOL=ON \
91         -DBUILD_SHARED_LIBS:BOOL=OFF \
92         -DWITH_FFTW3:BOOL=ON \
93         -DWITH_JACK:BOOL=ON \
94         -DWITH_JACK_DYNLOAD:BOOL=ON \
95         -DWITH_CODEC_SNDFILE:BOOL=ON \
96         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
97         -DWITH_OPENCOLLADA:BOOL=ON \
98         -DWITH_OPENCOLORIO:BOOL=ON \
99         -DWITH_CYCLES:BOOL=ON \
100         -DWITH_FFTW3:BOOL=ON \
101         -DWITH_MOD_OCEANSIM:BOOL=ON \
102         -DOPENCOLLADA=%{_includedir} \
103         -DWITH_PYTHON:BOOL=ON \
104         -DPYTHON_VERSION:STRING=%{py3_ver} \
105         -DWITH_PYTHON_INSTALL:BOOL=OFF \
106         -DWITH_CODEC_FFMPEG:BOOL=ON \
107         -DWITH_GAMEENGINE:BOOL=ON \
108         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
109         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
110         -DWITH_PYTHON_SAFETY:BOOL=ON \
111         -DWITH_PLAYER:BOOL=ON \
112         -DWITH_MEM_JEMALLOC:BOOL=ON \
113         -DWITH_SYSTEM_GLEW:BOOL=ON \
114         -DBOOST_ROOT=%{_prefix} \
115         -DWITH_INPUT_NDOF:BOOL=ON \
116         -DWITH_SDL:BOOL=ON \
117         -DWITH_SDL_DYNLOAD:BOOL=ON \
118         ..
119
120 %{__make} V=1
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
126
127 %{__make} -C build install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 ./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
131
132 #%find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 %update_desktop_database_post
139
140 %postun
141 %update_desktop_database_postun
142
143 %files
144 %defattr(644,root,root,755)
145 # -f %{name}.lang
146 %doc doc/license/bf-members.txt doc/guides/*.txt
147 %attr(755,root,root) %{_bindir}/blender
148 %attr(755,root,root) %{_bindir}/blender-thumbnailer.py
149 %attr(755,root,root) %{_datadir}/%{name}
150 %{_desktopdir}/*.desktop
151 %{_iconsdir}/hicolor/scalable/apps/blender.svg
152 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
153 %{_mandir}/man1/*
This page took 0.062533 seconds and 3 git commands to generate.