]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
33ee41488ffb7e92b35bdd022e10040d9ed4694a
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.80
8 Release:        3
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  30dedaf688741d0d5d6fa1e3c331610c
13 Patch0:         %{name}-2.76-droid.patch
14 Patch1:         format-security.patch
15 Patch2:         python-3.8.patch
16 URL:            http://www.blender.org/
17 BuildRequires:  OpenAL-devel
18 BuildRequires:  OpenColorIO-devel
19 BuildRequires:  OpenEXR-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  OpenImageIO-devel
23 BuildRequires:  SDL2-devel
24 BuildRequires:  boost-devel
25 BuildRequires:  cmake
26 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
27 BuildRequires:  fftw3-devel
28 BuildRequires:  freealut-devel
29 BuildRequires:  freetype-devel
30 BuildRequires:  ftgl-devel
31 BuildRequires:  gcc >= 5:3.4.0
32 BuildRequires:  gettext-tools
33 BuildRequires:  glew-devel
34 BuildRequires:  jack-audio-connection-kit-devel
35 BuildRequires:  jemalloc-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libsndfile-devel
39 BuildRequires:  libspnav-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 BuildRequires:  libtool
43 BuildRequires:  libvorbis-devel
44 BuildRequires:  openjpeg2-devel
45 BuildRequires:  openssl-devel >= 0.9.7d
46 BuildRequires:  pugixml-devel
47 BuildRequires:  python3
48 BuildRequires:  python3-devel
49 BuildRequires:  python3-numpy-devel
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.385
52 BuildRequires:  sed >= 4.0
53 BuildRequires:  xorg-lib-libXi-devel
54 BuildRequires:  zlib-devel
55 Requires(post,postun):  desktop-file-utils
56 Requires:       OpenGL
57 Requires:       freetype
58 Requires:       python-modules
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
62
63 %description
64 Blender is a free and fully functional 3D modeling, rendering,
65 animation and game creation package for Unix, Windows and BeOS
66 systems.
67
68 %description -l pl.UTF-8
69 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
70 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p1
77
78 %build
79 install -d build
80 cd build
81 %cmake \
82         -DCMAKE_SKIP_RPATH:BOOL=ON \
83         -DBUILD_SHARED_LIBS:BOOL=OFF \
84         -DWITH_FFTW3:BOOL=ON \
85         -DWITH_JACK:BOOL=ON \
86         -DWITH_JACK_DYNLOAD:BOOL=ON \
87         -DWITH_CODEC_SNDFILE:BOOL=ON \
88         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
89         -DWITH_OPENCOLLADA:BOOL=ON \
90         -DWITH_OPENCOLORIO:BOOL=ON \
91         -DWITH_CYCLES:BOOL=ON \
92         -DWITH_FFTW3:BOOL=ON \
93         -DWITH_MOD_OCEANSIM:BOOL=ON \
94         -DOPENCOLLADA=%{_includedir} \
95         -DWITH_PYTHON:BOOL=ON \
96         -DPYTHON_VERSION:STRING=%{py3_ver} \
97         -DWITH_PYTHON_INSTALL:BOOL=OFF \
98         -DWITH_CODEC_FFMPEG:BOOL=ON \
99         -DWITH_GAMEENGINE:BOOL=ON \
100         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
101         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
102         -DWITH_PYTHON_SAFETY:BOOL=ON \
103         -DWITH_PLAYER:BOOL=ON \
104         -DWITH_MEM_JEMALLOC:BOOL=ON \
105         -DWITH_SYSTEM_GLEW:BOOL=ON \
106         -DBOOST_ROOT=%{_prefix} \
107         -DWITH_INPUT_NDOF:BOOL=ON \
108         -DWITH_SDL:BOOL=ON \
109         -DWITH_SDL_DYNLOAD:BOOL=ON \
110         ..
111
112 %{__make} V=1
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
118
119 %{__make} -C build install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 ./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
123
124 #%find_lang %{name}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 %update_desktop_database_post
131
132 %postun
133 %update_desktop_database_postun
134
135 %files
136 %defattr(644,root,root,755)
137 # -f %{name}.lang
138 %doc doc/license/bf-members.txt doc/guides/*.txt
139 %attr(755,root,root) %{_bindir}/blender
140 %attr(755,root,root) %{_bindir}/blender-thumbnailer.py
141 %attr(755,root,root) %{_datadir}/%{name}
142 %{_desktopdir}/*.desktop
143 %{_iconsdir}/hicolor/scalable/apps/blender.svg
144 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
145 %{_mandir}/man1/*
This page took 0.041249 seconds and 2 git commands to generate.