]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- add OpenImageIO 2 build fix from fedora
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.79b
8 Release:        3
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  cef9a203857dc65076e05c41fc7a7d03
13 Source1:        %{name}.desktop
14 Source2:        %{name}.png
15 Source3:        %{name}.manpage
16 Patch0:         %{name}-2.76-droid.patch
17 Patch1:         ffmpeg4.patch
18 Patch2:         gcc8.patch
19 Patch3:         oiio2.patch
20 URL:            http://www.blender.org/
21 BuildRequires:  OpenAL-devel
22 BuildRequires:  OpenEXR-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  OpenImageIO-devel
25 BuildRequires:  SDL2-devel
26 BuildRequires:  cmake
27 #BuildRequires: esound-devel
28 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
29 BuildRequires:  freealut-devel
30 BuildRequires:  freetype-devel
31 BuildRequires:  ftgl-devel
32 BuildRequires:  gcc >= 5:3.4.0
33 BuildRequires:  gettext-tools
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  libtool
39 BuildRequires:  libvorbis-devel
40 BuildRequires:  openssl-devel >= 0.9.7d
41 BuildRequires:  python3-devel
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.385
44 BuildRequires:  sed >= 4.0
45 #BuildRequires: smpeg-devel
46 BuildRequires:  xorg-lib-libXi-devel
47 BuildRequires:  zlib-devel
48 Requires(post,postun):  desktop-file-utils
49 Requires:       OpenGL
50 Requires:       freetype
51 Requires:       python-modules
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
55
56 %description
57 Blender is a free and fully functional 3D modeling, rendering,
58 animation and game creation package for Unix, Windows and BeOS
59 systems.
60
61 %description -l pl.UTF-8
62 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
63 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %patch3 -p1
71
72 %build
73 install -d build
74 cd build
75 %cmake \
76         -DCMAKE_SKIP_RPATH=ON \
77         -DBUILD_SHARED_LIBS=OFF \
78         -DWITH_FFTW3:BOOL=ON \
79         -DWITH_JACK:BOOL=ON \
80         -DWITH_CODEC_SNDFILE:BOOL=ON \
81         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
82         -DWITH_OPENCOLLADA:BOOL=ON \
83         -DWITH_CYCLES:BOOL=ON \
84         -DWITH_FFTW3:BOOL=ON \
85         -DWITH_MOD_OCEANSIM:BOOL=ON \
86         -DOPENCOLLADA=%{_includedir} \
87         -DWITH_PYTHON:BOOL=ON \
88         -DPYTHON_VERSION:STRING=%{py3_ver} \
89         -DWITH_PYTHON_INSTALL:BOOL=OFF \
90         -DWITH_CODEC_FFMPEG:BOOL=ON \
91         -DWITH_GAMEENGINE:BOOL=ON \
92         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
93         -DWITH_BUILTIN_GLEW=OFF \
94         -DWITH_INSTALL_PORTABLE=OFF \
95         -DWITH_PYTHON_SAFETY=ON \
96         -DWITH_PLAYER=ON \
97         -DWITH_MEM_JEMALLOC=ON \
98         -DBOOST_ROOT=%{_prefix} \
99         -DWITH_INPUT_NDOF=ON \
100         -DWITH_SDL:BOOL=ON \
101         ..
102
103 %{__make} V=1
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
109
110 %{__make} -C build install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
114 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
115 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
116
117 #%find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 %update_desktop_database_post
124
125 %postun
126 %update_desktop_database_postun
127
128 %files
129 %defattr(644,root,root,755)
130 # -f %{name}.lang
131 %doc doc/license/bf-members.txt doc/guides/*.txt
132 %attr(755,root,root) %{_bindir}/blender
133 %attr(755,root,root) %{_bindir}/blender-thumbnailer.py
134 %attr(755,root,root) %{_bindir}/blenderplayer
135 %attr(755,root,root) %{_datadir}/%{name}
136 %{_desktopdir}/*.desktop
137 %{_pixmapsdir}/*.png
138 %{_iconsdir}/*/*x*/apps/blender.png
139 %{_iconsdir}/*/scalable/apps/blender.svg
140 %{_mandir}/man1/*
This page took 0.071541 seconds and 3 git commands to generate.