]> git.pld-linux.org Git - packages/blender.git/blame_incremental - blender.spec
boost rebuild
[packages/blender.git] / blender.spec
... / ...
CommitLineData
1# TODO:
2# - enable internalization support (BR libftgl)
3# - libsolid/libqhull/libode BR ?
4Summary: 3D modeling, rendering, animation and game creation package
5Summary(pl.UTF-8): Pakiet do tworzenia animacji 3D oraz gier
6Name: blender
7Version: 2.83.12
8Release: 2
9License: GPL
10Group: X11/Applications/Graphics
11Source0: http://download.blender.org/source/%{name}-%{version}.tar.xz
12# Source0-md5: 6c890dfb3599bffed5edc05d43f61506
13Patch0: %{name}-2.76-droid.patch
14Patch1: format-security.patch
15Patch2: 0006-fix_FTBFS_with_python3.9.patch
16URL: http://www.blender.org/
17BuildRequires: OpenAL-devel
18BuildRequires: OpenColorIO-devel
19BuildRequires: OpenEXR-devel
20BuildRequires: OpenGL-devel
21BuildRequires: OpenGL-GLU-devel
22BuildRequires: OpenImageIO-devel
23BuildRequires: SDL2-devel
24BuildRequires: boost-devel
25BuildRequires: cmake
26BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
27BuildRequires: fftw3-devel
28BuildRequires: freealut-devel
29BuildRequires: freetype-devel
30BuildRequires: ftgl-devel
31BuildRequires: gcc >= 5:3.4.0
32BuildRequires: gettext-tools
33BuildRequires: glew-devel
34BuildRequires: jack-audio-connection-kit-devel
35BuildRequires: jemalloc-devel
36BuildRequires: libjpeg-devel
37BuildRequires: libpng-devel
38BuildRequires: libsndfile-devel
39BuildRequires: libspnav-devel
40BuildRequires: libstdc++-devel
41BuildRequires: libtiff-devel
42BuildRequires: libtool
43BuildRequires: libvorbis-devel
44BuildRequires: openjpeg2-devel
45BuildRequires: openssl-devel >= 0.9.7d
46BuildRequires: pugixml-devel
47BuildRequires: python3
48BuildRequires: python3-devel
49BuildRequires: python3-numpy-devel
50BuildRequires: rpm-pythonprov
51BuildRequires: rpmbuild(macros) >= 1.385
52BuildRequires: sed >= 4.0
53BuildRequires: xorg-lib-libXi-devel
54BuildRequires: zlib-devel
55Requires(post,postun): desktop-file-utils
56Requires: OpenGL
57Requires: freetype
58Requires: python3-modules
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%define _noautoreqdep libGL.so.1 libGLU.so.1
62
63%description
64Blender is a free and fully functional 3D modeling, rendering,
65animation and game creation package for Unix, Windows and BeOS
66systems.
67
68%description -l pl.UTF-8
69Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
703D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
71
72%prep
73%setup -q
74%patch0 -p1
75%patch1 -p1
76%patch2 -p1
77
78%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
79 release/bin/blender-thumbnailer.py \
80 release/scripts/addons/io_curve_svg/svg_util_test.py \
81 release/scripts/addons/io_scene_fbx/fbx2json.py \
82 release/scripts/addons/io_scene_fbx/json2fbx.py \
83 release/scripts/addons/sun_position/geo.py \
84 release/scripts/modules/bl_i18n_utils/merge_po.py \
85 release/scripts/modules/bl_i18n_utils/utils_rtl.py \
86 release/scripts/modules/blend_render_info.py
87
88%build
89install -d build
90cd build
91%cmake \
92 -DCMAKE_SKIP_RPATH:BOOL=ON \
93 -DBUILD_SHARED_LIBS:BOOL=OFF \
94 -DWITH_FFTW3:BOOL=ON \
95 -DWITH_JACK:BOOL=ON \
96 -DWITH_JACK_DYNLOAD:BOOL=ON \
97 -DWITH_CODEC_SNDFILE:BOOL=ON \
98 -DWITH_IMAGE_OPENJPEG:BOOL=ON \
99 -DWITH_OPENCOLLADA:BOOL=ON \
100 -DWITH_OPENCOLORIO:BOOL=ON \
101 -DWITH_CYCLES:BOOL=ON \
102 -DWITH_FFTW3:BOOL=ON \
103 -DWITH_MOD_OCEANSIM:BOOL=ON \
104 -DOPENCOLLADA=%{_includedir} \
105 -DWITH_PYTHON:BOOL=ON \
106 -DPYTHON_VERSION:STRING=%{py3_ver} \
107 -DWITH_PYTHON_INSTALL:BOOL=OFF \
108 -DWITH_CODEC_FFMPEG:BOOL=ON \
109 -DWITH_GAMEENGINE:BOOL=ON \
110 -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
111 -DWITH_INSTALL_PORTABLE:BOOL=OFF \
112 -DWITH_PYTHON_SAFETY:BOOL=ON \
113 -DWITH_PLAYER:BOOL=ON \
114 -DWITH_MEM_JEMALLOC:BOOL=ON \
115 -DWITH_SYSTEM_GLEW:BOOL=ON \
116 -DBOOST_ROOT=%{_prefix} \
117 -DWITH_INPUT_NDOF:BOOL=ON \
118 -DWITH_SDL:BOOL=ON \
119 -DWITH_SDL_DYNLOAD:BOOL=ON \
120 ..
121
122%{__make} V=1
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
128
129%{__make} -C build install \
130 DESTDIR=$RPM_BUILD_ROOT
131
132./doc/manpage/blender.1.py $RPM_BUILD_ROOT%{_bindir}/blender $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
133
134#%find_lang %{name}
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post
140%update_desktop_database_post
141
142%postun
143%update_desktop_database_postun
144
145%files
146%defattr(644,root,root,755)
147# -f %{name}.lang
148%doc doc/license/bf-members.txt doc/guides/*.txt
149%attr(755,root,root) %{_bindir}/blender
150%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
151%attr(755,root,root) %{_datadir}/%{name}
152%{_desktopdir}/*.desktop
153%{_iconsdir}/hicolor/scalable/apps/blender.svg
154%{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
155%{_mandir}/man1/*
This page took 0.068939 seconds and 4 git commands to generate.