]> git.pld-linux.org Git - packages/blender.git/blame - blender.spec
- fix building with gcc 8
[packages/blender.git] / blender.spec
CommitLineData
38c09fc8
AF
1# TODO:
2# - enable internalization support (BR libftgl)
38c09fc8 3# - libsolid/libqhull/libode BR ?
4d72b1dc 4Summary: 3D modeling, rendering, animation and game creation package
3701d8b9 5Summary(pl.UTF-8): Pakiet do tworzenia animacji 3D oraz gier
4d72b1dc 6Name: blender
1f75c4ee 7Version: 2.79b
bfa95822 8Release: 2
d2866530 9License: GPL
10Group: X11/Applications/Graphics
e9e23885 11Source0: http://download.blender.org/source/%{name}-%{version}.tar.gz
1f75c4ee 12# Source0-md5: cef9a203857dc65076e05c41fc7a7d03
dfc2b368 13Source1: %{name}.desktop
14Source2: %{name}.png
490622c7 15Source3: %{name}.manpage
6cb9e722 16Patch0: %{name}-2.76-droid.patch
061abd18 17Patch1: ffmpeg4.patch
bfa95822 18Patch2: gcc8.patch
b98aa62c 19URL: http://www.blender.org/
126ba6ff 20BuildRequires: OpenAL-devel
ef63d3ab 21BuildRequires: OpenEXR-devel
9605d1bf 22BuildRequires: OpenGL-devel
6cb9e722 23BuildRequires: OpenImageIO-devel
490622c7 24BuildRequires: SDL2-devel
6cb9e722 25BuildRequires: cmake
126ba6ff 26#BuildRequires: esound-devel
8de72679 27BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
fdc7d606 28BuildRequires: freealut-devel
7bc683ce 29BuildRequires: freetype-devel
f313c0b5 30BuildRequires: ftgl-devel
126ba6ff 31BuildRequires: gcc >= 5:3.4.0
88d42750 32BuildRequires: gettext-tools
9605d1bf 33BuildRequires: libjpeg-devel
34BuildRequires: libpng-devel
dfc2b368 35BuildRequires: libstdc++-devel
fdc7d606 36BuildRequires: libtiff-devel
ff884909 37BuildRequires: libtool
dfc2b368 38BuildRequires: libvorbis-devel
2a53466d 39BuildRequires: openssl-devel >= 0.9.7d
490622c7 40BuildRequires: python3-devel
08055d90 41BuildRequires: rpm-pythonprov
97c2fd28 42BuildRequires: rpmbuild(macros) >= 1.385
dd78d76e 43BuildRequires: sed >= 4.0
42794eef 44#BuildRequires: smpeg-devel
4d805379 45BuildRequires: xorg-lib-libXi-devel
9605d1bf 46BuildRequires: zlib-devel
97c2fd28 47Requires(post,postun): desktop-file-utils
ff884909 48Requires: OpenGL
7bc683ce 49Requires: freetype
2c0478d0 50Requires: python-modules
4d72b1dc
JK
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
b1097d8e 53%define _noautoreqdep libGL.so.1 libGLU.so.1
4d72b1dc
JK
54
55%description
56Blender is a free and fully functional 3D modeling, rendering,
57animation and game creation package for Unix, Windows and BeOS
9071f685 58systems.
4d72b1dc 59
d3ad026c
JR
60%description -l pl.UTF-8
61Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
623D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
4d72b1dc
JK
63
64%prep
811f0f5d 65%setup -q
a374ab50 66%patch0 -p1
061abd18 67%patch1 -p1
bfa95822 68%patch2 -p1
4d72b1dc 69
c3538bdb 70%build
490622c7
AM
71install -d build
72cd build
73%cmake \
74 -DCMAKE_SKIP_RPATH=ON \
75 -DBUILD_SHARED_LIBS=OFF \
76 -DWITH_FFTW3:BOOL=ON \
77 -DWITH_JACK:BOOL=ON \
78 -DWITH_CODEC_SNDFILE:BOOL=ON \
79 -DWITH_IMAGE_OPENJPEG:BOOL=ON \
80 -DWITH_OPENCOLLADA:BOOL=ON \
81 -DWITH_CYCLES:BOOL=ON \
82 -DWITH_FFTW3:BOOL=ON \
83 -DWITH_MOD_OCEANSIM:BOOL=ON \
84 -DOPENCOLLADA=%{_includedir} \
85 -DWITH_PYTHON:BOOL=ON \
86 -DPYTHON_VERSION:STRING=%{py3_ver} \
87 -DWITH_PYTHON_INSTALL:BOOL=OFF \
88 -DWITH_CODEC_FFMPEG:BOOL=ON \
89 -DWITH_GAMEENGINE:BOOL=ON \
90 -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
91 -DWITH_BUILTIN_GLEW=OFF \
92 -DWITH_INSTALL_PORTABLE=OFF \
93 -DWITH_PYTHON_SAFETY=ON \
94 -DWITH_PLAYER=ON \
95 -DWITH_MEM_JEMALLOC=ON \
96 -DBOOST_ROOT=%{_prefix} \
97 -DWITH_INPUT_NDOF=ON \
98 -DWITH_SDL:BOOL=ON \
99 ..
100
101%{__make} V=1
aeb8eec7 102
4d72b1dc
JK
103%install
104rm -rf $RPM_BUILD_ROOT
dfc2b368 105
490622c7
AM
106install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
107
108%{__make} -C build install \
109 DESTDIR=$RPM_BUILD_ROOT
110
6cb9e722
AM
111cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
112cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
113cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
7bc683ce 114
490622c7 115#%find_lang %{name}
3e6b0a09 116
4d72b1dc
JK
117%clean
118rm -rf $RPM_BUILD_ROOT
119
97c2fd28
MB
120%post
121%update_desktop_database_post
122
123%postun
124%update_desktop_database_postun
125
490622c7 126%files
4d72b1dc 127%defattr(644,root,root,755)
6cb9e722 128# -f %{name}.lang
490622c7
AM
129%doc doc/license/bf-members.txt doc/guides/*.txt
130%attr(755,root,root) %{_bindir}/blender
131%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
132%attr(755,root,root) %{_bindir}/blenderplayer
961f6430 133%attr(755,root,root) %{_datadir}/%{name}
98471f49 134%{_desktopdir}/*.desktop
135%{_pixmapsdir}/*.png
490622c7
AM
136%{_iconsdir}/*/*x*/apps/blender.png
137%{_iconsdir}/*/scalable/apps/blender.svg
b643ae44 138%{_mandir}/man1/*
This page took 0.208146 seconds and 4 git commands to generate.