]> git.pld-linux.org Git - packages/blender.git/blame - blender.spec
- add OpenImageIO 2 build fix from fedora
[packages/blender.git] / blender.spec
CommitLineData
38c09fc8
AF
1# TODO:
2# - enable internalization support (BR libftgl)
38c09fc8 3# - libsolid/libqhull/libode BR ?
4d72b1dc 4Summary: 3D modeling, rendering, animation and game creation package
3701d8b9 5Summary(pl.UTF-8): Pakiet do tworzenia animacji 3D oraz gier
4d72b1dc 6Name: blender
1f75c4ee 7Version: 2.79b
3adce530 8Release: 3
d2866530 9License: GPL
10Group: X11/Applications/Graphics
e9e23885 11Source0: http://download.blender.org/source/%{name}-%{version}.tar.gz
1f75c4ee 12# Source0-md5: cef9a203857dc65076e05c41fc7a7d03
dfc2b368 13Source1: %{name}.desktop
14Source2: %{name}.png
490622c7 15Source3: %{name}.manpage
6cb9e722 16Patch0: %{name}-2.76-droid.patch
061abd18 17Patch1: ffmpeg4.patch
bfa95822 18Patch2: gcc8.patch
3adce530 19Patch3: oiio2.patch
b98aa62c 20URL: http://www.blender.org/
126ba6ff 21BuildRequires: OpenAL-devel
ef63d3ab 22BuildRequires: OpenEXR-devel
9605d1bf 23BuildRequires: OpenGL-devel
6cb9e722 24BuildRequires: OpenImageIO-devel
490622c7 25BuildRequires: SDL2-devel
6cb9e722 26BuildRequires: cmake
126ba6ff 27#BuildRequires: esound-devel
8de72679 28BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
fdc7d606 29BuildRequires: freealut-devel
7bc683ce 30BuildRequires: freetype-devel
f313c0b5 31BuildRequires: ftgl-devel
126ba6ff 32BuildRequires: gcc >= 5:3.4.0
88d42750 33BuildRequires: gettext-tools
9605d1bf 34BuildRequires: libjpeg-devel
35BuildRequires: libpng-devel
dfc2b368 36BuildRequires: libstdc++-devel
fdc7d606 37BuildRequires: libtiff-devel
ff884909 38BuildRequires: libtool
dfc2b368 39BuildRequires: libvorbis-devel
2a53466d 40BuildRequires: openssl-devel >= 0.9.7d
490622c7 41BuildRequires: python3-devel
08055d90 42BuildRequires: rpm-pythonprov
97c2fd28 43BuildRequires: rpmbuild(macros) >= 1.385
dd78d76e 44BuildRequires: sed >= 4.0
42794eef 45#BuildRequires: smpeg-devel
4d805379 46BuildRequires: xorg-lib-libXi-devel
9605d1bf 47BuildRequires: zlib-devel
97c2fd28 48Requires(post,postun): desktop-file-utils
ff884909 49Requires: OpenGL
7bc683ce 50Requires: freetype
2c0478d0 51Requires: python-modules
4d72b1dc
JK
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
b1097d8e 54%define _noautoreqdep libGL.so.1 libGLU.so.1
4d72b1dc
JK
55
56%description
57Blender is a free and fully functional 3D modeling, rendering,
58animation and game creation package for Unix, Windows and BeOS
9071f685 59systems.
4d72b1dc 60
d3ad026c
JR
61%description -l pl.UTF-8
62Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
633D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
4d72b1dc
JK
64
65%prep
811f0f5d 66%setup -q
a374ab50 67%patch0 -p1
061abd18 68%patch1 -p1
bfa95822 69%patch2 -p1
3adce530 70%patch3 -p1
4d72b1dc 71
c3538bdb 72%build
490622c7
AM
73install -d build
74cd build
75%cmake \
76 -DCMAKE_SKIP_RPATH=ON \
77 -DBUILD_SHARED_LIBS=OFF \
78 -DWITH_FFTW3:BOOL=ON \
79 -DWITH_JACK:BOOL=ON \
80 -DWITH_CODEC_SNDFILE:BOOL=ON \
81 -DWITH_IMAGE_OPENJPEG:BOOL=ON \
82 -DWITH_OPENCOLLADA:BOOL=ON \
83 -DWITH_CYCLES:BOOL=ON \
84 -DWITH_FFTW3:BOOL=ON \
85 -DWITH_MOD_OCEANSIM:BOOL=ON \
86 -DOPENCOLLADA=%{_includedir} \
87 -DWITH_PYTHON:BOOL=ON \
88 -DPYTHON_VERSION:STRING=%{py3_ver} \
89 -DWITH_PYTHON_INSTALL:BOOL=OFF \
90 -DWITH_CODEC_FFMPEG:BOOL=ON \
91 -DWITH_GAMEENGINE:BOOL=ON \
92 -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
93 -DWITH_BUILTIN_GLEW=OFF \
94 -DWITH_INSTALL_PORTABLE=OFF \
95 -DWITH_PYTHON_SAFETY=ON \
96 -DWITH_PLAYER=ON \
97 -DWITH_MEM_JEMALLOC=ON \
98 -DBOOST_ROOT=%{_prefix} \
99 -DWITH_INPUT_NDOF=ON \
100 -DWITH_SDL:BOOL=ON \
101 ..
102
103%{__make} V=1
aeb8eec7 104
4d72b1dc
JK
105%install
106rm -rf $RPM_BUILD_ROOT
dfc2b368 107
490622c7
AM
108install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
109
110%{__make} -C build install \
111 DESTDIR=$RPM_BUILD_ROOT
112
6cb9e722
AM
113cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
114cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
115cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
7bc683ce 116
490622c7 117#%find_lang %{name}
3e6b0a09 118
4d72b1dc
JK
119%clean
120rm -rf $RPM_BUILD_ROOT
121
97c2fd28
MB
122%post
123%update_desktop_database_post
124
125%postun
126%update_desktop_database_postun
127
490622c7 128%files
4d72b1dc 129%defattr(644,root,root,755)
6cb9e722 130# -f %{name}.lang
490622c7
AM
131%doc doc/license/bf-members.txt doc/guides/*.txt
132%attr(755,root,root) %{_bindir}/blender
133%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
134%attr(755,root,root) %{_bindir}/blenderplayer
961f6430 135%attr(755,root,root) %{_datadir}/%{name}
98471f49 136%{_desktopdir}/*.desktop
137%{_pixmapsdir}/*.png
490622c7
AM
138%{_iconsdir}/*/*x*/apps/blender.png
139%{_iconsdir}/*/scalable/apps/blender.svg
b643ae44 140%{_mandir}/man1/*
This page took 0.130328 seconds and 4 git commands to generate.