]> git.pld-linux.org Git - packages/bladeenc.git/commitdiff
- added fseek-sec patch (arbitrary code execution through wave file) STABLE bladeenc-0_94_2-4
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 3 Feb 2003 21:01:23 +0000 (21:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 4, STBR to ra/updates/security

Changed files:
    bladeenc-fseek-sec.patch -> 1.1
    bladeenc.spec -> 1.37

bladeenc-fseek-sec.patch [new file with mode: 0644]
bladeenc.spec

diff --git a/bladeenc-fseek-sec.patch b/bladeenc-fseek-sec.patch
new file mode 100644 (file)
index 0000000..e04e4c2
--- /dev/null
@@ -0,0 +1,29 @@
+--- bladeenc-0.94.2/bladeenc/samplein.c.orig   Tue May  8 14:11:53 2001
++++ bladeenc-0.94.2/bladeenc/samplein.c        Mon Feb  3 20:47:55 2003
+@@ -75,7 +75,7 @@
+ static        int                             initAIFF (SI_Stream *psInfo);
+ static        uint                    readAIFFSamples (SI_Stream *psInfo, int nSamples, short *wpSamples);
+-static        int                             myFseek (FILE *fp, int offset);
++static        int                             myFseek (FILE *fp, unsigned int offset);
+@@ -332,6 +332,8 @@
+               {
+                       if (fread (aTemp, sizeof(sFmtChunk), 1, psInfo->fp) != 1)
+                               goto unexpEndOfFile;
++                      if (intlLong(&header[4]) < sizeof(sFmtChunk))
++                              goto unexpEndOfFile; /* I can't find "corrupted file" error code */
+                       myFseek (psInfo->fp, intlLong(&header[4]) - sizeof(sFmtChunk));
+                       fFmtChunkFound = TRUE;
+               }
+@@ -613,7 +615,7 @@
+ /* We can't use the real fseek() since you can't seek in a stream (stdin) */
+-static int                                    myFseek (FILE *fp, int offset)
++static int                                    myFseek (FILE *fp, unsigned int offset)
+ {
+       char                                    dummy[256];
index 14d7aefd801dd607f0f3bde5cd19406a489c9150..e5bb53790a9e747ecbc039c0040584a2a084a502 100644 (file)
@@ -1,13 +1,14 @@
 Summary:       Blade's MP3 Encoder
-Summary(pl):   Encoder MP3 Blade'a
+Summary(pl):   Koder MP3 Blade'a
 Name:          bladeenc
 Version:       0.94.2
-Release:       3
+Release:       4
 Epoch:         1
 License:       GPL
 Vendor:                Tord Jansson <tord.jansson@swipnet.se>
 Group:         Applications/Sound
 Source0:       http://bladeenc.mp3.no/source/%{name}-%{version}-src-stable.tar.gz
+Patch0:                %{name}-fseek-sec.patch
 URL:           http://bladeenc.mp3.no/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -24,6 +25,7 @@ d
 
 %prep
 %setup -q
+%patch -p1
 
 %build
 %{__aclocal}
This page took 0.132993 seconds and 4 git commands to generate.