]> git.pld-linux.org Git - packages/bkchem.git/commitdiff
- initital pld version partialy based on mdk spec
authorundefine <undefine@pld-linux.org>
Sat, 2 Oct 2004 22:26:14 +0000 (22:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bkchem.spec -> 1.1

bkchem.spec [new file with mode: 0644]

diff --git a/bkchem.spec b/bkchem.spec
new file mode 100644 (file)
index 0000000..3e24d3c
--- /dev/null
@@ -0,0 +1,66 @@
+# TODO:
+# - pl description
+# - desktop file
+%define                pre     pre2
+Summary:       Python 2D chemical structure drawing tool
+Summary(pl):   Narzêdzie do rysowania 2D struktur chemicznych
+Name:          bkchem
+Version:       0.8.0
+Release:       0.%{pre}.1
+Source0:       http://zirael.org/bkchem/download/%{name}-%{version}-pre2.tar.gz
+# Source0-md5: 8280cc1a8b675252b90d565cbf73cc0f
+URL:           http://zirael.org/bkchem/index.html
+License:       GPL
+Group:         X11/Applications/Science
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: python-devel
+Requires:      python
+Requires:      Pmw
+Requires:      python-PyXML
+Buildarch:     noarch
+
+%description
+BKchem is a free (as in free software :o) chemical drawing program. It
+was concieved and written by Beda Kosata. Supported file formats are
+SVG and CML. The output looks best with the Adobe SVG viewer, but
+sodipodi and batik do a reasonable job as well.
+
+%prep
+%setup -q -n %{name}-%{version}-%{pre}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+python setup.py install \
+       --root=$RPM_BUILD_ROOT \
+       --optimize=2
+
+#fix executable
+sed -e "s@$RPM_BUILD_ROOT@@g" $RPM_BUILD_ROOT%{_bindir}/%{name} |\
+       sed -e "s@%{name}.py@%{name}.pyo@g" >$RPM_BUILD_ROOT%{_bindir}/%{name}.new
+mv $RPM_BUILD_ROOT%{_bindir}/%{name}.new $RPM_BUILD_ROOT%{_bindir}/%{name}
+
+%find_lang BKchem
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files -f BKchem.lang
+%defattr(644,root,root,755)
+%doc README RELEASE doc/html
+%attr(755,root,root) %{_bindir}/%{name}
+%{_datadir}/%{name}
+%dir %{py_sitescriptdir}/%{name}
+%{py_sitescriptdir}/%{name}/*.py[co]
+%{py_sitescriptdir}/%{name}/%{name}.py
+%dir %{py_sitescriptdir}/%{name}/plugins
+%{py_sitescriptdir}/%{name}/plugins/*.py[co]
+%dir %{py_sitescriptdir}/%{name}/oasa
+%{py_sitescriptdir}/%{name}/oasa/*.py[co]
+%dir %{py_sitescriptdir}/%{name}/oasa/oasa/graph
+%{py_sitescriptdir}/%{name}/oasa/oasa/graph/*.py[co]
+%dir %{py_sitescriptdir}/%{name}/oasa/oasa
+%{py_sitescriptdir}/%{name}/oasa/oasa/*.py[co]
This page took 0.049946 seconds and 4 git commands to generate.