]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
- bcond header
[packages/bison.git] / bison.spec
1 Summary:        A GNU general-purpose parser generator
2 Summary(de.UTF-8):      GNU-Parser-Generator
3 Summary(es.UTF-8):      Generador de parser de la GNU
4 Summary(fr.UTF-8):      Générateur d'analyseur lexical de GNU
5 Summary(pl.UTF-8):      GNU generator składni
6 Summary(pt_BR.UTF-8):   Gerador de parser da GNU
7 Summary(ru.UTF-8):      Bison - генератор парсеров GNU
8 Summary(tr.UTF-8):      GNU ayrıştırıcı üreticisi
9 Summary(uk.UTF-8):      Bison - генератор парсерів GNU
10 Name:           bison
11 Version:        3.0.4
12 Release:        2
13 License:        GPL v3+
14 Group:          Development/Tools
15 Source0:        http://ftp.gnu.org/gnu/bison/%{name}-%{version}.tar.xz
16 # Source0-md5:  c342201de104cc9ce0a21e0ad10d4021
17 Source1:        %{name}.1.pl
18 Patch0:         %{name}-info.patch
19 URL:            http://gnu.org/software/bison/
20 BuildRequires:  automake >= 1:1.11.1
21 BuildRequires:  flex
22 BuildRequires:  gettext-tools >= 0.18
23 BuildRequires:  m4 >= 1.4.6
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  texinfo >= 4.0
26 BuildRequires:  xz
27 Requires:       %{name}-runtime = %{version}-%{release}
28 Requires:       m4 >= 1.4.6
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         pkgdatadir      %{_datadir}/bison
32
33 %description
34 Bison is a general purpose parser generator which converts a grammar
35 description for an LALR context-free grammar into a C program to parse
36 that grammar. Bison can be used to develop a wide range of language
37 parsers, from ones used in simple desk calculators to complex
38 programming languages. Bison is upwardly compatible with Yacc, so any
39 correctly written Yacc grammar should work with Bison without any
40 changes. If you know Yacc, you shouldn't have any trouble using Bison
41 (but you do need to be very proficient in C programming to be able to
42 use Bison). Many programs use Bison as part of their build process.
43 Bison is only needed on systems that are used for development.
44
45 %description -l de.UTF-8
46 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
47 kompatibel ist. Viele Programme benutzen ihn als Teil des
48 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
49 Entwicklung verwendet werden.
50
51 %description -l es.UTF-8
52 Este es el creador de análisis gramatical GNU más compatible con yacc.
53 Varios programas lo utilizan como parte del su proceso de
54 construcción. Bison solamente hace falta en sistemas que se usan para
55 desarrollo.
56
57 %description -l fr.UTF-8
58 Générateur d'analyseur lexical de GNU compatible avec yacc. De
59 nombreux programmes l'utilisent dans leur phase de construction. Bison
60 ne sert que sur les systèmes utilisés pour le développement.
61
62 %description -l pl.UTF-8
63 W pakiecie znajduje się implementacja GNU generatora analizatora
64 składni, który jest odpowiednikiem programu yacc. Wiele programów
65 podczas kompilacji potrzebuje tego programu aby proces budowy plików
66 binarnych przebiegał prawidłowo. Bison jest potrzebny tylko w
67 systemach, w których prowadzone są różnego rodzaju kompilacje.
68
69 %description -l pt_BR.UTF-8
70 Este é o gerador de análise gramatical GNU que é mais compatível com
71 yacc. Vários programas o utilizam como parte do seu processo de
72 construção. Bison é somente necessário em sistemas que são usados para
73 desenvolvimento.
74
75 %description -l ru.UTF-8
76 Bison - это парсер, в основном совместимый с yacc. Многие программы
77 используют его в процессе компилляции. Bison нужен только в системах,
78 которые используются для разработки программ.
79
80 %description -l tr.UTF-8
81 byacc bir yacc ayrıştırıcısıdır. Pek çok program tarafından, kurulum
82 süreci sırasında kullanılır. Geliştirme yapanlara gerekli olabilir.
83
84 %description -l uk.UTF-8
85 Bison - це парсер, здебільшого сумісний з yacc. Багато програм
86 використовують його в процесі компіляції. Bison потрібен тільки в
87 системах, які використовуються для розробки програм.
88
89 %package runtime
90 Summary:        Runtime library for programs containing bison-generated parsers
91 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla programów zawierajacych parsery bisonowe
92 Group:          Libraries
93
94 %description runtime
95 Runtime library for internationalized programs containing
96 bison-generated parsers.
97
98 %description runtime -l pl.UTF-8
99 Biblioteka uruchomieniowa dla umiędzynarodowionych programów
100 zawierajacych parsery wygenerowane przez bisona.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %{__rm} po/stamp-po
107
108 %build
109 cp -f /usr/share/automake/config.sub config
110 %configure \
111         --disable-silent-rules
112 %{__make} \
113         pkgdatadir=%{pkgdatadir}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         pkgdatadir=%{pkgdatadir}
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
124
125 %find_lang %{name}
126 %find_lang %{name}-runtime
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/postshell
132 -/usr/sbin/fix-info-dir -c %{_infodir}
133
134 %postun -p /sbin/postshell
135 -/usr/sbin/fix-info-dir -c %{_infodir}
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README THANKS TODO
140 %attr(755,root,root) %{_bindir}/bison
141 # would conflict with byacc (but is not 100% compatible)
142 #%attr(755,root,root) %{_bindir}/yacc
143 %{pkgdatadir}
144 %{_libdir}/liby.a
145 %{_aclocaldir}/bison-i18n.m4
146 %{_mandir}/man1/bison.1*
147 %lang(pl) %{_mandir}/pl/man1/bison.1*
148 %{_infodir}/bison.info*
149
150 %files runtime -f %{name}-runtime.lang
151 %defattr(644,root,root,755)
This page took 0.139139 seconds and 3 git commands to generate.