]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
- bcond header
[packages/bison.git] / bison.spec
1 Summary:        A GNU general-purpose parser generator
2 Summary(de.UTF-8):      GNU-Parser-Generator
3 Summary(es.UTF-8):      Generador de parser de la GNU
4 Summary(fr.UTF-8):      Générateur d'analyseur lexical de GNU
5 Summary(pl.UTF-8):      GNU generator składni
6 Summary(pt_BR.UTF-8):   Gerador de parser da GNU
7 Summary(ru.UTF-8):      Bison - генератор парсеров GNU
8 Summary(tr.UTF-8):      GNU ayrıştırıcı üreticisi
9 Summary(uk.UTF-8):      Bison - генератор парсерів GNU
10 Name:           bison
11 Version:        3.0.5
12 Release:        1
13 License:        GPL v3+
14 Group:          Development/Tools
15 Source0:        http://ftp.gnu.org/gnu/bison/%{name}-%{version}.tar.xz
16 # Source0-md5:  3e54f20988ecd1b62044e25481e5f06b
17 Source1:        %{name}.1.pl
18 Patch0:         %{name}-info.patch
19 URL:            http://gnu.org/software/bison/
20 BuildRequires:  flex
21 BuildRequires:  gettext-tools >= 0.18
22 BuildRequires:  help2man
23 BuildRequires:  libxslt-progs
24 BuildRequires:  m4 >= 1.4.6
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  texinfo >= 4.0
27 BuildRequires:  xz
28 Requires:       %{name}-runtime = %{version}-%{release}
29 Requires:       m4 >= 1.4.6
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bison is a general purpose parser generator which converts a grammar
34 description for an LALR context-free grammar into a C program to parse
35 that grammar. Bison can be used to develop a wide range of language
36 parsers, from ones used in simple desk calculators to complex
37 programming languages. Bison is upwardly compatible with Yacc, so any
38 correctly written Yacc grammar should work with Bison without any
39 changes. If you know Yacc, you shouldn't have any trouble using Bison
40 (but you do need to be very proficient in C programming to be able to
41 use Bison). Many programs use Bison as part of their build process.
42 Bison is only needed on systems that are used for development.
43
44 %description -l de.UTF-8
45 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
46 kompatibel ist. Viele Programme benutzen ihn als Teil des
47 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
48 Entwicklung verwendet werden.
49
50 %description -l es.UTF-8
51 Este es el creador de análisis gramatical GNU más compatible con yacc.
52 Varios programas lo utilizan como parte del su proceso de
53 construcción. Bison solamente hace falta en sistemas que se usan para
54 desarrollo.
55
56 %description -l fr.UTF-8
57 Générateur d'analyseur lexical de GNU compatible avec yacc. De
58 nombreux programmes l'utilisent dans leur phase de construction. Bison
59 ne sert que sur les systèmes utilisés pour le développement.
60
61 %description -l pl.UTF-8
62 W pakiecie znajduje się implementacja GNU generatora analizatora
63 składni, który jest odpowiednikiem programu yacc. Wiele programów
64 podczas kompilacji potrzebuje tego programu aby proces budowy plików
65 binarnych przebiegał prawidłowo. Bison jest potrzebny tylko w
66 systemach, w których prowadzone są różnego rodzaju kompilacje.
67
68 %description -l pt_BR.UTF-8
69 Este é o gerador de análise gramatical GNU que é mais compatível com
70 yacc. Vários programas o utilizam como parte do seu processo de
71 construção. Bison é somente necessário em sistemas que são usados para
72 desenvolvimento.
73
74 %description -l ru.UTF-8
75 Bison - это парсер, в основном совместимый с yacc. Многие программы
76 используют его в процессе компилляции. Bison нужен только в системах,
77 которые используются для разработки программ.
78
79 %description -l tr.UTF-8
80 byacc bir yacc ayrıştırıcısıdır. Pek çok program tarafından, kurulum
81 süreci sırasında kullanılır. Geliştirme yapanlara gerekli olabilir.
82
83 %description -l uk.UTF-8
84 Bison - це парсер, здебільшого сумісний з yacc. Багато програм
85 використовують його в процесі компіляції. Bison потрібен тільки в
86 системах, які використовуються для розробки програм.
87
88 %package runtime
89 Summary:        Runtime library for programs containing bison-generated parsers
90 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla programów zawierajacych parsery bisonowe
91 Group:          Libraries
92
93 %description runtime
94 Runtime library for internationalized programs containing
95 bison-generated parsers.
96
97 %description runtime -l pl.UTF-8
98 Biblioteka uruchomieniowa dla umiędzynarodowionych programów
99 zawierajacych parsery wygenerowane przez bisona.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104
105 %{__rm} po/stamp-po
106
107 %build
108 %configure \
109         --disable-silent-rules
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
120
121 # provided by byacc (bison is not 100% compatible)
122 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/yacc,%{_mandir}/man1/yacc.1}
123
124 install -d $RPM_BUILD_ROOT%{_examplesdir}
125 %{__mv} $RPM_BUILD_ROOT%{_docdir}/bison/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
126 # the rest is packaged as %doc
127 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bison
128
129 %find_lang %{name}
130 %find_lang %{name}-runtime
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/postshell
136 -/usr/sbin/fix-info-dir -c %{_infodir}
137
138 %postun -p /sbin/postshell
139 -/usr/sbin/fix-info-dir -c %{_infodir}
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README THANKS TODO
144 %attr(755,root,root) %{_bindir}/bison
145 %{_libdir}/liby.a
146 %{_datadir}/bison
147 %{_aclocaldir}/bison-i18n.m4
148 %{_mandir}/man1/bison.1*
149 %lang(pl) %{_mandir}/pl/man1/bison.1*
150 %{_infodir}/bison.info*
151 %{_examplesdir}/%{name}-%{version}
152
153 %files runtime -f %{name}-runtime.lang
154 %defattr(644,root,root,755)
This page took 0.053253 seconds and 3 git commands to generate.