]> git.pld-linux.org Git - packages/bird.git/blobdiff - bird.spec
- up to 1.3.9
[packages/bird.git] / bird.spec
index 5e16f52ab62490461454884d5feaa81de67aab3d..78b70f9fb466528a55690f124001cef00f8029eb 100644 (file)
--- a/bird.spec
+++ b/bird.spec
@@ -1,25 +1,27 @@
-
-%bcond_without ipv6    # disable IPv6 support (and building bird-ipv6 package) 
-%bcond_without ipv4    # disable IPv4 support (and building bird-ipv4 package)
-
 # TODO:
 #      - trigger to clean up after old bird package (stop, chkconfig --del)
-
-Summary:       Routing daemon
-Summary(pl):   Demon dynamicznego routingu
+#
+# Conditional build:
+%bcond_without ipv6    # disable IPv6 support (and building bird-ipv6 package)
+%bcond_without ipv4    # disable IPv4 support (and building bird-ipv4 package)
+%bcond_with    alien   # enable possibility to import 'alien' routes import into bird's routing table
+#
+Summary:       The BIRD Internet Routing Daemon
+Summary(pl.UTF-8):     Demon BIRD Internetowego Routingu Dynamicznego
 Name:          bird
-Version:       1.0.11
+Version:       1.3.9
 Release:       1
-License:       GPL
+License:       GPL v2+
 Group:         Networking/Daemons
 Source0:       ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
-# Source0-md5: 9f9dfe2af0bde45a0adbbd0ebc36f249
+# Source0-md5: 86042560b5053dd008ba0b5ecbdde136
 Source1:       %{name}-ipv4.init
 Source2:       %{name}-ipv4.sysconfig
 Source3:       %{name}-ipv6.init
 Source4:       %{name}-ipv6.sysconfig
-Patch0:                %{name}-flex.patch
-Patch1:                %{name}-64bit.patch
+Source5:       ftp://bird.network.cz/pub/bird/%{name}-doc-%{version}.tar.gz
+# Source5-md5: 20746cd5af65207101b90344084a3293
+Patch0:                %{name}-allowalien.patch
 URL:           http://bird.network.cz/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -30,6 +32,8 @@ BuildRequires:        rpmbuild(macros) >= 1.268
 Requires(post,preun):  /sbin/chkconfig
 Requires:      bird-daemon
 Requires:      rc-scripts
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /usr/sbin/useradd
 Obsoletes:     gated
 Obsoletes:     mrt
 Obsoletes:     zebra
@@ -42,15 +46,15 @@ UNIX-like systems (but not necessarily limited to them) with full
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
-%description -l pl
+%description -l pl.UTF-8
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
-pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
-protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
-filtrów o du¿ych mo¿liwo¶ciach.
+pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
+protokołów routingu, łatwym interfejsem konfiguracji i językiem
+filtrów o dużych możliwościach.
 
 %package ipv4
 Summary:       Routing daemon for IPv4
-Summary(pl):   Demon dynamicznego routingu IPv4
+Summary(pl.UTF-8):     Demon dynamicznego routingu IPv4
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
@@ -68,15 +72,15 @@ UNIX-like systems (but not necessarily limited to them) with full
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
-%description ipv4 -l pl
+%description ipv4 -l pl.UTF-8
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
-pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
-protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
-filtrów o du¿ych mo¿liwo¶ciach.
+pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
+protokołów routingu, łatwym interfejsem konfiguracji i językiem
+filtrów o dużych możliwościach.
 
 %package ipv6
 Summary:       Routing daemon for IPv6
-Summary(pl):   Demon dynamicznego routingu IPv6
+Summary(pl.UTF-8):     Demon dynamicznego routingu IPv6
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
@@ -94,27 +98,28 @@ UNIX-like systems (but not necessarily limited to them) with full
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
-%description ipv6 -l pl
+%description ipv6 -l pl.UTF-8
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
-pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
-protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
-filtrów o du¿ych mo¿liwo¶ciach.
+pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
+protokołów routingu, łatwym interfejsem konfiguracji i językiem
+filtrów o dużych możliwościach.
 
 %prep
-%setup -q
-%patch0 -p1
-%patch1 -p1
+%setup -q -a 5
+%{?with_alien:%patch0 -p1}
 
 %build
 cp -f /usr/share/automake/config.* tools
+%{__autoconf}
+
+export CFLAGS="%{rpmcflags} -I%{_includedir}/ncursesw"
 
 %if %{with ipv6}
-%{__autoconf}
 %configure \
        --disable-memcheck \
        --enable-client \
        --enable-ipv6
-%{__make}
+%{__make} -j1
 
 mv bird bird-6
 
@@ -126,7 +131,7 @@ mv bird bird-6
        --disable-memcheck \
        --enable-client \
        --disable-ipv6
-%{__make}
+%{__make} -j1
 %endif
 
 %install
@@ -135,7 +140,7 @@ install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_sbindir}}
 
 install birdc $RPM_BUILD_ROOT%{_sbindir}
 
-%if %{with ipv6}
+%if %{with ipv4}
 install bird $RPM_BUILD_ROOT%{_sbindir}
 install doc/bird.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv4
@@ -146,8 +151,9 @@ install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv4
 install bird-6 $RPM_BUILD_ROOT%{_sbindir}
 cat <<EOF > $RPM_BUILD_ROOT%{_sbindir}/birdc-6
 #!/bin/sh
-exec %{_sbindir}/birdc -s /var/run/bird-6.ctl
+exec %{_sbindir}/birdc -s /var/run/bird6.ctl
 EOF
+:> $RPM_BUILD_ROOT%{_sysconfdir}/%{name}6.conf
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv6
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv6
 %endif
@@ -155,6 +161,16 @@ install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv6
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 271 bird
+%useradd -u 271 -d /usr/share/empty -s /bin/false -c "bird routing daemon" -g bird bird
+
+%postun
+if [ "$1" = "0" ]; then
+       %userremove bird
+       %groupremove bird
+fi
+
 %post ipv4
 /sbin/chkconfig --add %{name}-ipv4
 %service %{name}-ipv4 restart "routing daemon"
@@ -175,9 +191,13 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del %{name}-ipv6
 fi
 
+%triggerpostun ipv4 -- %{name}-ipv4 < 1.3.4-3
+chmod 0640 /etc/bird.conf
+chgrp bird /etc/bird.conf
+
 %files
 %defattr(644,root,root,755)
-%doc doc/*.html TODO README
+%doc doc/*.html doc/reply_codes %{name}-doc-%{version}/doc/*.ps ChangeLog NEWS README TODO
 %attr(755,root,root) %{_sbindir}/birdc
 
 %if %{with ipv4}
@@ -185,8 +205,8 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird
 %attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
+%attr(640,root,bird) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
 %endif
 
 %if %{with ipv6}
@@ -194,7 +214,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird-6
 %attr(755,root,root) %{_sbindir}/birdc-6
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rc.d/init.d/bird-ipv6
-#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird-6.conf
+%attr(754,root,root) /etc/rc.d/init.d/bird-ipv6
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
+%attr(640,root,bird) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird6.conf
 %endif
This page took 0.717852 seconds and 4 git commands to generate.