]> git.pld-linux.org Git - packages/bird.git/blame - bird.spec
- fixed typo
[packages/bird.git] / bird.spec
CommitLineData
587f8625
JK
1# TODO:
2# - trigger to clean up after old bird package (stop, chkconfig --del)
0e72880e
ER
3#
4# Conditional build:
5%bcond_without ipv6 # disable IPv6 support (and building bird-ipv6 package)
6%bcond_without ipv4 # disable IPv4 support (and building bird-ipv4 package)
3c309a5c 7%bcond_with alien # enable possibility to import 'alien' routes import into bird's routing table
0e72880e 8#
46b7240d
TP
9Summary: The BIRD Internet Routing Daemon
10Summary(pl.UTF-8): Demon BIRD Internetowego Routingu Dynamicznego
859a1f4d 11Name: bird
dcb2fa8e
AM
12Version: 1.3.1
13Release: 1
46b7240d 14License: GPL v2+
859a1f4d 15Group: Networking/Daemons
859a1f4d 16Source0: ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
dcb2fa8e 17# Source0-md5: d11f53b79c7371b76e5c93209dbe2a10
587f8625
JK
18Source1: %{name}-ipv4.init
19Source2: %{name}-ipv4.sysconfig
20Source3: %{name}-ipv6.init
21Source4: %{name}-ipv6.sysconfig
46b7240d 22Source5: ftp://bird.network.cz/pub/bird/%{name}-doc-%{version}.tar.gz
dcb2fa8e
AM
23# Source5-md5: 340be3f6c7ade302a0b4b34dd2773957
24Patch0: %{name}-allowalien.patch
859a1f4d 25URL: http://bird.network.cz/
42582df4 26BuildRequires: autoconf
bd9359d2 27BuildRequires: automake
0e8a59db 28BuildRequires: bison
29BuildRequires: flex
1e96d8fe 30BuildRequires: readline-devel >= 4.2
f3122825 31BuildRequires: rpmbuild(macros) >= 1.268
90026ef8 32Requires(post,preun): /sbin/chkconfig
587f8625 33Requires: bird-daemon
f3122825 34Requires: rc-scripts
bd846c8e 35Obsoletes: gated
dab997f5 36Obsoletes: mrt
bd846c8e 37Obsoletes: zebra
38Obsoletes: zebra-guile
f3122825 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
859a1f4d
AM
40
41%description
42The BIRD project is an attempt to create a routing daemon running on
43UNIX-like systems (but not necessarily limited to them) with full
44support of all modern routing protocols, easy to use configuration
45interface and powerful route filtering language.
46
bf003f25 47%description -l pl.UTF-8
859a1f4d 48Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
bf003f25
JR
49pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
50protokołów routingu, łatwym interfejsem konfiguracji i językiem
51filtrów o dużych możliwościach.
859a1f4d 52
587f8625
JK
53%package ipv4
54Summary: Routing daemon for IPv4
6317c737 55Summary(pl.UTF-8): Demon dynamicznego routingu IPv4
587f8625 56Group: Networking/Daemons
587f8625 57Requires(post,preun): /sbin/chkconfig
f3122825
ER
58Requires: %{name} = %{version}-%{release}
59Requires: rc-scripts
587f8625 60Provides: bird-daemon
f3122825 61Provides: routingdaemon
587f8625
JK
62Obsoletes: gated
63Obsoletes: mrt
64Obsoletes: zebra
65Obsoletes: zebra-guile
587f8625
JK
66
67%description ipv4
68The BIRD project is an attempt to create a routing daemon running on
69UNIX-like systems (but not necessarily limited to them) with full
70support of all modern routing protocols, easy to use configuration
71interface and powerful route filtering language.
72
bf003f25 73%description ipv4 -l pl.UTF-8
587f8625 74Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
bf003f25
JR
75pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
76protokołów routingu, łatwym interfejsem konfiguracji i językiem
77filtrów o dużych możliwościach.
587f8625
JK
78
79%package ipv6
80Summary: Routing daemon for IPv6
6317c737 81Summary(pl.UTF-8): Demon dynamicznego routingu IPv6
587f8625 82Group: Networking/Daemons
587f8625 83Requires(post,preun): /sbin/chkconfig
f3122825
ER
84Requires: %{name} = %{version}-%{release}
85Requires: rc-scripts
587f8625 86Provides: bird-daemon
f3122825 87Provides: routingdaemon
587f8625
JK
88Obsoletes: gated
89Obsoletes: mrt
90Obsoletes: zebra
91Obsoletes: zebra-guile
587f8625
JK
92
93%description ipv6
94The BIRD project is an attempt to create a routing daemon running on
95UNIX-like systems (but not necessarily limited to them) with full
96support of all modern routing protocols, easy to use configuration
97interface and powerful route filtering language.
98
bf003f25 99%description ipv6 -l pl.UTF-8
587f8625 100Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
bf003f25
JR
101pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
102protokołów routingu, łatwym interfejsem konfiguracji i językiem
103filtrów o dużych możliwościach.
587f8625 104
859a1f4d 105%prep
46b7240d 106%setup -q -a 5
dbe442d0 107%{?with_alien:%patch0 -p1}
859a1f4d
AM
108
109%build
bd9359d2 110cp -f /usr/share/automake/config.* tools
46b7240d
TP
111%{__autoconf}
112
f455108b 113export CFLAGS="%{rpmcflags} -I%{_includedir}/ncursesw"
587f8625
JK
114
115%if %{with ipv6}
587f8625 116%configure \
859a1f4d
AM
117 --disable-memcheck \
118 --enable-client \
119 --enable-ipv6
b90dbe4c 120%{__make} -j1
859a1f4d 121
587f8625
JK
122mv bird bird-6
123
124%{__make} clean
125%endif
126
127%if %{with ipv4}
128%configure \
129 --disable-memcheck \
130 --enable-client \
131 --disable-ipv6
b90dbe4c 132%{__make} -j1
587f8625
JK
133%endif
134
859a1f4d
AM
135%install
136rm -rf $RPM_BUILD_ROOT
587f8625 137install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_sbindir}}
859a1f4d 138
bd846c8e 139install birdc $RPM_BUILD_ROOT%{_sbindir}
140
587f8625
JK
141%if %{with ipv6}
142install bird $RPM_BUILD_ROOT%{_sbindir}
bd846c8e 143install doc/bird.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
587f8625
JK
144install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv4
145install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv4
146%endif
147
148%if %{with ipv6}
149install bird-6 $RPM_BUILD_ROOT%{_sbindir}
150cat <<EOF > $RPM_BUILD_ROOT%{_sbindir}/birdc-6
151#!/bin/sh
152exec %{_sbindir}/birdc -s /var/run/bird-6.ctl
153EOF
154install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv6
155install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv6
156%endif
bd846c8e 157
e7d0d739
JB
158%clean
159rm -rf $RPM_BUILD_ROOT
160
587f8625 161%post ipv4
f3122825
ER
162/sbin/chkconfig --add %{name}-ipv4
163%service %{name}-ipv4 restart "routing daemon"
7873eba9 164
587f8625 165%preun ipv4
cddbae54 166if [ "$1" = "0" ]; then
f3122825
ER
167 %service %{name}-ipv4 stop
168 /sbin/chkconfig --del %{name}-ipv4
587f8625
JK
169fi
170
171%post ipv6
f3122825
ER
172/sbin/chkconfig --add %{name}-ipv6
173%service %{name}-ipv6 restart "routing daemon"
587f8625
JK
174
175%preun ipv6
176if [ "$1" = "0" ]; then
f3122825
ER
177 %service %{name}-ipv6 stop
178 /sbin/chkconfig --del %{name}-ipv6
cddbae54 179fi
859a1f4d 180
859a1f4d 181%files
d889a53b 182%defattr(644,root,root,755)
46b7240d 183%doc doc/*.html doc/reply_codes %{name}-doc-%{version}/doc/*.ps ChangeLog NEWS README TODO
587f8625
JK
184%attr(755,root,root) %{_sbindir}/birdc
185
186%if %{with ipv4}
187%files ipv4
859a1f4d 188%defattr(644,root,root,755)
587f8625
JK
189%attr(755,root,root) %{_sbindir}/bird
190%attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
0e8a59db 191%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
192%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
587f8625 193%endif
859a1f4d 194
587f8625
JK
195%if %{with ipv6}
196%files ipv6
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_sbindir}/bird-6
199%attr(755,root,root) %{_sbindir}/birdc-6
0e8a59db 200%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
201%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rc.d/init.d/bird-ipv6
202#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird-6.conf
587f8625 203%endif
This page took 0.120895 seconds and 4 git commands to generate.