]> git.pld-linux.org Git - packages/binwalk.git/commitdiff
- up to 2.1.1 auto/th/binwalk-2.1.1-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 22 Apr 2016 13:56:28 +0000 (15:56 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 22 Apr 2016 13:56:28 +0000 (15:56 +0200)
binwalk.spec

index a8a41fc6cf0a9bc7083c1e4e4d722808bde354fb..3837e88777b8309e9ca60f9ded65cf6981c9bc5e 100644 (file)
@@ -1,51 +1,52 @@
+# TODO:
+# - split library into subpackage?
+#
+%define        module  binwalk
 Summary:       Binary image analyze tool
 Name:          binwalk
-Version:       0.3.8
+Version:       2.1.1
 Release:       1
 License:       MIT
 Group:         Applications/Development
-Source0:       http://binwalk.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: bc145f8b9abd5e79d5bc3aecdc0ab829
-URL:           http://code.google.com/p/binwalk/
-BuildRequires: autoconf >= 2.65
-BuildRequires: curl-devel
-BuildRequires: libmagic-devel
+Source0:       https://github.com/devttys0/binwalk/archive/v%{version}.tar.gz
+# Source0-md5: e5015a8d0eff287eda8c4afeeca89ed6
+URL:           https://github.com/devttys0/binwalk
+%if %{with python3}
+BuildRequires: python3-modules
+BuildRequires: python3-setuptools
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Binwalk is a tool for searching a given binary image for embedded files
-and executable code. Specifically, it is designed for identifying files
-and code embedded inside of firmware images. Binwalk uses the libmagic
-library, so it is compatible with magic signatures created for the Unix
-file utility.
+Binwalk is a tool for searching a given binary image for embedded
+files and executable code. Specifically, it is designed for
+identifying files and code embedded inside of firmware images. Binwalk
+uses the libmagic library, so it is compatible with magic signatures
+created for the Unix file utility.
 
 Binwalk also includes a custom magic signature file which contains
 improved signatures for files that are commonly found in firmware
 images such as compressed/archived files, firmware headers, Linux
-kernels, bootloaders, filesystems, etc. 
+kernels, bootloaders, filesystems, etc.
 
 %prep
 %setup -q
-perl -ne 's/-lz/-lmagic/; print unless /^tar -zxvf \$FILE\.tar\.gz/' -i src/configure.ac
-perl -ne 'print unless /FILE/' -i src/Makefile.in
 
 %build
-cd src
-%{__autoconf}
-%configure
-%{__make}
+%py3_build %{?with_tests:test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} -C src install \
-       DESTDIR=$RPM_BUILD_ROOT
+%py3_install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc docs/README
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
-%attr(755,root,root) %{_bindir}/%{name}
+%doc API.md README.md
+%attr(755,root,root) %{_bindir}/binwalk
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+
This page took 0.078684 seconds and 4 git commands to generate.