]> git.pld-linux.org Git - packages/binutils.git/commitdiff
- updated to 2.28 auto/th/binutils-2.28-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 6 Jun 2017 13:51:41 +0000 (15:51 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 6 Jun 2017 13:51:41 +0000 (15:51 +0200)
- updated discarded,absolute-gnu_debuglink-path,build-id patches

binutils-absolute-gnu_debuglink-path.patch
binutils-build-id.patch
binutils-discarded.patch
binutils.spec

index f4d314473193be71aa90ffc0e82b1068c5da4cde..c1822ad3c4340e73d62562867f3cdd5da07ca4b0 100644 (file)
@@ -1,18 +1,7 @@
---- binutils-2.18.50.0.2/bfd/opncls.c.orig     2007-10-03 17:52:57.000000000 +0200
-+++ binutils-2.18.50.0.2/bfd/opncls.c  2007-10-22 22:30:03.233754376 +0200
-@@ -1241,6 +1241,10 @@
-       return NULL;
-     }
-+  /* PLD: check the possible absolute debuginfo path (e.g. /tmp/.../usr/lib/debug/... */
-+  if (separate_debug_file_exists (basename, crc32))
-+    return basename;
-+
-   for (dirlen = strlen (abfd->filename); dirlen > 0; dirlen--)
-     if (IS_DIR_SEPARATOR (abfd->filename[dirlen - 1]))
-       break;
-@@ -1345,6 +1349,15 @@
-   return find_separate_debug_file (abfd, dir);
+--- binutils-2.28/bfd/opncls.c.orig    2017-03-02 09:23:53.000000000 +0100
++++ binutils-2.28/bfd/opncls.c 2017-06-06 05:31:14.585633912 +0200
+@@ -1209,6 +1209,15 @@
+   return name;
  }
  
 +static char const*
 +
  /*
  FUNCTION
-       bfd_create_gnu_debuglink_section
-@@ -1376,8 +1389,7 @@
+       bfd_get_alt_debug_link_info
+@@ -1397,6 +1406,10 @@
+   if (include_dirs)
+     {
++      /* PLD: check the possible absolute debuginfo path (e.g. /tmp/.../usr/lib/debug/... */
++      if (separate_debug_file_exists (basename, crc32))
++        return basename;
++
+       for (dirlen = strlen (abfd->filename); dirlen > 0; dirlen--)
+       if (IS_DIR_SEPARATOR (abfd->filename[dirlen - 1]))
+         break;
+@@ -1629,8 +1642,7 @@
        return NULL;
      }
  
@@ -37,7 +37,7 @@
  
    sect = bfd_get_section_by_name (abfd, GNU_DEBUGLINK);
    if (sect)
-@@ -1463,9 +1475,7 @@
+@@ -1716,9 +1728,7 @@
      crc32 = bfd_calc_gnu_debuglink_crc32 (crc32, buffer, count);
    fclose (handle);
  
index f76d0588cc04a589b915c620908865c1044fbfeb..eb36832625a9f06839ab057869750289dfbe470e 100644 (file)
@@ -1,15 +1,6 @@
---- binutils-2.23.51.0.5/bfd/compress.c.orig   2012-11-12 17:45:23.000000000 +0100
-+++ binutils-2.23.51.0.5/bfd/compress.c        2012-11-13 17:20:33.925842054 +0100
-@@ -178,7 +178,7 @@ bfd_get_full_section_contents (bfd *abfd
-     case COMPRESS_SECTION_NONE:
-       if (p == NULL)
-       {
--        p = (bfd_byte *) bfd_malloc (sz);
-+        p = (bfd_byte *) bfd_zmalloc (sz);
-         if (p == NULL)
-           return FALSE;
-       }
-@@ -218,7 +218,7 @@ bfd_get_full_section_contents (bfd *abfd
+--- binutils-2.28/bfd/compress.c.orig  2017-03-02 09:23:53.000000000 +0100
++++ binutils-2.28/bfd/compress.c       2017-06-06 05:39:38.755628152 +0200
+@@ -290,7 +290,7 @@ bfd_get_full_section_contents (bfd *abfd
        goto fail_compressed;
  
        if (p == NULL)
@@ -18,3 +9,12 @@
        if (p == NULL)
        goto fail_compressed;
  
+@@ -319,7 +319,7 @@ bfd_get_full_section_contents (bfd *abfd
+       return FALSE;
+       if (p == NULL)
+       {
+-        p = (bfd_byte *) bfd_malloc (sz);
++        p = (bfd_byte *) bfd_zmalloc (sz);
+         if (p == NULL)
+           return FALSE;
+         *ptr = p;
index 8a0ce07674a258eeb0af2bee66e4a97b85730aa3..e16e4cc9d78e76f4272dccd85d1d89e80c9f9e54 100644 (file)
@@ -1,9 +1,9 @@
---- binutils-2.22.52.0.4/bfd/elflink.c.orig    2012-06-12 20:17:08.000000000 +0200
-+++ binutils-2.22.52.0.4/bfd/elflink.c 2012-06-12 20:19:42.632670882 +0200
-@@ -9643,7 +9643,7 @@
-                     BFD_ASSERT (r_symndx != STN_UNDEF);
+--- binutils-2.28/bfd/elflink.c.orig   2017-06-05 22:10:50.459268960 +0200
++++ binutils-2.28/bfd/elflink.c        2017-06-05 22:30:10.125922386 +0200
+@@ -10420,7 +10420,7 @@
                      if (action_discarded & COMPLAIN)
                        (*flinfo->info->callbacks->einfo)
+                         /* xgettext:c-format */
 -                        (_("%X`%s' referenced in section `%A' of %B: "
 +                        (_("`%s' referenced in section `%A' of %B: "
                             "defined in discarded section `%A' of %B\n"),
index b11316d46835c7ad84e85ebd0e72782771e4ea74..7d1f61412895210c03ce34b0a406779351c1d720 100644 (file)
@@ -23,13 +23,13 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.27
+Version:       2.28
 Release:       1
 Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
 Source0:       http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.bz2
-# Source0-md5: 2869c9bf3e60ee97c74ac2a6bf4e9d68
+# Source0-md5: 9e8340c96626b469a603c15c9d843727
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
This page took 0.224125 seconds and 4 git commands to generate.