]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
- disable tests, they are failing for years
[packages/binutils.git] / binutils.spec
index d96c19684a651d20a3e6e8b87727fe8d97ac5ab9..ca2da316d27dcdd495af3775bd70f4e6a94cc1d5 100644 (file)
@@ -5,10 +5,11 @@
                                # http://sourceware.org/ml/binutils/2008-03/msg00162.html
 %bcond_without pax             # without PaX flags (for upstream bugreports)
 %bcond_without gold            # don't build gold (no C++ dependencies)
-%bcond_without default_ld      # default ld instead of gold
-%bcond_without tests
+%bcond_without default_bfd     # default ld.bfd instead of gold
+%bcond_without gasp            # gasp
+%bcond_with    tests
 
-%ifnarch %{ix86} %{x8664}
+%ifnarch %{ix86} %{x8664} x32
 %undefine      with_gold
 %endif
 
@@ -22,13 +23,17 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.23.51.0.5
-Release:       1
+Version:       2.24.51.0.4
+Release:       2
 Epoch:         3
 License:       GPL v3+
 Group:         Development/Tools
-Source0:       http://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.xz
-# Source0-md5: 25ab1cdd20e9080c873428320a294fa4
+# Source0:     https://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.xz
+
+# release with no tarball - https://sourceware.org/git/?p=binutils-gdb.git;a=summary
+Source0:       %{name}-%{version}.tar.bz2
+# Source0-md5: a44a86209c84e2072824183c4b0a11f4
+
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
@@ -41,12 +46,17 @@ Patch7:             %{name}-libtool-m.patch
 Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
 Patch10:       %{name}-sanity-check.patch
+Patch11:       %{name}-am.patch
+Patch12:       pr-17422.patch
+Patch13:       pr-17440.patch
+Patch14:       pr-17447.patch
+Patch15:       pr-17467.patch
 URL:           http://sources.redhat.com/binutils/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
 BuildRequires: bison
 BuildRequires: flex
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 %{?with_gold:BuildRequires:    libstdc++-devel >= 6:4.0-1}
 %{?with_tests:BuildRequires:   libstdc++-static >= 6:4.0}
 BuildRequires: perl-tools-pod
@@ -60,6 +70,7 @@ BuildRequires:        zlib-devel
 %{?with_tests:BuildRequires:   zlib-static}
 Conflicts:     gcc-c++ < 5:3.3
 Conflicts:     modutils < 2.4.17
+Conflicts:     rpmbuild(macros) < 1.660
 Obsoletes:     binutils-gold
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -158,7 +169,7 @@ niektórych pakietów.
 
 %prep
 %setup -q
-%patch0 -p1
+%{?with_gasp:%patch0 -p1}
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
@@ -168,6 +179,11 @@ niektórych pakietów.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
+%patch15 -p1
 
 # file contains hacks for ac 2.59 only
 %{__rm} config/override.m4
@@ -202,6 +218,9 @@ TARGETS=sparc64-linux
 %ifarch %{x8664}
 TARGETS="x86_64-pep"
 %endif
+%ifarch x32
+TARGETS="x86_64-linux,x86_64-pep"
+%endif
 %{?addtargets:TARGETS="%{addtargets}"}
 
 cp -f /usr/share/automake/config.* .
@@ -231,9 +250,9 @@ sparc32 \
 %else
        %{?with_allarchs:--enable-64-bit-bfd} \
 %endif
-       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
+       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
 %if %{with gold}
-       --enable-gold%{!?with_default_ld:=default} --enable-ld%{?with_default_ld:=default} \
+       --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
 %endif
 
 %{__make} -j1
@@ -246,8 +265,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{_infodir}/standards.info*
-
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
@@ -295,6 +312,12 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post  gasp -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        gasp -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README
@@ -321,7 +344,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/strip
 %{_infodir}/as.info*
 %{_infodir}/binutils.info*
-%{_infodir}/configure.info*
 %{_infodir}/gprof.info*
 %{_infodir}/ld.info*
 %{_prefix}/lib/ldscripts
@@ -361,7 +383,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libbfd.a
 %{_libdir}/libopcodes.a
 
+%if %{with gasp}
 %files gasp
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gasp
 %{_infodir}/gasp.info*
+%endif
This page took 0.034258 seconds and 4 git commands to generate.