]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
- unified gasp.texi source name
[packages/binutils.git] / binutils.spec
index d0be750b32eb2b5fba284e48d659c527406d5066..8f5800bd651c65321ab4641209d22e1e3a29c053 100644 (file)
@@ -4,8 +4,15 @@
 # define addtargets x,y,z      # build with additional targets x,y,z (e.g. x86_64-linux)
                                # http://sourceware.org/ml/binutils/2008-03/msg00162.html
 %bcond_without pax             # without PaX flags (for upstream bugreports)
-%bcond_with    default_ld      # default ld instead of gold
-#
+%bcond_without gold            # don't build gold (no C++ dependencies)
+%bcond_without default_bfd     # default ld.bfd instead of gold
+%bcond_without gasp            # gasp
+%bcond_with    tests           # check target
+
+%ifnarch %{ix86} %{x8664} x32
+%undefine      with_gold
+%endif
+
 Summary:       GNU Binary Utility Development Utilities
 Summary(de.UTF-8):     GNU Binary Utility Development Utilities
 Summary(es.UTF-8):     Utilitarios para desarrollo de binarios de la GNU
@@ -16,38 +23,46 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.21.52.0.2
-Release:       3
-Epoch:         3
+Version:       2.31
+Release:       1
+Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
-Source0:       ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
-# Source0-md5: 680e4cdfecfa14f5590b994150aa5c7e
+Source0:       http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
+# Source0-md5: 1ea8ddd13bd6fdcab1fe6cf377894476
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-libtool-relink.patch
 Patch3:                %{name}-pt_pax_flags.patch
-Patch5:                %{name}-discarded.patch
+Patch4:                %{name}-libdir.patch
+
 Patch6:                %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
 Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
+Patch10:       %{name}-sanity-check.patch
 URL:           http://sources.redhat.com/binutils/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
 BuildRequires: bison
 BuildRequires: flex
-BuildRequires: gettext-devel
-BuildRequires: libstdc++-devel >= 6:4.0-1
+BuildRequires: gettext-tools
+%{?with_gold:BuildRequires:    libstdc++-devel >= 6:4.0-1}
+%{?with_tests:BuildRequires:   libstdc++-static >= 6:4.0}
+BuildRequires: lzip
 BuildRequires: perl-tools-pod
 %ifarch sparc sparc32
 BuildRequires: sparc32
 %endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.2
+BuildRequires: zlib-devel
+%{?with_tests:BuildRequires:   zlib-static}
 Conflicts:     gcc-c++ < 5:3.3
 Conflicts:     modutils < 2.4.17
+Conflicts:     rpmbuild(macros) < 1.660
 Obsoletes:     binutils-gold
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -61,8 +76,7 @@ Binutils is a collection of binary utilities, including:
 - size - list the section sizes of an object or archive file,
 - strings - list printable strings from files,
 - strip - discard symbols,
-- addr2line - convert addresses to file and line,
-- nlmconv - convert object code into an NLM.
+- addr2line - convert addresses to file and line.
 
 %description -l es.UTF-8
 Binutils es una colección de utilitarios necesarios para compilar
@@ -121,6 +135,7 @@ Summary:    GNU binutils static libraries
 Summary(pl.UTF-8):     Biblioteki statyczne do GNU binutils
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+#Requires:     zlib-static
 
 %description static
 Static GNU binutils libraries (libbfd, libopcodes).
@@ -145,15 +160,17 @@ niektórych pakietów.
 
 %prep
 %setup -q
-%patch0 -p1
+%{?with_gasp:%patch0 -p1}
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
-%patch5 -p1
+%patch4 -p1
+
 %patch6 -p1
 %patch7 -p1
-%patch8 -p0
+%patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 # file contains hacks for ac 2.59 only
 %{__rm} config/override.m4
@@ -185,6 +202,12 @@ TARGETS=x86_64-linux
 %ifarch sparc
 TARGETS=sparc64-linux
 %endif
+%ifarch %{x8664}
+TARGETS="x86_64-pep"
+%endif
+%ifarch x32
+TARGETS="x86_64-linux,x86_64-pep"
+%endif
 %{?addtargets:TARGETS="%{addtargets}"}
 
 cp -f /usr/share/automake/config.* .
@@ -196,46 +219,49 @@ CXX="%{__cxx}"; export CXX
 sparc32 \
 %endif
 ./configure %{_target_platform} \
-       --disable-debug \
-       --disable-werror \
-       --enable-build-warnings=,-Wno-missing-prototypes \
-       --enable-shared \
-       --enable-lto \
-       --enable-plugins \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
-       --with-tooldir=%{_prefix} \
-       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --disable-debug \
+       --disable-werror \
 %ifarch sparc
        --enable-64-bit-bfd \
 %else
        %{?with_allarchs:--enable-64-bit-bfd} \
 %endif
-       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout} \
-%ifarch %{ix86} %{x8664}
-       --enable-gold%{!?with_default_ld:=default} --enable-ld%{?with_default_ld:=default} \
+       --enable-build-warnings=,-Wno-missing-prototypes \
+       --enable-install-libiberty \
+       --enable-lto \
+       --enable-plugins \
+       --enable-shared \
+       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
+       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --with-tooldir=%{_prefix} \
+       --with-zlib \
+%if %{with gold}
+       --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
 %endif
 
-%{__make}
+%{__make} -j1
+
+%{?with_tests:%{__make} -j1 check}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{_infodir}/standards.info*
-
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
-install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
-install libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
+# overwrite libiberty.a with PIC version
+cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
 
 # remove evil -L pointing inside builder's home
 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
@@ -248,12 +274,10 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 %find_lang binutils
 %find_lang gas
 %find_lang gprof
-touch ld.lang
+touch ld.lang gold.lang
 %find_lang ld
-%ifarch %{ix86} %{x8664}
+%if %{with gold}
 %find_lang gold
-%else
-:> gold.lang
 %endif
 %find_lang opcodes
 cat bfd.lang opcodes.lang > %{name}-libs.lang
@@ -277,9 +301,16 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post  gasp -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        gasp -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README
+%{?with_gold:%doc gold/{ChangeLog,README,TODO}}
 %attr(755,root,root) %{_bindir}/addr2line
 %attr(755,root,root) %{_bindir}/ar
 %attr(755,root,root) %{_bindir}/as
@@ -288,8 +319,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gprof
 %attr(755,root,root) %{_bindir}/ld
 %attr(755,root,root) %{_bindir}/ld.bfd
-%ifarch %{ix86} %{x8664}
+%if %{with gold}
 %attr(755,root,root) %{_bindir}/ld.gold
+%attr(755,root,root) %{_bindir}/dwp
 %endif
 %attr(755,root,root) %{_bindir}/nm
 %attr(755,root,root) %{_bindir}/objcopy
@@ -299,13 +331,26 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/size
 %attr(755,root,root) %{_bindir}/strings
 %attr(755,root,root) %{_bindir}/strip
+%{_prefix}/lib/ldscripts
 %{_infodir}/as.info*
 %{_infodir}/binutils.info*
-%{_infodir}/configure.info*
 %{_infodir}/gprof.info*
 %{_infodir}/ld.info*
-%{_prefix}/lib/ldscripts
-%{_mandir}/man1/*
+%{_mandir}/man1/addr2line.1*
+%{_mandir}/man1/ar.1*
+%{_mandir}/man1/as.1*
+%{_mandir}/man1/c++filt.1*
+%{_mandir}/man1/elfedit.1*
+%{_mandir}/man1/gprof.1*
+%{_mandir}/man1/ld.1*
+%{_mandir}/man1/nm.1*
+%{_mandir}/man1/objcopy.1*
+%{_mandir}/man1/objdump.1*
+%{_mandir}/man1/ranlib.1*
+%{_mandir}/man1/readelf.1*
+%{_mandir}/man1/size.1*
+%{_mandir}/man1/strings.1*
+%{_mandir}/man1/strip.1*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(de) %{_mandir}/de/man1/*
 %lang(es) %{_mandir}/es/man1/*
@@ -317,8 +362,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs -f %{name}-libs.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libbfd-*.so
-%attr(755,root,root) %{_libdir}/libopcodes-*.so
+%attr(755,root,root) %{_libdir}/libbfd-%{version}.so
+%attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
+%dir %{_libdir}/bfd-plugins
 
 %files devel
 %defattr(644,root,root,755)
@@ -330,10 +376,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/ansidecl.h
 %{_includedir}/bfd.h
 %{_includedir}/bfdlink.h
+%{_includedir}/diagnostics.h
 %{_includedir}/dis-asm.h
-%{_includedir}/libiberty.h
 %{_includedir}/plugin-api.h
 %{_includedir}/symcat.h
+%{_includedir}/libiberty
 %{_infodir}/bfd.info*
 
 %files static
@@ -341,7 +388,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libbfd.a
 %{_libdir}/libopcodes.a
 
+%if %{with gasp}
 %files gasp
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gasp
 %{_infodir}/gasp.info*
+%endif
This page took 0.399805 seconds and 4 git commands to generate.