]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
up to 2.42
[packages/binutils.git] / binutils.spec
index 4a054f257aa71bfa76919bccd381b049c78d4794..314f4ca4a5ac0cd9a80db75e8c4d02a0fd3a889b 100644 (file)
@@ -1,12 +1,25 @@
+# TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
 #
 # Conditional build:
 %bcond_with    allarchs        # enable all targets
 # define addtargets x,y,z      # build with additional targets x,y,z (e.g. x86_64-linux)
                                # http://sourceware.org/ml/binutils/2008-03/msg00162.html
-%bcond_without pax             # without PaX flags (for upstream bugreports)
-%bcond_without default_ld      # default ld instead of gold
-%bcond_without tests
-#
+%bcond_with    pax             # without PaX flags (for upstream bugreports)
+%bcond_without gold            # don't build gold (no C++ dependencies)
+%bcond_without default_bfd     # default ld.bfd instead of gold
+%bcond_without debuginfod      # debuginfo lokups with debuginfod
+%bcond_without gprofng         # gprofng
+%bcond_without jansson         # Package Metadata embedding support
+%bcond_without msgpack         # msgpack support
+%bcond_with    tests           # check target
+
+%ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
+%undefine      with_gold
+%endif
+%ifnarch %{ix86} %{x8664} aarch64
+%undefine      with_gprofng    1
+%endif
+
 Summary:       GNU Binary Utility Development Utilities
 Summary(de.UTF-8):     GNU Binary Utility Development Utilities
 Summary(es.UTF-8):     Utilitarios para desarrollo de binarios de la GNU
@@ -17,45 +30,51 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.22.52.0.4
-Release:       3
-Epoch:         3
+Version:       2.42
+Release:       1
+Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
-# http://git.kernel.org/?p=linux/kernel/git/hjl/binutils.git;a=summary
-# git archive --prefix=binutils-2.22.51.0.1/ -o binutils-2.22.51.0.1.tar remotes/origin/linux/release/2.22.51.0.1
-Source0:       http://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
-# Source0-md5: 2a5beea06d6f3e21107365b91184e11c
+Source0:       https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
+# Source0-md5: c1526faed7197b4e79dfe04eded7fc11
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
-Patch0:                %{name}-gasp.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-libtool-relink.patch
 Patch3:                %{name}-pt_pax_flags.patch
-Patch5:                %{name}-discarded.patch
+
 Patch6:                %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
-Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
 Patch10:       %{name}-sanity-check.patch
-URL:           http://sources.redhat.com/binutils/
-BuildRequires: autoconf >= 2.64
+URL:           http://www.sourceware.org/binutils/
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.11
 BuildRequires: bison
+%{?with_debuginfod:BuildRequires:      elfutils-debuginfod-devel >= 0.179}
 BuildRequires: flex
-BuildRequires: gettext-devel
-BuildRequires: libstdc++-devel >= 6:4.0-1
-%{?with_tests:BuildRequires:   libstdc++-static >= 6:4.0}
+BuildRequires: gettext-tools
+%{?with_jansson:BuildRequires: jansson-devel}
+%{?with_gold:BuildRequires:    libstdc++-devel >= 6:4.8.1}
+%{?with_tests:BuildRequires:   libstdc++-static >= 6:4.8.1}
+BuildRequires: lzip
+%{?with_msgpack:BuildRequires: msgpack-devel}
 BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.527
 %ifarch sparc sparc32
 BuildRequires: sparc32
 %endif
-BuildRequires: texinfo >= 4.2
+BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo >= 6.3
 BuildRequires: zlib-devel
 %{?with_tests:BuildRequires:   zlib-static}
+BuildRequires: zstd-devel
+%{?with_debuginfod:Requires:   elfutils-debuginfod-libs >= 0.179}
 Conflicts:     gcc-c++ < 5:3.3
 Conflicts:     modutils < 2.4.17
-Obsoletes:     binutils-gold
+Conflicts:     rpmbuild(macros) < 1.660
+Obsoletes:     binutils-gold < 3:2.21.51.0.7-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -68,8 +87,7 @@ Binutils is a collection of binary utilities, including:
 - size - list the section sizes of an object or archive file,
 - strings - list printable strings from files,
 - strip - discard symbols,
-- addr2line - convert addresses to file and line,
-- nlmconv - convert object code into an NLM.
+- addr2line - convert addresses to file and line.
 
 %description -l es.UTF-8
 Binutils es una colección de utilitarios necesarios para compilar
@@ -136,51 +154,107 @@ Static GNU binutils libraries (libbfd, libopcodes).
 %description static -l pl.UTF-8
 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
 
-%package gasp
-Summary:       GASP - old preprocessor for assembly programs
-Summary(pl.UTF-8):     GASP - stary preprocesor dla programów w asemblerze
+%package gprofng
+Summary:       GNU Next Generation profiler
+Summary(pl.UTF-8):     Narzędzie profilujące GNU Next Generation
 Group:         Development/Tools
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name}-gprofng-libs = %{epoch}:%{version}-%{release}
+Requires:      coreutils
+Requires:      hostname
+Requires:      perl-base >= 1:5.10.0
+Requires:      which
+
+%description gprofng
+Gprofng is the GNU Next Generation profiler for analyzing the
+performance of Linux applications. Gprofng allows you to:
+- Profile C / C++ / Java / Scala applications without needing to
+  recompile
+- Profile multi-threaded applications
+- Analyze and compare multiple experiments
+- Use time-based sampling and / or hardware event counters
+
+%description gprofng -l pl.UTF-8
+Gprofng jest narzędziem profilującym GNU Next Generation do analizy
+wydajności aplikacji w systemie Linux. Gprofng pozwala na:
+- Profilowanie aplikacji C / C++ / Java / Scala bez potrzeby ponownej
+  kompilacji
+- Profilowanie aplikacji wielowątkowych
+- Analizę i porównanie wielu eksperymentów
+- Użycie próbkowania w dziedzinie czasu i/lub sprzętowych liczników
+  zdarzeń
+
+%package gprofng-libs
+Summary:       GNU Next Generation profiler shared libraries
+Summary(pl.UTF-8):     Biblioteki narzędzia profilującego GNU Next Generation
+Group:         Libraries
+
+%description gprofng-libs
+GNU Next Generation profiler shared libraries.
+
+%description gprofng-libs -l pl.UTF-8
+Biblioteki narzędzia profilującego GNU Next Generation.
+
+%package gprofng-devel
+Summary:       Development files for GNU Next Generation profiler
+Summary(pl.UTF-8):     Pliki programistyczne bibliotek narzędzia profilującego GNU Next Generation
+Group:         Development/Libraries
+Requires:      %{name}-gprofng-libs = %{epoch}:%{version}-%{release}
+
+%description gprofng-devel
+Development files for GNU Next Generation profiler.
+
+%description gprofng-devel -l pl.UTF-8
+Pliki programistyczne bibliotek narzędzia profilującego GNU Next Generation.
+
+%package gprofng-static
+Summary:       GNU Next Generation profiler static libraries
+Summary(pl.UTF-8):     Biblioteki statyczne narzędzia profilującego GNU Next Generation
+Group:         Development/Libraries
+Requires:      %{name}-gprofng-devel = %{epoch}:%{version}-%{release}
 
-%description gasp
-GASP - old preprocessor for assembly programs. It's officially
-obsoleted, but it's still needed to build some packages.
+%description gprofng-static
+GNU Next Generation profiler static libraries.
 
-%description gasp -l pl.UTF-8
-GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
-uznany za przestarzały, ale jest nadal potrzebny do zbudowania
-niektórych pakietów.
+%description gprofng-static -l pl.UTF-8
+Biblioteki statyczne narzędzia profilującego GNU Next Generation.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
-%patch5 -p1
+
 %patch6 -p1
 %patch7 -p1
-%patch8 -p0
 %patch9 -p1
 %patch10 -p1
 
-# file contains hacks for ac 2.59 only
+%{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
+
+# file contains hacks for ac 2.69 only
 %{__rm} config/override.m4
 
 %build
 %{__aclocal}
 %{__autoconf}
 
-# non-standard regeneration (needed because of gasp patch)
+# non-standard regeneration
 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
 for dir in gas bfd; do
        cd $dir || exit 1
        %{__aclocal} -I .. -I ../config -I ../bfd
        %{__automake} Makefile
-       %{__automake} doc/Makefile
+       test -f doc/Makefile.am && %{__automake} doc/Makefile
        %{__autoconf}
        cd ..
 done
+cd libctf
+%{__aclocal} -I.. -I../config -I../bfd
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ..
 
 # More targets
 TARGETS=
@@ -194,6 +268,12 @@ TARGETS=x86_64-linux
 %ifarch sparc
 TARGETS=sparc64-linux
 %endif
+%ifarch %{x8664}
+TARGETS="x86_64-pep"
+%endif
+%ifarch x32
+TARGETS="x86_64-linux,x86_64-pep"
+%endif
 %{?addtargets:TARGETS="%{addtargets}"}
 
 cp -f /usr/share/automake/config.* .
@@ -205,49 +285,54 @@ CXX="%{__cxx}"; export CXX
 sparc32 \
 %endif
 ./configure %{_target_platform} \
-       --disable-debug \
-       --disable-werror \
-       --enable-build-warnings=,-Wno-missing-prototypes \
-       --enable-shared \
-       --enable-lto \
-       --enable-plugins \
-       --with-zlib=yes \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
-       --with-tooldir=%{_prefix} \
-       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --sysconfdir=%{_sysconfdir} \
+       --disable-debug \
+       --disable-silent-rules \
+       --disable-werror \
 %ifarch sparc
        --enable-64-bit-bfd \
 %else
        %{?with_allarchs:--enable-64-bit-bfd} \
 %endif
-       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout} \
-%ifarch %{ix86} %{x8664}
-       --enable-gold%{!?with_default_ld:=default} --enable-ld%{?with_default_ld:=default} \
+       --enable-build-warnings=,-Wno-missing-prototypes \
+       --enable-install-libiberty \
+       --enable-lto \
+       --enable-plugins \
+       --enable-shared \
+       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
+       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --with-tooldir=%{_prefix} \
+       --with-system-zlib \
+%if %{with gold}
+       --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
 %endif
+       %{__with_without msgpack} \
+       %{__enable_disable jansson} \
+       %{__with_without debuginfod}
 
-%{__make} -j1
+%{__make}
 
 %{?with_tests:%{__make} -j1 check}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{_infodir}/standards.info*
-
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
-install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
-install libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
+# overwrite libiberty.a with PIC version
+cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
 
 # remove evil -L pointing inside builder's home
 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
@@ -256,16 +341,23 @@ perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
+%if %{with gprofng}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/gprofng/libgp-collectorAPI.{a,la}
+%endif
+
+%if %{with gold}
+install -d gold-doc
+cp -p gold/{README,ChangeLog,TODO} gold-doc
+%endif
+
 %find_lang bfd
 %find_lang binutils
 %find_lang gas
 %find_lang gprof
-touch ld.lang
+touch ld.lang gold.lang
 %find_lang ld
-%ifarch %{ix86} %{x8664}
+%if %{with gold}
 %find_lang gold
-%else
-:> gold.lang
 %endif
 %find_lang opcodes
 cat bfd.lang opcodes.lang > %{name}-libs.lang
@@ -289,9 +381,19 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post  gprofng -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        gprofng -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%post  gprofng-libs -p /sbin/ldconfig
+%postun        gprofng-libs -p /sbin/ldconfig
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README
+%{?with_gold:%doc gold-doc}
 %attr(755,root,root) %{_bindir}/addr2line
 %attr(755,root,root) %{_bindir}/ar
 %attr(755,root,root) %{_bindir}/as
@@ -300,8 +402,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gprof
 %attr(755,root,root) %{_bindir}/ld
 %attr(755,root,root) %{_bindir}/ld.bfd
-%ifarch %{ix86} %{x8664}
+%if %{with gold}
 %attr(755,root,root) %{_bindir}/ld.gold
+%attr(755,root,root) %{_bindir}/dwp
 %endif
 %attr(755,root,root) %{_bindir}/nm
 %attr(755,root,root) %{_bindir}/objcopy
@@ -311,13 +414,29 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/size
 %attr(755,root,root) %{_bindir}/strings
 %attr(755,root,root) %{_bindir}/strip
+%{_prefix}/lib/ldscripts
 %{_infodir}/as.info*
 %{_infodir}/binutils.info*
-%{_infodir}/configure.info*
+%{_infodir}/ctf-spec.info*
 %{_infodir}/gprof.info*
 %{_infodir}/ld.info*
-%{_prefix}/lib/ldscripts
-%{_mandir}/man1/*
+%{_infodir}/ldint.info*
+%{_infodir}/sframe-spec.info*
+%{_mandir}/man1/addr2line.1*
+%{_mandir}/man1/ar.1*
+%{_mandir}/man1/as.1*
+%{_mandir}/man1/c++filt.1*
+%{_mandir}/man1/elfedit.1*
+%{_mandir}/man1/gprof.1*
+%{_mandir}/man1/ld.1*
+%{_mandir}/man1/nm.1*
+%{_mandir}/man1/objcopy.1*
+%{_mandir}/man1/objdump.1*
+%{_mandir}/man1/ranlib.1*
+%{_mandir}/man1/readelf.1*
+%{_mandir}/man1/size.1*
+%{_mandir}/man1/strings.1*
+%{_mandir}/man1/strip.1*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(de) %{_mandir}/de/man1/*
 %lang(es) %{_mandir}/es/man1/*
@@ -329,31 +448,90 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs -f %{name}-libs.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libbfd-*.so
-%attr(755,root,root) %{_libdir}/libopcodes-*.so
+%attr(755,root,root) %{_libdir}/libbfd-%{version}.so
+%attr(755,root,root) %{_libdir}/libctf.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libctf.so.0
+%attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
+%attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
+%attr(755,root,root) %{_libdir}/libsframe.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsframe.so.1
+%dir %{_libdir}/bfd-plugins
+%attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbfd.so
+%attr(755,root,root) %{_libdir}/libctf.so
+%attr(755,root,root) %{_libdir}/libctf-nobfd.so
 %attr(755,root,root) %{_libdir}/libopcodes.so
+%attr(755,root,root) %{_libdir}/libsframe.so
 %{_libdir}/libbfd.la
+%{_libdir}/libctf.la
+%{_libdir}/libctf-nobfd.la
 %{_libdir}/libopcodes.la
 %{_libdir}/libiberty.a
+%{_libdir}/libsframe.la
 %{_includedir}/ansidecl.h
 %{_includedir}/bfd.h
 %{_includedir}/bfdlink.h
+%{_includedir}/ctf-api.h
+%{_includedir}/ctf.h
+%{_includedir}/diagnostics.h
 %{_includedir}/dis-asm.h
-%{_includedir}/libiberty.h
 %{_includedir}/plugin-api.h
+%{_includedir}/sframe-api.h
+%{_includedir}/sframe.h
 %{_includedir}/symcat.h
+%{_includedir}/libiberty
 %{_infodir}/bfd.info*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libbfd.a
+%{_libdir}/libctf.a
+%{_libdir}/libctf-nobfd.a
 %{_libdir}/libopcodes.a
+%{_libdir}/libsframe.a
+
+%if %{with gprofng}
+%files gprofng
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc
+%attr(755,root,root) %{_bindir}/gp-archive
+%attr(755,root,root) %{_bindir}/gp-collect-app
+%attr(755,root,root) %{_bindir}/gp-display-html
+%attr(755,root,root) %{_bindir}/gp-display-src
+%attr(755,root,root) %{_bindir}/gp-display-text
+%attr(755,root,root) %{_bindir}/gprofng
+%{_infodir}/gprofng.info*
+%{_mandir}/man1/gp-archive.*
+%{_mandir}/man1/gp-collect-app.*
+%{_mandir}/man1/gp-display-html.*
+%{_mandir}/man1/gp-display-src.*
+%{_mandir}/man1/gp-display-text.*
+%{_mandir}/man1/gprofng.1*
+
+%files gprofng-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgprofng.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgprofng.so.0
+%dir %{_libdir}/gprofng
+%attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
+%attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
+%attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
+%attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
+%attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
+
+%files gprofng-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgprofng.so
+%{_libdir}/libgprofng.la
+%{_includedir}/collectorAPI.h
+%{_includedir}/libcollector.h
+%{_includedir}/libfcollector.h
 
-%files gasp
+%files gprofng-static
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gasp
-%{_infodir}/gasp.info*
+%attr(755,root,root) %{_libdir}/libgprofng.a
+%endif
This page took 0.135336 seconds and 4 git commands to generate.