]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
up to 2.42
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 %bcond_without  gold            # don't build gold (no C++ dependencies)
8 %bcond_without  default_bfd     # default ld.bfd instead of gold
9 %bcond_without  gasp            # gasp
10 %bcond_with     tests           # check target
11
12 %ifnarch %{ix86} %{x8664} x32
13 %undefine       with_gold
14 %endif
15
16 Summary:        GNU Binary Utility Development Utilities
17 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
18 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
19 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
20 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
21 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
22 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
23 Summary(tr.UTF-8):      GNU geliştirme araçları
24 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
25 Name:           binutils
26 Version:        2.31.1
27 Release:        4
28 Epoch:          4
29 License:        GPL v3+
30 Group:          Development/Tools
31 Source0:        http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
32 # Source0-md5:  a517a836dd5747cc9e64d81addc517ad
33 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
34 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
35 Patch0:         %{name}-gasp.patch
36 Patch1:         %{name}-info.patch
37 Patch2:         %{name}-libtool-relink.patch
38 Patch3:         %{name}-pt_pax_flags.patch
39 Patch4:         %{name}-libdir.patch
40
41 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
42 Patch7:         %{name}-libtool-m.patch
43 Patch8:         %{name}-build-id.patch
44 Patch9:         %{name}-tooldir.patch
45 Patch10:        %{name}-sanity-check.patch
46 Patch11:        binutils-bug-23499.patch
47 Patch12:        fd-leak.patch
48 URL:            http://sources.redhat.com/binutils/
49 BuildRequires:  autoconf >= 2.64
50 BuildRequires:  automake >= 1:1.11
51 BuildRequires:  bison
52 BuildRequires:  flex
53 BuildRequires:  gettext-tools
54 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
55 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
56 BuildRequires:  lzip
57 BuildRequires:  perl-tools-pod
58 %ifarch sparc sparc32
59 BuildRequires:  sparc32
60 %endif
61 BuildRequires:  tar >= 1:1.22
62 BuildRequires:  texinfo >= 4.2
63 BuildRequires:  zlib-devel
64 %{?with_tests:BuildRequires:    zlib-static}
65 Conflicts:      gcc-c++ < 5:3.3
66 Conflicts:      modutils < 2.4.17
67 Conflicts:      rpmbuild(macros) < 1.660
68 Obsoletes:      binutils-gold
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Binutils is a collection of binary utilities, including:
73 - ar - create, modify and extract from archives,
74 - nm - lists symbols from object files,
75 - objcopy - copy and translate object files,
76 - objdump - display information from object files,
77 - ranlib - generate an index for the contents of an archive,
78 - size - list the section sizes of an object or archive file,
79 - strings - list printable strings from files,
80 - strip - discard symbols,
81 - addr2line - convert addresses to file and line.
82
83 %description -l es.UTF-8
84 Binutils es una colección de utilitarios necesarios para compilar
85 programas. Incluye assembler y linker, así como varios otros programas
86 para trabajar con formatos que se puedan ejecutar.
87
88 %description -l pl.UTF-8
89 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
90 programów. Znajdują się tutaj między innymi assembler, konsolidator
91 (linker), a także inne narzędzia do manipulowania binarnymi plikami
92 programów i bibliotek.
93
94 %description -l pt_BR.UTF-8
95 binutils é uma coletânea de utilitários necessários para compilar
96 programas. Inclui assembler e linker, assim como vários outros
97 programas para trabalhar com formatos executáveis.
98
99 %description -l ru.UTF-8
100 binutils - это набор инструментов, необходимых для компилляции
101 программ. Включает ассемблер, компоновщик и набор других программ для
102 работы с исполняемыми файлами разнообразных форматов.
103
104 %description -l uk.UTF-8
105 binutils - це набір інструментів, необхідних для компіляції програм.
106 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
107 виконуваними файлами різних форматів.
108
109 %package libs
110 Summary:        GNU binutils shared libraries
111 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
112 Group:          Libraries
113 Conflicts:      binutils < 3:2.17.50.0.8-3
114
115 %description libs
116 GNU binutils shared libraries (libbfd, libopcodes).
117
118 %description libs -l pl.UTF-8
119 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
120
121 %package devel
122 Summary:        Development files for GNU binutils libraries
123 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
124 Group:          Development/Libraries
125 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
126
127 %description devel
128 Development files for GNU binutils libraries (libbfd, libopcodes) and
129 static libiberty library.
130
131 %description devel -l pl.UTF-8
132 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
133 statyczna biblioteka libiberty.
134
135 %package static
136 Summary:        GNU binutils static libraries
137 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
140 #Requires:      zlib-static
141
142 %description static
143 Static GNU binutils libraries (libbfd, libopcodes).
144
145 %description static -l pl.UTF-8
146 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
147
148 %package gasp
149 Summary:        GASP - old preprocessor for assembly programs
150 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
151 Group:          Development/Tools
152 Requires:       %{name} = %{epoch}:%{version}-%{release}
153
154 %description gasp
155 GASP - old preprocessor for assembly programs. It's officially
156 obsoleted, but it's still needed to build some packages.
157
158 %description gasp -l pl.UTF-8
159 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
160 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
161 niektórych pakietów.
162
163 %prep
164 %setup -q
165 %{?with_gasp:%patch0 -p1}
166 %patch1 -p1
167 %patch2 -p1
168 %{?with_pax:%patch3 -p1}
169 %patch4 -p1
170
171 %patch6 -p1
172 %patch7 -p1
173 %patch8 -p1
174 %patch9 -p1
175 %patch10 -p1
176 %patch11 -p1
177 %patch12 -p1
178
179 # file contains hacks for ac 2.59 only
180 %{__rm} config/override.m4
181
182 %build
183 %{__aclocal}
184 %{__autoconf}
185
186 # non-standard regeneration (needed because of gasp patch)
187 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
188 for dir in gas bfd; do
189         cd $dir || exit 1
190         %{__aclocal} -I .. -I ../config -I ../bfd
191         %{__automake} Makefile
192         %{__automake} doc/Makefile
193         %{__autoconf}
194         cd ..
195 done
196
197 # More targets
198 TARGETS=
199 %ifarch ia64
200 TARGETS=i686-linux
201 %endif
202 # uhm?
203 %ifarch %{ix86}
204 TARGETS=x86_64-linux
205 %endif
206 %ifarch sparc
207 TARGETS=sparc64-linux
208 %endif
209 %ifarch %{x8664}
210 TARGETS="x86_64-pep"
211 %endif
212 %ifarch x32
213 TARGETS="x86_64-linux,x86_64-pep"
214 %endif
215 %{?addtargets:TARGETS="%{addtargets}"}
216
217 cp -f /usr/share/automake/config.* .
218 CFLAGS="%{rpmcflags}"; export CFLAGS
219 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
220 CC="%{__cc}"; export CC
221 CXX="%{__cxx}"; export CXX
222 %ifarch sparc
223 sparc32 \
224 %endif
225 ./configure %{_target_platform} \
226         --prefix=%{_prefix} \
227         --libdir=%{_libdir} \
228         --infodir=%{_infodir} \
229         --mandir=%{_mandir} \
230         --disable-debug \
231         --disable-werror \
232 %ifarch sparc
233         --enable-64-bit-bfd \
234 %else
235         %{?with_allarchs:--enable-64-bit-bfd} \
236 %endif
237         --enable-build-warnings=,-Wno-missing-prototypes \
238         --enable-install-libiberty \
239         --enable-lto \
240         --enable-plugins \
241         --enable-shared \
242         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
243         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
244         --with-tooldir=%{_prefix} \
245         --with-zlib \
246 %if %{with gold}
247         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
248 %endif
249
250 %{__make} -j1
251
252 %{?with_tests:%{__make} -j1 check}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
257
258 %{__make} install \
259         DESTDIR=$RPM_BUILD_ROOT
260
261 # remove these man pages unless we cross-build for win*/netware platforms.
262 # however, this should be done in Makefiles.
263 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
264
265 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
266
267 # overwrite libiberty.a with PIC version
268 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
269
270 # remove evil -L pointing inside builder's home
271 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
272
273 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
274
275 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
276
277 %find_lang bfd
278 %find_lang binutils
279 %find_lang gas
280 %find_lang gprof
281 touch ld.lang gold.lang
282 %find_lang ld
283 %if %{with gold}
284 %find_lang gold
285 %endif
286 %find_lang opcodes
287 cat bfd.lang opcodes.lang > %{name}-libs.lang
288 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
289
290 %clean
291 rm -rf $RPM_BUILD_ROOT
292
293 %post   -p /sbin/postshell
294 -/usr/sbin/fix-info-dir -c %{_infodir}
295
296 %postun -p /sbin/postshell
297 -/usr/sbin/fix-info-dir -c %{_infodir}
298
299 %post   libs -p /sbin/ldconfig
300 %postun libs -p /sbin/ldconfig
301
302 %post   devel -p /sbin/postshell
303 -/usr/sbin/fix-info-dir -c %{_infodir}
304
305 %postun devel -p /sbin/postshell
306 -/usr/sbin/fix-info-dir -c %{_infodir}
307
308 %post   gasp -p /sbin/postshell
309 -/usr/sbin/fix-info-dir -c %{_infodir}
310
311 %postun gasp -p /sbin/postshell
312 -/usr/sbin/fix-info-dir -c %{_infodir}
313
314 %files -f %{name}.lang
315 %defattr(644,root,root,755)
316 %doc README
317 %{?with_gold:%doc gold/{ChangeLog,README,TODO}}
318 %attr(755,root,root) %{_bindir}/addr2line
319 %attr(755,root,root) %{_bindir}/ar
320 %attr(755,root,root) %{_bindir}/as
321 %attr(755,root,root) %{_bindir}/c++filt
322 %attr(755,root,root) %{_bindir}/elfedit
323 %attr(755,root,root) %{_bindir}/gprof
324 %attr(755,root,root) %{_bindir}/ld
325 %attr(755,root,root) %{_bindir}/ld.bfd
326 %if %{with gold}
327 %attr(755,root,root) %{_bindir}/ld.gold
328 %attr(755,root,root) %{_bindir}/dwp
329 %endif
330 %attr(755,root,root) %{_bindir}/nm
331 %attr(755,root,root) %{_bindir}/objcopy
332 %attr(755,root,root) %{_bindir}/objdump
333 %attr(755,root,root) %{_bindir}/ranlib
334 %attr(755,root,root) %{_bindir}/readelf
335 %attr(755,root,root) %{_bindir}/size
336 %attr(755,root,root) %{_bindir}/strings
337 %attr(755,root,root) %{_bindir}/strip
338 %{_prefix}/lib/ldscripts
339 %{_infodir}/as.info*
340 %{_infodir}/binutils.info*
341 %{_infodir}/gprof.info*
342 %{_infodir}/ld.info*
343 %{_mandir}/man1/addr2line.1*
344 %{_mandir}/man1/ar.1*
345 %{_mandir}/man1/as.1*
346 %{_mandir}/man1/c++filt.1*
347 %{_mandir}/man1/elfedit.1*
348 %{_mandir}/man1/gprof.1*
349 %{_mandir}/man1/ld.1*
350 %{_mandir}/man1/nm.1*
351 %{_mandir}/man1/objcopy.1*
352 %{_mandir}/man1/objdump.1*
353 %{_mandir}/man1/ranlib.1*
354 %{_mandir}/man1/readelf.1*
355 %{_mandir}/man1/size.1*
356 %{_mandir}/man1/strings.1*
357 %{_mandir}/man1/strip.1*
358 %lang(cs) %{_mandir}/cs/man1/*
359 %lang(de) %{_mandir}/de/man1/*
360 %lang(es) %{_mandir}/es/man1/*
361 %lang(fi) %{_mandir}/fi/man1/*
362 %lang(fr) %{_mandir}/fr/man1/*
363 %lang(hu) %{_mandir}/hu/man1/*
364 %lang(ja) %{_mandir}/ja/man1/*
365 %lang(pl) %{_mandir}/pl/man1/*
366
367 %files libs -f %{name}-libs.lang
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
370 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
371 %dir %{_libdir}/bfd-plugins
372
373 %files devel
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_libdir}/libbfd.so
376 %attr(755,root,root) %{_libdir}/libopcodes.so
377 %{_libdir}/libbfd.la
378 %{_libdir}/libopcodes.la
379 %{_libdir}/libiberty.a
380 %{_includedir}/ansidecl.h
381 %{_includedir}/bfd.h
382 %{_includedir}/bfdlink.h
383 %{_includedir}/diagnostics.h
384 %{_includedir}/dis-asm.h
385 %{_includedir}/plugin-api.h
386 %{_includedir}/symcat.h
387 %{_includedir}/libiberty
388 %{_infodir}/bfd.info*
389
390 %files static
391 %defattr(644,root,root,755)
392 %{_libdir}/libbfd.a
393 %{_libdir}/libopcodes.a
394
395 %if %{with gasp}
396 %files gasp
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_bindir}/gasp
399 %{_infodir}/gasp.info*
400 %endif
This page took 0.178344 seconds and 3 git commands to generate.