]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
up to 2.42
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 %bcond_without  gold            # don't build gold (no C++ dependencies)
8 %bcond_without  default_bfd     # default ld.bfd instead of gold
9 %bcond_without  gasp            # gasp
10 %bcond_with     tests           # check target
11
12 %ifnarch %{ix86} %{x8664} x32
13 %undefine       with_gold
14 %endif
15
16 Summary:        GNU Binary Utility Development Utilities
17 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
18 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
19 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
20 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
21 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
22 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
23 Summary(tr.UTF-8):      GNU geliştirme araçları
24 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
25 Name:           binutils
26 Version:        2.30
27 Release:        1
28 Epoch:          4
29 License:        GPL v3+
30 Group:          Development/Tools
31 Source0:        http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
32 # Source0-md5:  e64eb5655c6c2caa78677e19c84ba5b5
33 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
34 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
35 Patch0:         %{name}-gasp.patch
36 Patch1:         %{name}-info.patch
37 Patch2:         %{name}-libtool-relink.patch
38 Patch3:         %{name}-pt_pax_flags.patch
39 Patch4:         %{name}-libdir.patch
40 Patch5:         %{name}-discarded.patch
41 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
42 Patch7:         %{name}-libtool-m.patch
43 Patch8:         %{name}-build-id.patch
44 Patch9:         %{name}-tooldir.patch
45 Patch10:        %{name}-sanity-check.patch
46 Patch11:        %{name}-am.patch
47 URL:            http://sources.redhat.com/binutils/
48 BuildRequires:  autoconf >= 2.64
49 BuildRequires:  automake >= 1:1.11
50 BuildRequires:  bison
51 BuildRequires:  flex
52 BuildRequires:  gettext-tools
53 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
54 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
55 BuildRequires:  lzip
56 BuildRequires:  perl-tools-pod
57 %ifarch sparc sparc32
58 BuildRequires:  sparc32
59 %endif
60 BuildRequires:  tar >= 1:1.22
61 BuildRequires:  texinfo >= 4.2
62 BuildRequires:  zlib-devel
63 %{?with_tests:BuildRequires:    zlib-static}
64 Conflicts:      gcc-c++ < 5:3.3
65 Conflicts:      modutils < 2.4.17
66 Conflicts:      rpmbuild(macros) < 1.660
67 Obsoletes:      binutils-gold
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 Binutils is a collection of binary utilities, including:
72 - ar - create, modify and extract from archives,
73 - nm - lists symbols from object files,
74 - objcopy - copy and translate object files,
75 - objdump - display information from object files,
76 - ranlib - generate an index for the contents of an archive,
77 - size - list the section sizes of an object or archive file,
78 - strings - list printable strings from files,
79 - strip - discard symbols,
80 - addr2line - convert addresses to file and line,
81 - nlmconv - convert object code into an NLM.
82
83 %description -l es.UTF-8
84 Binutils es una colección de utilitarios necesarios para compilar
85 programas. Incluye assembler y linker, así como varios otros programas
86 para trabajar con formatos que se puedan ejecutar.
87
88 %description -l pl.UTF-8
89 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
90 programów. Znajdują się tutaj między innymi assembler, konsolidator
91 (linker), a także inne narzędzia do manipulowania binarnymi plikami
92 programów i bibliotek.
93
94 %description -l pt_BR.UTF-8
95 binutils é uma coletânea de utilitários necessários para compilar
96 programas. Inclui assembler e linker, assim como vários outros
97 programas para trabalhar com formatos executáveis.
98
99 %description -l ru.UTF-8
100 binutils - это набор инструментов, необходимых для компилляции
101 программ. Включает ассемблер, компоновщик и набор других программ для
102 работы с исполняемыми файлами разнообразных форматов.
103
104 %description -l uk.UTF-8
105 binutils - це набір інструментів, необхідних для компіляції програм.
106 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
107 виконуваними файлами різних форматів.
108
109 %package libs
110 Summary:        GNU binutils shared libraries
111 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
112 Group:          Libraries
113 Conflicts:      binutils < 3:2.17.50.0.8-3
114
115 %description libs
116 GNU binutils shared libraries (libbfd, libopcodes).
117
118 %description libs -l pl.UTF-8
119 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
120
121 %package devel
122 Summary:        Development files for GNU binutils libraries
123 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
124 Group:          Development/Libraries
125 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
126
127 %description devel
128 Development files for GNU binutils libraries (libbfd, libopcodes) and
129 static libiberty library.
130
131 %description devel -l pl.UTF-8
132 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
133 statyczna biblioteka libiberty.
134
135 %package static
136 Summary:        GNU binutils static libraries
137 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
140 #Requires:      zlib-static
141
142 %description static
143 Static GNU binutils libraries (libbfd, libopcodes).
144
145 %description static -l pl.UTF-8
146 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
147
148 %package gasp
149 Summary:        GASP - old preprocessor for assembly programs
150 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
151 Group:          Development/Tools
152 Requires:       %{name} = %{epoch}:%{version}-%{release}
153
154 %description gasp
155 GASP - old preprocessor for assembly programs. It's officially
156 obsoleted, but it's still needed to build some packages.
157
158 %description gasp -l pl.UTF-8
159 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
160 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
161 niektórych pakietów.
162
163 %prep
164 %setup -q
165 %{?with_gasp:%patch0 -p1}
166 %patch1 -p1
167 %patch2 -p1
168 %{?with_pax:%patch3 -p1}
169 %patch4 -p1
170 %patch5 -p1
171 %patch6 -p1
172 %patch7 -p1
173 %patch8 -p1
174 %patch9 -p1
175 %patch10 -p1
176 %patch11 -p1
177
178 # file contains hacks for ac 2.59 only
179 %{__rm} config/override.m4
180
181 %build
182 %{__aclocal}
183 %{__autoconf}
184
185 # non-standard regeneration (needed because of gasp patch)
186 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
187 for dir in gas bfd; do
188         cd $dir || exit 1
189         %{__aclocal} -I .. -I ../config -I ../bfd
190         %{__automake} Makefile
191         %{__automake} doc/Makefile
192         %{__autoconf}
193         cd ..
194 done
195
196 # More targets
197 TARGETS=
198 %ifarch ia64
199 TARGETS=i686-linux
200 %endif
201 # uhm?
202 %ifarch %{ix86}
203 TARGETS=x86_64-linux
204 %endif
205 %ifarch sparc
206 TARGETS=sparc64-linux
207 %endif
208 %ifarch %{x8664}
209 TARGETS="x86_64-pep"
210 %endif
211 %ifarch x32
212 TARGETS="x86_64-linux,x86_64-pep"
213 %endif
214 %{?addtargets:TARGETS="%{addtargets}"}
215
216 cp -f /usr/share/automake/config.* .
217 CFLAGS="%{rpmcflags}"; export CFLAGS
218 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
219 CC="%{__cc}"; export CC
220 CXX="%{__cxx}"; export CXX
221 %ifarch sparc
222 sparc32 \
223 %endif
224 ./configure %{_target_platform} \
225         --prefix=%{_prefix} \
226         --libdir=%{_libdir} \
227         --infodir=%{_infodir} \
228         --mandir=%{_mandir} \
229         --disable-debug \
230         --disable-werror \
231 %ifarch sparc
232         --enable-64-bit-bfd \
233 %else
234         %{?with_allarchs:--enable-64-bit-bfd} \
235 %endif
236         --enable-build-warnings=,-Wno-missing-prototypes \
237         --enable-install-libiberty \
238         --enable-lto \
239         --enable-plugins \
240         --enable-shared \
241         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
242         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
243         --with-tooldir=%{_prefix} \
244         --with-zlib \
245 %if %{with gold}
246         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
247 %endif
248
249 %{__make} -j1
250
251 %{?with_tests:%{__make} -j1 check}
252
253 %install
254 rm -rf $RPM_BUILD_ROOT
255 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
256
257 %{__make} install \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 # remove these man pages unless we cross-build for win*/netware platforms.
261 # however, this should be done in Makefiles.
262 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windmc,windres}.1
263
264 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
265
266 # overwrite libiberty.a with PIC version
267 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
268
269 # remove evil -L pointing inside builder's home
270 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
271
272 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
273
274 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
275
276 %find_lang bfd
277 %find_lang binutils
278 %find_lang gas
279 %find_lang gprof
280 touch ld.lang gold.lang
281 %find_lang ld
282 %if %{with gold}
283 %find_lang gold
284 %endif
285 %find_lang opcodes
286 cat bfd.lang opcodes.lang > %{name}-libs.lang
287 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
288
289 %clean
290 rm -rf $RPM_BUILD_ROOT
291
292 %post   -p /sbin/postshell
293 -/usr/sbin/fix-info-dir -c %{_infodir}
294
295 %postun -p /sbin/postshell
296 -/usr/sbin/fix-info-dir -c %{_infodir}
297
298 %post   libs -p /sbin/ldconfig
299 %postun libs -p /sbin/ldconfig
300
301 %post   devel -p /sbin/postshell
302 -/usr/sbin/fix-info-dir -c %{_infodir}
303
304 %postun devel -p /sbin/postshell
305 -/usr/sbin/fix-info-dir -c %{_infodir}
306
307 %post   gasp -p /sbin/postshell
308 -/usr/sbin/fix-info-dir -c %{_infodir}
309
310 %postun gasp -p /sbin/postshell
311 -/usr/sbin/fix-info-dir -c %{_infodir}
312
313 %files -f %{name}.lang
314 %defattr(644,root,root,755)
315 %doc README
316 %{?with_gold:%doc gold/{ChangeLog,README,TODO}}
317 %attr(755,root,root) %{_bindir}/addr2line
318 %attr(755,root,root) %{_bindir}/ar
319 %attr(755,root,root) %{_bindir}/as
320 %attr(755,root,root) %{_bindir}/c++filt
321 %attr(755,root,root) %{_bindir}/elfedit
322 %attr(755,root,root) %{_bindir}/gprof
323 %attr(755,root,root) %{_bindir}/ld
324 %attr(755,root,root) %{_bindir}/ld.bfd
325 %if %{with gold}
326 %attr(755,root,root) %{_bindir}/ld.gold
327 %attr(755,root,root) %{_bindir}/dwp
328 %endif
329 %attr(755,root,root) %{_bindir}/nm
330 %attr(755,root,root) %{_bindir}/objcopy
331 %attr(755,root,root) %{_bindir}/objdump
332 %attr(755,root,root) %{_bindir}/ranlib
333 %attr(755,root,root) %{_bindir}/readelf
334 %attr(755,root,root) %{_bindir}/size
335 %attr(755,root,root) %{_bindir}/strings
336 %attr(755,root,root) %{_bindir}/strip
337 %{_prefix}/lib/ldscripts
338 %{_infodir}/as.info*
339 %{_infodir}/binutils.info*
340 %{_infodir}/gprof.info*
341 %{_infodir}/ld.info*
342 %{_mandir}/man1/addr2line.1*
343 %{_mandir}/man1/ar.1*
344 %{_mandir}/man1/as.1*
345 %{_mandir}/man1/c++filt.1*
346 %{_mandir}/man1/elfedit.1*
347 %{_mandir}/man1/gprof.1*
348 %{_mandir}/man1/ld.1*
349 %{_mandir}/man1/nm.1*
350 %{_mandir}/man1/objcopy.1*
351 %{_mandir}/man1/objdump.1*
352 %{_mandir}/man1/ranlib.1*
353 %{_mandir}/man1/readelf.1*
354 %{_mandir}/man1/size.1*
355 %{_mandir}/man1/strings.1*
356 %{_mandir}/man1/strip.1*
357 %lang(cs) %{_mandir}/cs/man1/*
358 %lang(de) %{_mandir}/de/man1/*
359 %lang(es) %{_mandir}/es/man1/*
360 %lang(fi) %{_mandir}/fi/man1/*
361 %lang(fr) %{_mandir}/fr/man1/*
362 %lang(hu) %{_mandir}/hu/man1/*
363 %lang(ja) %{_mandir}/ja/man1/*
364 %lang(pl) %{_mandir}/pl/man1/*
365
366 %files libs -f %{name}-libs.lang
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
369 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
370 %dir %{_libdir}/bfd-plugins
371
372 %files devel
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/libbfd.so
375 %attr(755,root,root) %{_libdir}/libopcodes.so
376 %{_libdir}/libbfd.la
377 %{_libdir}/libopcodes.la
378 %{_libdir}/libiberty.a
379 %{_includedir}/ansidecl.h
380 %{_includedir}/bfd.h
381 %{_includedir}/bfdlink.h
382 %{_includedir}/dis-asm.h
383 %{_includedir}/plugin-api.h
384 %{_includedir}/symcat.h
385 %{_includedir}/libiberty
386 %{_infodir}/bfd.info*
387
388 %files static
389 %defattr(644,root,root,755)
390 %{_libdir}/libbfd.a
391 %{_libdir}/libopcodes.a
392
393 %if %{with gasp}
394 %files gasp
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_bindir}/gasp
397 %{_infodir}/gasp.info*
398 %endif
This page took 0.110825 seconds and 3 git commands to generate.