]> git.pld-linux.org Git - packages/bins.git/blobdiff - bins.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/bins.git] / bins.spec
index 7f112f6ac330a9442205723cb315fcae770d1493..db39287a682d9d1ce383cac9191311d498264795 100644 (file)
--- a/bins.spec
+++ b/bins.spec
@@ -1,19 +1,21 @@
 # TODO:
 # - add desktop and png icon for bins-edit-gui.
 #
-%include       /usr/lib/rpm/macros.perl
 Summary:       HTML photo album generator
-Summary(pl):   Generator albumów fotograficznych w HTML
+Summary(pl.UTF-8):     Generator albumów fotograficznych w HTML-u
 Name:          bins
-Version:       1.1.21
-Release:       4
+Version:       1.1.29
+Release:       1
 License:       GPL
 Group:         Applications/Graphics
-Source0:       http://jsautret.free.fr/BINS/%{name}-%{version}.tar.bz2
-# Source0-md5: a63dc5db4ec60b730066eefdea9b1748
+Source0:       http://zubro.chez.tiscali.fr/BINS/%{name}-%{version}.tar.bz2
+# Source0-md5: 3398d0ea3a97e49f5aaabb3b79da334a
 Patch0:                %{name}-localedir.patch
 Patch1:                %{name}-gladedir.patch
+Patch2:                %{name}-datadir.patch
+Patch3:                %{name}-po.patch
 URL:           http://bins.sautret.org/
+BuildRequires: gettext-tools
 BuildRequires: rpm-perlprov >= 3.0.3-18
 Requires:      ImageMagick
 BuildArch:     noarch
@@ -22,57 +24,71 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 The aim of BINS is to generate static HTML photo albums.
 
-%description -l pl
-BINS s³u¿y do generowania albumów fotograficznych w postaci statyczych
-stron HTML.
+%description -l pl.UTF-8
+BINS służy do generowania albumów fotograficznych w postaci
+statycznych stron HTML.
 
 %package edit-gui
 Summary:       Editor GUI for BINS
-Summary(pl):   Interfejs u¿ytkownika do edycji albumów BINS
+Summary(pl.UTF-8):     Interfejs użytkownika do edycji albumów BINS
 Group:         Applications/Graphics
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description edit-gui
 GUI for editing BINS albums.
 
-%description edit-gui -l pl
-Graficzny interfejs u¿ytkownika do edycji albumów BINS.
+%description edit-gui -l pl.UTF-8
+Graficzny interfejs użytkownika do edycji albumów BINS.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+# outdated
+rm -f intl/zh_TW.Big5.po
+rm -f intl/*.mo
+
+%build
+cd intl
+for L in *.po ; do
+       msgfmt -o `basename $L .po`.mo $L
+done
+cd -
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1} \
-          $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1} \
-          $RPM_BUILD_ROOT%{_datadir}/%{name} \
-          $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.default \
-          $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.joi \
-          $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.joi/static \
-          $RPM_BUILD_ROOT%{_datadir}/locale/{fr,de,pl}/LC_MESSAGES
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
+       $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1} \
+       $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 install bins bins_edit $RPM_BUILD_ROOT%{_bindir}
-install bins_cleanupgallery  $RPM_BUILD_ROOT%{_bindir}
+install tools/{anti_bins,bins_cleanupgallery,bins_addtext,bins_txt2xml} $RPM_BUILD_ROOT%{_bindir}
+install tools/add_num_prefix $RPM_BUILD_ROOT%{_bindir}/bins_add_num_prefix
+install tools/remove_num_prefix $RPM_BUILD_ROOT%{_bindir}/bins_remove_num_prefix
 install bins-edit-gui $RPM_BUILD_ROOT%{_bindir}
 install binsrc $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
-install templates/*.html $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.default
-install templates.joi/*.html $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.joi
-install templates.joi/static/* $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates.joi/static
+cp -r templates* $RPM_BUILD_ROOT%{_datadir}/%{name}
 install bins-edit-gui.glade $RPM_BUILD_ROOT%{_datadir}/%{name}
 install doc/{bins,bins_edit}.1 $RPM_BUILD_ROOT%{_mandir}/man1
 install doc/*gui*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
-for L in fr de pl ; do
-       install intl/$L.mo $RPM_BUILD_ROOT%{_datadir}/locale/$L/LC_MESSAGES/%{name}.mo
-       if [ -f intl/gui-$L.mo ] ; then
-               install intl/gui-$L.mo $RPM_BUILD_ROOT%{_datadir}/locale/$L/LC_MESSAGES/%{name}-edit-gui.mo
+cd intl
+for L in ??.mo ??_??.mo ; do
+       LL=`basename $L .mo`
+       install -d $RPM_BUILD_ROOT%{_datadir}/locale/$LL/LC_MESSAGES
+       install $LL.mo $RPM_BUILD_ROOT%{_datadir}/locale/$LL/LC_MESSAGES/%{name}.mo
+       if [ -f gui-$LL.mo ] ; then
+               install gui-$LL.mo $RPM_BUILD_ROOT%{_datadir}/locale/$LL/LC_MESSAGES/%{name}-edit-gui.mo
        fi
 done
+cd -
 
 %find_lang %{name}
-%find_lang %{name}-edit-gui
+# The only file here is empty...
+#%%find_lang %{name}-edit-gui
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -82,18 +98,22 @@ rm -rf $RPM_BUILD_ROOT
 %doc CREDITS ChangeLog README TODO doc/*.html
 %attr(755,root,root) %{_bindir}/bins
 %attr(755,root,root) %{_bindir}/bins_edit
+%attr(755,root,root) %{_bindir}/bins_add_num_prefix
+%attr(755,root,root) %{_bindir}/anti_bins
 %attr(755,root,root) %{_bindir}/bins_cleanupgallery
+%attr(755,root,root) %{_bindir}/bins_addtext
+%attr(755,root,root) %{_bindir}/bins_txt2xml
+%attr(755,root,root) %{_bindir}/bins_remove_num_prefix
 %dir %{_sysconfdir}/%{name}
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/binsrc
-%dir %{_sysconfdir}/%{name}/templates.default
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/templates.default/*
-%dir %{_sysconfdir}/%{name}/templates.joi
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/templates.joi/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/binsrc
+%dir %{_datadir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_datadir}/%{name}/templates*
 %{_mandir}/man1/bins.1*
 %{_mandir}/man1/bins_edit.1*
 
-%files edit-gui -f %{name}-edit-gui.lang
+#%files edit-gui -f %{name}-edit-gui.lang
+%files edit-gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/bins-edit-gui
+%{_datadir}/%{name}/bins-edit-gui.glade
 %{_mandir}/man1/bins-edit-gui.1*
-%{_datadir}/%{name}
This page took 0.236352 seconds and 4 git commands to generate.