]> git.pld-linux.org Git - packages/bind.git/blobdiff - bind.spec
- force tests
[packages/bind.git] / bind.spec
index 89a7cba94b0a8c72274ff3adea11917b879551a9..9dae7ce1b6f14cc29f8a79ca488fcd7855f401fd 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -1,15 +1,34 @@
 # TODO
-# - schema regstering in openldap-schema-bind
+# - apply http://www.caraytech.com/geodns/
 #
 # Conditional build:
 %bcond_without ssl             # build without OpenSSL support
 %bcond_without ipv6            # build without IPv6 support
 %bcond_without ldap            # build without LDAP support
+%bcond_without kerberos5       # build without kerneros5 support
 %bcond_without sql             # build without SQL support
 %bcond_without static_libs     # build without static libraries
 %bcond_without tests           # perform tests
+%bcond_with    edns_cli        # build with the ability to use edns-client-subnet in dig
 %bcond_with    hip             # build with HIP RR support
-#
+%if "%{pld_release}" == "ac"
+%bcond_with    epoll           # enable epoll support
+# there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
+%ifarch %{x8664}
+%define                with_epoll      1
+%endif
+%else
+%bcond_without epoll           # disable epoll support
+%endif
+
+%define                ver     9.9.3
+%if 0
+%define                pverdot .P2
+%define                pverdir -P2
+%else
+%define                pverdot %{nil}
+%define                pverdir %{nil}
+%endif
 Summary:       BIND - DNS name server
 Summary(de.UTF-8):     BIND - DNS-Namenserver
 Summary(es.UTF-8):     BIND - Servidor de nombres DNS
@@ -21,48 +40,53 @@ Summary(tr.UTF-8):  DNS alan adı sunucusu
 Summary(uk.UTF-8):     BIND - cервер системи доменних імен (DNS)
 Summary(zh_CN.UTF-8):  Internet 域名服务器
 Name:          bind
-Version:       9.4.1
-Release:       6
-Epoch:         6
+Version:       %{ver}%{pverdot}
+Release:       1
+Epoch:         7
 License:       BSD-like
 Group:         Networking/Daemons
-Source0:       ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 09b54d35036cb0423b2e618f21766285
-Source1:       %{name}-conf.tar.gz
-# Source1-md5: 8ee77729f806fcd548fe0cceb34b4a06
-Source2:       named.init
-Source3:       named.sysconfig
-Source4:       named.logrotate
-Source5:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
-# Source5-md5: 35b1dfaa12615c9802126ee833e0e7f7
-Source6:       http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
-# Source6-md5: 49fe799c6eca54ae227b22d57ebc1145
-Source7:       %{name}-hip.tar.gz
-# Source7-md5: 62a8a67f51ff8db9fe815205416a1f62
+Source0:       ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
+# Source0-md5: 7baa8359f0773e04f63d7e694db1909c
+Source1:       named.init
+Source2:       named.sysconfig
+Source3:       named.logrotate
+Source4:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
+# Source4-md5: 35b1dfaa12615c9802126ee833e0e7f7
+Source5:       http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
+# Source5-md5: 49fe799c6eca54ae227b22d57ebc1145
+Source6:       %{name}-hip.tar.gz
+# Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
+Source7:       ftp://rs.internic.net/domain/root.zone
+# Source7-md5: 2b06fa74e9415aaf02269160d95fa01a
+Source8:       %{name}-127.0.0.zone
+Source9:       %{name}-localhost.zone
+Source10:      %{name}-named.conf
+Source11:      %{name}.tmpfiles
+Source12:      named.service
 Patch0:                %{name}-time.patch
-Patch1:                %{name}-autoconf.patch
-Patch2:                %{name}-includedir-libbind.patch
-Patch3:                %{name}-link.patch
-Patch4:                %{name}-pmake.patch
-Patch5:                %{name}-sdb-ldap.patch
-Patch6:                %{name}-noinet6.patch
-Patch7:                %{name}-getifaddrs.patch
-Patch8:                %{name}-dighost_asccheck.patch
-Patch9:                %{name}-chroot-numcpus.patch
-URL:           http://www.isc.org/products/BIND/bind9.html
-BuildRequires: autoconf
+Patch1:                %{name}-link.patch
+Patch2:                %{name}-pmake.patch
+Patch3:                %{name}-sdb-ldap.patch
+Patch4:                %{name}-ac-libs.patch
+Patch5:                %{name}-edns-client-subnet.patch
+Patch6:         nsupdate_segfault.patch
+URL:           https://www.isc.org/software/bind
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: idnkit-devel
-%{?with_hip:BuildRequires:     libxml2-devel}
 BuildRequires: libtool
-%{?with_ldap:BuildRequires:    openldap-devel}
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+%{?with_hip:BuildRequires:     libxml2-devel}
 %{?with_sql:BuildRequires:     mysql-devel}
+%{?with_ldap:BuildRequires:    openldap-devel}
+%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.8d}
 %{?with_sql:BuildRequires:     postgresql-devel}
-BuildRequires: unixODBC-devel
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: readline-devel
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.647
+%{?with_sql:BuildRequires:     unixODBC-devel}
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
@@ -74,14 +98,18 @@ Requires(pre):      fileutils
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.2.0
+Requires:      systemd-units >= 38
+Requires:      uname(release) >= 2.2.18
 Provides:      group(named)
 Provides:      nameserver
 Provides:      user(named)
 Obsoletes:     caching-nameserver
 Conflicts:     %{name}-chroot
-Conflicts:     kernel < 2.2.18
+Conflicts:     logrotate < 3.8.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                schemadir       /usr/share/openldap/schema
+
 %description
 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
 (Domain Name System) protocols. BIND includes a DNS server (named),
@@ -321,8 +349,9 @@ BIND.
 Summary:       BIND schema for openldap
 Summary(pl.UTF-8):     Schemat BIND dla openldap
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires(post,postun): sed >= 4.0
 Requires:      openldap-servers
+Requires:      sed >= 4.0
 
 %description -n openldap-schema-bind
 BIND schema for openldap.
@@ -331,34 +360,29 @@ BIND schema for openldap.
 Schemat BIND dla openldap.
 
 %prep
-%setup -q -a1 %{?with_hip:-a7}
+%setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%{?with_ldap:%patch3 -p1}
 %patch4 -p1
-%{?with_ldap:%patch5 -p1}
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%patch9 -p1
 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
+%patch6 -p0
+
+%{?with_edns_cli:%patch5 -p0}
 
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
-cd lib/bind
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-cd ../..
+cp -f /usr/share/automake/config.* .
 %configure \
+       CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
        --with-idn \
        --with-libtool \
-       %{?with_ssl:--with-openssl=%{_prefix}} \
+       %{?with_ssl:--with-openssl} \
        %{?with_ipv6:--enable-ipv6} \
-       --enable-libbind \
+       %{?with_kerberos5:--with-gssapi} \
        %{?with_sql:--with-dlz-postgres=yes} \
        %{?with_sql:--with-dlz-mysql=yes} \
        --with-dlz-bdb=no \
@@ -367,55 +391,69 @@ cd ../..
        --with-dlz-odbc=no \
        --with-dlz-stub=yes \
        --enable-largefile \
+       %{!?with_epoll:--disable-epoll --disable-devpoll} \
        %{!?with_static_libs:--enable-static=no} \
        --enable-threads \
-       --enable-getifaddrs=glibc
+       --enable-getifaddrs \
+       --enable-newstats
 
 %{__make}
 %{?with_hip:cd bind-hip/; %{__make}}
 
-%{?with_tests:%{__make} test}
+%{?with_tests:%{__make} test-force}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
-       $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run,log}}
+       $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
+       $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f doc/rfc/rfc*
-
-bzip2 -dc %{SOURCE5} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
 
-install conf-pld/*.zone                        $RPM_BUILD_ROOT%{_var}/lib/named/M
-install conf-pld/*.hint                        $RPM_BUILD_ROOT%{_var}/lib/named
-install conf-pld/*.conf                        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}
-install bin/tests/named.conf           EXAMPLE-CONFIG-named
-install bin/tests/ndc.conf             EXAMPLE-CONFIG-ndc
-install %{SOURCE2}                     $RPM_BUILD_ROOT/etc/rc.d/init.d/named
-install %{SOURCE3}                     $RPM_BUILD_ROOT/etc/sysconfig/named
-install %{SOURCE4}                     $RPM_BUILD_ROOT/etc/logrotate.d/named
+cp -p bin/tests/named.conf             EXAMPLE-CONFIG-named
+cp -p bin/tests/ndc.conf               EXAMPLE-CONFIG-ndc
+install -p %{SOURCE1}                  $RPM_BUILD_ROOT/etc/rc.d/init.d/named
+cp -p %{SOURCE2}                       $RPM_BUILD_ROOT/etc/sysconfig/named
+cp -p %{SOURCE3}                       $RPM_BUILD_ROOT/etc/logrotate.d/named
+cp -p %{SOURCE7}                       $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
+cp -p %{SOURCE8}                       $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
+cp -p %{SOURCE9}                       $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
+cp -p %{SOURCE10}                      $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
+mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
 
 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
+ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
 ln -sf %{_var}/lib/named/named.log     $RPM_BUILD_ROOT%{_var}/log/named
 ln -sf %{_var}/lib/named/named.stats   $RPM_BUILD_ROOT%{_var}/log/named.stats
 
 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
 
-%{?with_ldap:install -d $RPM_BUILD_ROOT%{_datadir}/openldap/schema}
-%{?with_ldap:install %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/openldap/schema/dnszone.schema}
-%{?with_hip:install bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
+install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
+install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+
+%if %{with ldap}
+install -d $RPM_BUILD_ROOT%{schemadir}
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
+%endif
+
+%{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
 
 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
 
+# let rpm generate deps (workaround -m644 used for libs installation)
+chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
+
 # we don't want Makefiles in documentation...
-# FIXME: breaks re-entrant install
-#rm -f doc/misc/Makefile*
+rm -rf _doc
+cp -a doc _doc
+rm -f _doc/misc/Makefile*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -424,7 +462,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -f %{_sysconfdir}/named.boot ]; then
        cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
        mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
-       echo "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave." 1>&2
+       echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
 fi
 %groupadd -g 58 named
 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
@@ -432,58 +470,102 @@ fi
 %post
 /sbin/chkconfig --add named
 %service named restart
+%systemd_post named.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service named stop
        /sbin/chkconfig --del named
 fi
+%systemd_preun named.service
 
 %postun
 if [ "$1" = "0" ]; then
        %userremove named
        %groupremove named
 fi
+%systemd_reload
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%triggerpostun -- %{name} < 6:9.4.1
-sed -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
-sed -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
-sed -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+%post -n openldap-schema-bind
+%openldap_schema_register %{schemadir}/dnszone.schema
+%service -q ldap restart
+
+%postun -n openldap-schema-bind
+if [ "$1" = "0" ]; then
+       %openldap_schema_unregister %{schemadir}/dnszone.schema
+       %service -q ldap restart
+fi
+
+%triggerpostun -- %{name} < 7:9.4.2-2
+/sbin/chkconfig named reset
+%{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+%{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+%{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+
+%triggerpostun -- %{name} < 7:9.9.2.P2-2
+%systemd_trigger named.service
 
 %files
 %defattr(644,root,root,755)
-%doc README EXAMPLE-CONFIG-* FAQ doc/misc/* doc/arm/*.html doc/rfc/index %{?with_ldap:doc/*.sdb-ldap} %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
+%doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
+%doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
 
+%{systemdunitdir}/named.service
 %attr(754,root,root) /etc/rc.d/init.d/named
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
+%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
 
-%attr(755,root,root) %{_sbindir}/*
-
-%{_mandir}/man8/dns*
-%{_mandir}/man8/lwres*
-%{_mandir}/man8/named*
-%{_mandir}/man8/rndc*
-%{_mandir}/man5/rndc*
-%{_mandir}/man5/named.conf*
+%attr(755,root,root) %{_sbindir}/arpaname
+%attr(755,root,root) %{_sbindir}/ddns-confgen
+%attr(755,root,root) %{_sbindir}/dnssec-*
+%attr(755,root,root) %{_sbindir}/genrandom
+%attr(755,root,root) %{_sbindir}/isc-hmac-fixup
+%attr(755,root,root) %{_sbindir}/lwresd
+%attr(755,root,root) %{_sbindir}/named
+%attr(755,root,root) %{_sbindir}/named-*
+%attr(755,root,root) %{_sbindir}/nsec3hash
+%attr(755,root,root) %{_sbindir}/rndc
+%attr(755,root,root) %{_sbindir}/rndc-confgen
+
+%{_mandir}/man1/arpaname.1*
+%{_mandir}/man5/named.conf.5*
+%{_mandir}/man5/rndc.conf.5*
+%{_mandir}/man8/ddns-confgen.8*
+%{_mandir}/man8/dnssec-*.8*
+%{_mandir}/man8/genrandom.8*
+%{_mandir}/man8/isc-hmac-fixup.8*
+%{_mandir}/man8/lwresd.8*
+%{_mandir}/man8/named.8*
+%{_mandir}/man8/named-*.8*
+%{_mandir}/man8/nsec3hash.8*
+%{_mandir}/man8/rndc.8*
+%{_mandir}/man8/rndc-confgen.8*
 %lang(ja) %{_mandir}/ja/man8/named*
 
+%{systemdtmpfilesdir}/%{name}.conf
+
 %attr(770,root,named) %dir %{_var}/lib/named
 %attr(770,root,named) %dir %{_var}/lib/named/D
 %attr(750,root,named) %dir %{_var}/lib/named/M
 %attr(770,root,named) %dir %{_var}/lib/named/S
-%attr(750,root,named) %dir %{_var}/lib/named%{_sysconfdir}
+%attr(750,root,named) %dir %{_var}/lib/named/etc
+%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
+%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
+%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
+%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
+%attr(660,named,named) %ghost %{_var}/lib/named/named.log
+%attr(660,named,named) %ghost %{_var}/lib/named/named.stats
+
+%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
+%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
 
-%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*
-%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.*
-%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named%{_sysconfdir}/*
-%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named*
-%attr(660,named,named) %ghost  %{_var}/lib/named/named.log
-%attr(660,named,named) %ghost  %{_var}/lib/named/named.stats
+%attr(770,root,named) %dir %{_var}/run/named
+%attr(770,root,named) %dir %{_var}/run/lwresd
 
 %files utils
 %defattr(644,root,root,755)
@@ -495,7 +577,7 @@ sed -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/et
 %{_mandir}/man1/dig.1*
 %{_mandir}/man1/host.1*
 %{_mandir}/man1/nslookup.1*
-%{_mandir}/man8/nsupdate.8*
+%{_mandir}/man1/nsupdate.1*
 
 %lang(fi) %{_mandir}/fi/man1/host.1*
 
@@ -512,24 +594,57 @@ sed -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/et
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so.*.*
+%attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
+%attr(755,root,root) %{_libdir}/libdns.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
+%attr(755,root,root) %{_libdir}/libisc.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
+%attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
+%attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
+%attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*.sh
-%attr(755,root,root) %{_libdir}/*.so
-%{_libdir}/*.la
-%{_includedir}/*
-%{_mandir}/man3/*
+%attr(755,root,root) %{_bindir}/isc-config.sh
+%attr(755,root,root) %{_libdir}/libbind9.so
+%attr(755,root,root) %{_libdir}/libdns.so
+%attr(755,root,root) %{_libdir}/libisc.so
+%attr(755,root,root) %{_libdir}/libisccc.so
+%attr(755,root,root) %{_libdir}/libisccfg.so
+%attr(755,root,root) %{_libdir}/liblwres.so
+%{_libdir}/libbind9.la
+%{_libdir}/libdns.la
+%{_libdir}/libisc.la
+%{_libdir}/libisccc.la
+%{_libdir}/libisccfg.la
+%{_libdir}/liblwres.la
+%{_includedir}/bind9
+%{_includedir}/dns
+%{_includedir}/dst
+%{_includedir}/isc
+%{_includedir}/isccc
+%{_includedir}/isccfg
+%{_includedir}/lwres
+%{_mandir}/man1/isc-config.sh.1*
+%{_mandir}/man3/lwres*.3*
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libbind9.a
+%{_libdir}/libdns.a
+%{_libdir}/libisc.a
+%{_libdir}/libisccc.a
+%{_libdir}/libisccfg.a
+%{_libdir}/liblwres.a
 %endif
 
 %if %{with ldap}
 %files -n openldap-schema-bind
 %defattr(644,root,root,755)
-%{_datadir}/openldap/schema/*.schema
+%{_datadir}/openldap/schema/dnszone.schema
 %endif
This page took 0.129834 seconds and 4 git commands to generate.