]> git.pld-linux.org Git - packages/bind.git/blobdiff - bind.spec
- up to 9.12.3-P1; fixes dnssec related issue
[packages/bind.git] / bind.spec
index c21083340d13ddc7c2d3a21ebc7144b163602494..14a846504f75118ba38a53c23b257b58ff0de937 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -2,17 +2,20 @@
 # - apply http://www.caraytech.com/geodns/
 #
 # Conditional build:
-%bcond_without ssl             # build without OpenSSL support
-%bcond_without ipv6            # build without IPv6 support
-%bcond_with    ldap            # build without LDAP support
-%bcond_without kerberos5       # build without kerneros5 support
-%bcond_without sql             # build without SQL support
-%bcond_without static_libs     # build without static libraries
-%bcond_without tests           # perform tests
-%bcond_with    edns_cli        # build with the ability to use edns-client-subnet in dig
-%bcond_with    hip             # build with HIP RR support
-%bcond_without geoip           # build with GeoIP support
-%bcond_with    seccomp         # seccomp
+%bcond_without geoip           # GeoIP support
+%bcond_without ipv6            # IPv6 support
+%bcond_without kerberos5       # GSS-API support
+%bcond_without ssl             # OpenSSL support
+%bcond_with    ldap            # LDAP DLZ support
+%bcond_with    odbc            # ODBC DLZ support
+%bcond_without sql             # SQL (MySQL+PostgreSQL) DLZ support
+%bcond_without lmdb            # LMDB storage support for addzone zones
+%bcond_without static_libs     # static libraries
+%bcond_with    system_tests    # system tests (require root to configure localhost IPs)
+%bcond_without tests           # unit tests
+%bcond_with    edns_cli        # ability to use edns-client-subnet in dig
+%bcond_with    hip             # HIP RR support
+%bcond_with    seccomp         # libseccomp system call filtering
 
 %if "%{pld_release}" == "ac"
 %bcond_with    epoll           # enable epoll support
@@ -24,8 +27,8 @@
 %bcond_without epoll           # disable epoll support
 %endif
 
-%define                ver     9.12.0
-%if 0
+%define                ver     9.12.3
+%if 1
 %define                pverdot .P1
 %define                pverdir -P1
 %else
@@ -44,12 +47,12 @@ Summary(uk.UTF-8):  BIND - cервер системи доменних імен (
 Summary(zh_CN.UTF-8):  Internet 域名服务器
 Name:          bind
 Version:       %{ver}%{pverdot}
-Release:       4
+Release:       1
 Epoch:         7
 License:       MPL 2.0
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
-# Source0-md5: 8679dd7a45920cea3761c5586d84244b
+# Source0-md5: 6a73280ad5ad0dfeab611de04aefd35e
 Source1:       named.init
 Source2:       named.sysconfig
 Source3:       named.logrotate
@@ -59,8 +62,8 @@ Source5:      http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
 # Source5-md5: 49fe799c6eca54ae227b22d57ebc1145
 Source6:       %{name}-hip.tar.gz
 # Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
-Source7:       ftp://rs.internic.net/domain/root.zone
-# Source7-md5: f41bb1c130257be93ea60b5ab00c3d9d
+Source7:       https://www.internic.net/domain/named.root
+# Source7-md5: a2d36ae713cf5e8ea59641b320b6ec5d
 Source8:       %{name}-127.0.0.zone
 Source9:       %{name}-localhost.zone
 Source10:      %{name}-named.conf
@@ -80,10 +83,12 @@ BuildRequires:      bison
 BuildRequires: flex
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: idnkit-devel
+BuildRequires: json-c-devel
+BuildRequires: libidn2-devel
 %{?with_seccomp:BuildRequires: libseccomp-devel}
 BuildRequires: libtool
 %{?with_hip:BuildRequires:     libxml2-devel}
+%{?with_lmdb:BuildRequires:    lmdb-devel}
 %{?with_sql:BuildRequires:     mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.8d}
@@ -93,7 +98,8 @@ BuildRequires:        python3-ply
 BuildRequires: readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.647
-%{?with_sql:BuildRequires:     unixODBC-devel}
+%{?with_odbc:BuildRequires:    unixODBC-devel}
+BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
@@ -391,7 +397,7 @@ BIND-a.
 %patch2 -p1
 %{?with_ldap:%patch3 -p1}
 %patch4 -p1
-%{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
+%{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
 %{?with_edns_cli:%patch5 -p0}
 %patch6 -p0
 
@@ -402,32 +408,40 @@ BIND-a.
 cp -f /usr/share/automake/config.* .
 %configure \
        CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
-       --with-idn \
-       --with-libtool \
-       %{?with_ssl:--with-openssl} \
-       %{?with_ipv6:--enable-ipv6} \
-       %{?with_kerberos5:--with-gssapi} \
-       %{?with_sql:--with-dlz-postgres=yes} \
-       %{?with_sql:--with-dlz-mysql=yes} \
-       --with-dlz-bdb=no \
-       --with-dlz-filesystem=yes \
-       %{?with_ldap:--with-dlz-ldap=yes} \
-       %{?with_geoip:--with-geoip=yes} \
-       --with-dlz-odbc=no \
-       --with-dlz-stub=yes \
-       --enable-largefile \
        %{!?with_epoll:--disable-epoll --disable-devpoll} \
-       %{!?with_static_libs:--enable-static=no} \
-       --enable-threads \
-       --enable-getifaddrs \
        --enable-full-report \
+       --enable-getifaddrs \
+       %{?with_ipv6:--enable-ipv6} \
+       --enable-largefile \
        %{__enable_disable seccomp} \
+       %{!?with_static_libs:--disable-static} \
+       --enable-threads \
+       %{?with_kerberos5:--with-gssapi} \
+       --with-libidn2 \
+       --with-libtool \
+       %{?with_ssl:--with-openssl} \
+       %{?with_sql:--with-dlz-postgres} \
+       %{?with_sql:--with-dlz-mysql} \
+       --without-dlz-bdb \
+       --with-dlz-filesystem \
+       %{?with_ldap:--with-dlz-ldap} \
+       --with-dlz-odbc%{!?with_odbc:=no} \
+       --with-dlz-stub \
+       %{?with_geoip:--with-geoip} \
+       --with-lmdb%{!?with_lmdb:=no} \
        --with-python=%{__python3}
 
 %{__make}
-%{?with_hip:cd bind-hip/; %{__make}}
 
-%{?with_tests:%{__make} test-force}
+%{?with_hip:%{__make} -C bind-hip}
+
+%if %{with tests}
+%if %{with system_tests}
+%{__make} test-force
+%else
+sh unit/unittest.sh
+%endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -445,7 +459,6 @@ bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
 
 cp -p bin/tests/named.conf             EXAMPLE-CONFIG-named
-cp -p bin/tests/ndc.conf               EXAMPLE-CONFIG-ndc
 install -p %{SOURCE1}                  $RPM_BUILD_ROOT/etc/rc.d/init.d/named
 cp -p %{SOURCE2}                       $RPM_BUILD_ROOT/etc/sysconfig/named
 cp -p %{SOURCE3}                       $RPM_BUILD_ROOT/etc/logrotate.d/named
@@ -628,19 +641,19 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libbind9.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libbind9.so.1201
 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libdns.so.1201
+%attr(755,root,root) %ghost %{_libdir}/libdns.so.1207
 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libirs.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libirs.so.1201
 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisc.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisc.so.1204
 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisccc.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisccc.so.1201
 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1203
 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libns.so.1202
+%attr(755,root,root) %ghost %{_libdir}/libns.so.1205
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.126079 seconds and 4 git commands to generate.