]> git.pld-linux.org Git - packages/bind.git/blobdiff - bind.spec
geoip patch requires --with-geoip=yes configure
[packages/bind.git] / bind.spec
index 3349a69f3c81db5fdcfb0322b06d6dc3750cd323..1401c4caf2b0dfbac309883f555397279c199cec 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -11,6 +11,8 @@
 %bcond_without tests           # perform tests
 %bcond_with    edns_cli        # build with the ability to use edns-client-subnet in dig
 %bcond_with    hip             # build with HIP RR support
+%bcond_with    geoip           # build with GeoIP patch, https://code.google.com/p/bind-geoip/
+
 %if "%{pld_release}" == "ac"
 %bcond_with    epoll           # enable epoll support
 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
@@ -21,8 +23,8 @@
 %bcond_without epoll           # disable epoll support
 %endif
 
-%define                ver     9.9.3
-%if 1
+%define                ver     9.9.4
+%if 0
 %define                pverdot .P1
 %define                pverdir -P1
 %else
@@ -41,12 +43,12 @@ Summary(uk.UTF-8):  BIND - cервер системи доменних імен (
 Summary(zh_CN.UTF-8):  Internet 域名服务器
 Name:          bind
 Version:       %{ver}%{pverdot}
-Release:       1
+Release:       2
 Epoch:         7
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
-# Source0-md5: cf9cd9238d7bc15f1b4a5a5fff90f0d4
+# Source0-md5: f69757adc86776daed8e5acb0ee7c0ca
 Source1:       named.init
 Source2:       named.sysconfig
 Source3:       named.logrotate
@@ -57,7 +59,7 @@ Source5:      http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
 Source6:       %{name}-hip.tar.gz
 # Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
 Source7:       ftp://rs.internic.net/domain/root.zone
-# Source7-md5: faed23c2b8a71f40cf8a15cab5e26253
+# Source7-md5: cc31f5311962922a121b27fc85db4629
 Source8:       %{name}-127.0.0.zone
 Source9:       %{name}-localhost.zone
 Source10:      %{name}-named.conf
@@ -69,7 +71,9 @@ Patch2:               %{name}-pmake.patch
 Patch3:                %{name}-sdb-ldap.patch
 Patch4:                %{name}-ac-libs.patch
 Patch5:                %{name}-edns-client-subnet.patch
-Patch6:         nsupdate_segfault.patch
+Patch6:                nsupdate_segfault.patch
+# https://code.google.com/p/bind-geoip/
+Patch7:                %{name}-geoip.patch
 URL:           https://www.isc.org/software/bind
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -370,9 +374,9 @@ Schemat BIND dla openldap.
 %{?with_ldap:%patch3 -p1}
 %patch4 -p1
 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
-%patch6 -p0
-
 %{?with_edns_cli:%patch5 -p0}
+%patch6 -p0
+%{?with_geoip:%patch7 -p0}
 
 %build
 %{__libtoolize}
@@ -391,6 +395,7 @@ cp -f /usr/share/automake/config.* .
        --with-dlz-bdb=no \
        --with-dlz-filesystem=yes \
        %{?with_ldap:--with-dlz-ldap=yes} \
+       %{?with_geoip:--with-geoip=yes} \
        --with-dlz-odbc=no \
        --with-dlz-stub=yes \
        --enable-largefile \
@@ -398,7 +403,8 @@ cp -f /usr/share/automake/config.* .
        %{!?with_static_libs:--enable-static=no} \
        --enable-threads \
        --enable-getifaddrs \
-       --enable-newstats
+       --enable-newstats \
+       --enable-full-report
 
 %{__make}
 %{?with_hip:cd bind-hip/; %{__make}}
@@ -416,8 +422,9 @@ install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}}
        DESTDIR=$RPM_BUILD_ROOT
 
 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
-%{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
+%{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
 
 cp -p bin/tests/named.conf             EXAMPLE-CONFIG-named
 cp -p bin/tests/ndc.conf               EXAMPLE-CONFIG-ndc
@@ -600,7 +607,7 @@ fi
 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
+%attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9][0-9]
 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
This page took 0.087796 seconds and 4 git commands to generate.