]> git.pld-linux.org Git - packages/bind.git/blobdiff - bind.spec
- up to 9.4.2
[packages/bind.git] / bind.spec
index 1cd7915e691c2832b6dfe206dbe14295a24884ee..0f1aee47adffd8963084a1f8fa4a66ab6b9a6fa2 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -5,7 +5,9 @@
 %bcond_without ssl             # build without OpenSSL support
 %bcond_without ipv6            # build without IPv6 support
 %bcond_without ldap            # build without LDAP support
+%bcond_without sql             # build without SQL support
 %bcond_without static_libs     # build without static libraries
+%bcond_without tests           # perform tests
 %bcond_with    hip             # build with HIP RR support
 #
 Summary:       BIND - DNS name server
@@ -19,15 +21,15 @@ Summary(tr.UTF-8):  DNS alan adı sunucusu
 Summary(uk.UTF-8):     BIND - cервер системи доменних імен (DNS)
 Summary(zh_CN.UTF-8):  Internet 域名服务器
 Name:          bind
-Version:       9.4.1
-Release:       2
-Epoch:         6
+Version:       9.4.2
+Release:       1
+Epoch:         7
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 09b54d35036cb0423b2e618f21766285
+# Source0-md5: 57953d7264139b9506b9d66174125179
 Source1:       %{name}-conf.tar.gz
-# Source1-md5: 8ee77729f806fcd548fe0cceb34b4a06
+# Source1-md5: 14d2c6befe25e68c713a1deb552668cc
 Source2:       named.init
 Source3:       named.sysconfig
 Source4:       named.logrotate
@@ -37,6 +39,8 @@ Source6:      http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
 # Source6-md5: 49fe799c6eca54ae227b22d57ebc1145
 Source7:       %{name}-hip.tar.gz
 # Source7-md5: 62a8a67f51ff8db9fe815205416a1f62
+Source8:       ftp://rs.internic.net/domain/named.root
+# Source8-md5: 8c212c0260d708f15f75d3adc71f0149
 Patch0:                %{name}-time.patch
 Patch1:                %{name}-autoconf.patch
 Patch2:                %{name}-includedir-libbind.patch
@@ -44,9 +48,7 @@ Patch3:               %{name}-link.patch
 Patch4:                %{name}-pmake.patch
 Patch5:                %{name}-sdb-ldap.patch
 Patch6:                %{name}-noinet6.patch
-Patch7:                %{name}-getifaddrs.patch
-Patch8:                %{name}-dighost_asccheck.patch
-Patch9:                %{name}-chroot-numcpus.patch
+Patch7:                %{name}-chroot-numcpus.patch
 URL:           http://www.isc.org/products/BIND/bind9.html
 BuildRequires: autoconf
 BuildRequires: automake
@@ -55,11 +57,11 @@ BuildRequires:      flex
 BuildRequires: idnkit-devel
 %{?with_hip:BuildRequires:     libxml2-devel}
 BuildRequires: libtool
-%{?with_ldap:BuildRequires:    openldap-devel}
+%{?with_ldap:BuildRequires:    openldap-devel >= 2.4.6}
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
-BuildRequires: mysql-devel
-BuildRequires: postgresql-devel
-BuildRequires: unixODBC-devel
+%{?with_sql:BuildRequires:     mysql-devel}
+%{?with_sql:BuildRequires:     postgresql-devel}
+%{?with_sql:BuildRequires:     unixODBC-devel}
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -76,7 +78,6 @@ Provides:     group(named)
 Provides:      nameserver
 Provides:      user(named)
 Obsoletes:     caching-nameserver
-Obsoletes:     nameserver
 Conflicts:     %{name}-chroot
 Conflicts:     kernel < 2.2.18
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -339,10 +340,10 @@ Schemat BIND dla openldap.
 %{?with_ldap:%patch5 -p1}
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p1
 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
 
+install %{SOURCE8} conf-pld/root.hint
+
 %build
 %{__libtoolize}
 %{__aclocal}
@@ -358,8 +359,8 @@ cd ../..
        %{?with_ssl:--with-openssl=%{_prefix}} \
        %{?with_ipv6:--enable-ipv6} \
        --enable-libbind \
-       --with-dlz-postgres=yes \
-       --with-dlz-mysql=yes \
+       %{?with_sql:--with-dlz-postgres=yes} \
+       %{?with_sql:--with-dlz-mysql=yes} \
        --with-dlz-bdb=no \
        --with-dlz-filesystem=yes \
        %{?with_ldap:--with-dlz-ldap=yes} \
@@ -373,6 +374,8 @@ cd ../..
 %{__make}
 %{?with_hip:cd bind-hip/; %{__make}}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
@@ -401,7 +404,7 @@ ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
 ln -sf %{_var}/lib/named/named.log     $RPM_BUILD_ROOT%{_var}/log/named
 ln -sf %{_var}/lib/named/named.stats   $RPM_BUILD_ROOT%{_var}/log/named.stats
 
-touch $RPM_BUILD_ROOT%{_var}/lib/named/{named.{log,stats},dev/null}
+touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
 
 %{?with_ldap:install -d $RPM_BUILD_ROOT%{_datadir}/openldap/schema}
 %{?with_ldap:install %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/openldap/schema/dnszone.schema}
@@ -427,18 +430,6 @@ fi
 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
 
 %post
-if [ "$1" = 1 ]; then
-       mknod -m 660 %{_var}/lib/named/dev/null c 1 3 2>/dev/null
-       chown root:named %{_var}/lib/named/dev/null 2>/dev/null
-       if [ ! -c %{_var}/lib/named/dev/null ]; then
-%banner -e %{name}-devs <<-EOF
-Device node was not created!!!
-
-Please read PLD Linux Vserver FAQ if you're installing %{name} inside
-vserver: <http://www.pld-linux.org/Vserver>.
-EOF
-       fi #'
-fi
 /sbin/chkconfig --add named
 %service named restart
 
@@ -458,8 +449,9 @@ fi
 %postun        libs -p /sbin/ldconfig
 
 %triggerpostun -- %{name} < 6:9.4.1
-sed -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /etc/named.conf
-sed -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /etc/named.conf
+sed -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+sed -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
+sed -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
 
 %files
 %defattr(644,root,root,755)
@@ -493,10 +485,6 @@ sed -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /etc/n
 %attr(660,named,named) %ghost  %{_var}/lib/named/named.log
 %attr(660,named,named) %ghost  %{_var}/lib/named/named.stats
 
-# devices for chrooted bind
-%attr(750,root,named) %dir %{_var}/lib/named/dev
-%ghost %attr(660,root,named) %{_var}/lib/named/dev/null
-
 %files utils
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/dig
This page took 0.044849 seconds and 4 git commands to generate.