]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
Up to 9.18.25
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15 %bcond_with     seccomp         # seccomp
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.11.2
28 %if 0
29 %define         pverdot .P3
30 %define         pverdir -P3
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        1
48 Epoch:          7
49 License:        MPL 2.0
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
52 # Source0-md5:  efca7e5a63a07efba264da9be2fbb57f
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        ftp://rs.internic.net/domain/root.zone
63 # Source7-md5:  4a20043b9b7209c0da14665318b6dcdc
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69 Patch0:         %{name}-time.patch
70 Patch1:         %{name}-link.patch
71 Patch2:         %{name}-pmake.patch
72 Patch3:         %{name}-sdb-ldap.patch
73 Patch4:         %{name}-ac-libs.patch
74 Patch5:         %{name}-edns-client-subnet.patch
75 Patch6:         nsupdate_segfault.patch
76 URL:            https://www.isc.org/software/bind
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  flex
81 %{?with_geoip:BuildRequires:    GeoIP-devel}
82 %{?with_kerberos5:BuildRequires:        heimdal-devel}
83 BuildRequires:  idnkit-devel
84 %{?with_seccomp:BuildRequires:  libseccomp-devel}
85 BuildRequires:  libtool
86 %{?with_hip:BuildRequires:      libxml2-devel}
87 %{?with_sql:BuildRequires:      mysql-devel}
88 %{?with_ldap:BuildRequires:     openldap-devel}
89 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
90 %{?with_sql:BuildRequires:      postgresql-devel}
91 BuildRequires:  python3-devel
92 BuildRequires:  python3-ply
93 BuildRequires:  readline-devel
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.647
96 %{?with_sql:BuildRequires:      unixODBC-devel}
97 Requires(post,preun):   /sbin/chkconfig
98 Requires(postun):       /usr/sbin/groupdel
99 Requires(postun):       /usr/sbin/userdel
100 Requires(pre):  /bin/id
101 Requires(pre):  /usr/bin/getgid
102 Requires(pre):  /usr/sbin/groupadd
103 Requires(pre):  /usr/sbin/useradd
104 Requires(pre):  fileutils
105 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
106 # for dnssec-{checkds,coverage,keymgr}
107 Requires:       python3-isc = %{epoch}:%{version}-%{release}
108 Requires:       psmisc >= 20.1
109 Requires:       rc-scripts >= 0.2.0
110 Requires:       systemd-units >= 38
111 Requires:       uname(release) >= 2.2.18
112 Provides:       group(named)
113 Provides:       nameserver
114 Provides:       user(named)
115 Obsoletes:      caching-nameserver
116 Conflicts:      %{name}-chroot
117 Conflicts:      logrotate < 3.8.0
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         schemadir       /usr/share/openldap/schema
121
122 %description
123 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
124 (Domain Name System) protocols. BIND includes a DNS server (named),
125 which resolves host names to IP addresses, and a resolver library
126 (routines for applications to use when interfacing with DNS). A DNS
127 server allows clients to name resources or objects and share the
128 information with other network machines. The named DNS server can be
129 used on workstations as a caching name server, but is generally only
130 needed on one machine for an entire network. Note that the
131 configuration files for making BIND act as a simple caching nameserver
132 are included in the caching-nameserver package.
133
134 Install the bind package if you need a DNS server for your network. If
135 you want bind to act a caching name server, you will also need to
136 install the caching-nameserver package.
137
138 %description -l de.UTF-8
139 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
140 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
141 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
142 Recher des Netzwerks erforderlich.
143
144 %description -l es.UTF-8
145 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
146 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
147 un servidor de nombres caché, pero generalmente sólo hace falta en una
148 máquina para toda la red.
149
150 %description -l fr.UTF-8
151 Contient le serveur de noms named, utilisé pour définir les
152 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
153 utilisé sur les stations de travail comme serveur de nom en cache mais
154 n'est souvent nécessaire que sur une machine pour un réseau entier.
155
156 %description -l pl.UTF-8
157 Pakiet ten zawiera demona named, który służy do zmieniania nazw
158 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
159 roboczych jako bufor odwołań do serwisu nazw (caching name server),
160 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
161 program na fragment sieci.
162
163 %description -l pt_BR.UTF-8
164 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
165 IP (e vice-versa). Pode ser usado em estações de trabalho como um
166 servidor de nomes cache, mas geralmente só é necessário em uma máquina
167 para toda a rede.
168
169 %description -l ru.UTF-8
170 BIND (Berkeley Internet Name Domain) является реализацией протоколов
171 DNS (Domain Name System). BIND включает DNS сервер (named) и
172 библиотеку "резолвера" (подпрограммы для приложений, через которые
173 происходят обращения к DNS). DNS сервер named может быть использован
174 на рабочих станциях как кеширующий сервер, но обычно запускается на
175 одной машине в локальной сети и используется остальными машинами (этим
176 достигается намного более эффективное кеширование).
177
178 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
179 кеширующего сервера, включены в пакет caching-nameserver.
180
181 %description -l tr.UTF-8
182 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
183 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
184 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
185 için sadece bir makina üzerinde kurulur.
186
187 %description -l uk.UTF-8
188 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
189 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
190 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
191 сервер named може бути використаний на робочих станціях як кешируючий
192 сервер, але звичайно запускається на одній машині в локальній мережі і
193 використовується іншими (цим досягається більша ефективність
194 використання кешу).
195
196 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
197 кешируючого серверу, включені в пакет caching-nameserver.
198
199 %package utils
200 Summary:        DNS utils - host, dig, dnsquery, nslookup
201 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
202 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
203 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
204 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
205 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
206 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
207 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
208 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
209 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
210 Group:          Networking/Utilities
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212 Requires:       iconv
213
214 %description utils
215 Bind-utils contains a collection of utilities for querying DNS (Domain
216 Name Service) name servers to find out information about Internet
217 hosts. These tools will provide you with the IP addresses for given
218 host names, as well as other information about registered domains and
219 network addresses.
220
221 You should install bind-utils if you need to get information from DNS
222 name servers.
223
224 %description utils -l de.UTF-8
225 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
226 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
227 Informationen über registrierte Domains und Netzwerk-Adressen.
228
229 %description utils -l es.UTF-8
230 Conjunto de utilitarios para consulta a servidores de nombres. Estas
231 herramientas permiten la determinación de direcciones IP para nombres
232 de máquinas informados y busca información sobre dominios registrados
233 y direcciones de red.
234
235 %description utils -l fr.UTF-8
236 Ensemble d'utilitaires pour interroger les serveurs de noms et
237 rechercher des hôtes. Ces outils vous permettent de déterminer les
238 adresses IP pour des noms d'hôtes donnés, et trouver des informations
239 sur les noms de domaine déclarés et les adresses réseau.
240
241 %description utils -l pl.UTF-8
242 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
243 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
244 i ich adresach IP.
245
246 %description utils -l pt_BR.UTF-8
247 Conjunto de utilitários para consulta a servidores DNS. Estas
248 ferramentas permitem a determinação de endereços IP para nomes de
249 máquinas informados e busca informações sobre domínios registrados e
250 endereços de rede. Você deveria instalar este pacote se necessitar
251 obter informações de servidores DNS.
252
253 %description utils -l ru.UTF-8
254 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
255 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
256 доменному имени (и наоборот) и другую информацию о зарегистрированных
257 доменах и сетевых адресах.
258
259 %description utils -l tr.UTF-8
260 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
261 için kullanılan araçlar bulunmaktadır.
262
263 %description utils -l uk.UTF-8
264 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
265 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
266 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
267 домени та адреси.
268
269 %package libs
270 Summary:        DNS libraries
271 Summary(pl.UTF-8):      Biblioteki DNS
272 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
273 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
274 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
275 Group:          Libraries
276
277 %description libs
278 The bind-libs package contains all libraries required for running BIND
279 and bind utils.
280
281 %description libs -l pl.UTF-8
282 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
283 lub programów z pakietu bind-utils.
284
285 %description libs -l ru.UTF-8
286 Библиотеки, необходимые для работы bind.
287
288 %description libs -l uk.UTF-8
289 Бібліотеки, необхідні для роботи bind.
290
291 %package devel
292 Summary:        DNS development includes
293 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
294 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
295 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
296 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
297 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
298 Group:          Development/Libraries
299 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
300
301 %description devel
302 The bind-devel package contains all the include files and symlinks
303 required for DNS (Domain Name Service) development for BIND.
304
305 You should install bind-devel if you want to develop bind DNS
306 applications. If you install bind-devel, you'll also need to install
307 bind-libs.
308
309 %description devel -l es.UTF-8
310 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
311 para el bind.
312
313 %description devel -l pl.UTF-8
314 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
315 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
316 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
317 pakiet.
318
319 %description devel -l pt_BR.UTF-8
320 Todos os arquivos de cabeçalho e bibliotecas necessários para o
321 desenvolvimento com o bind.
322
323 %description devel -l ru.UTF-8
324 Все хедеры и библиотеки, необходимые для написания программ с
325 использованием BIND 9.x.x.
326
327 %description devel -l uk.UTF-8
328 Всі хедери та бібліотеки, необхідні для розробки програм з
329 використанням BIND 9.x.x.
330
331 %package static
332 Summary:        DNS static libs
333 Summary(pl.UTF-8):      Biblioteki statyczne DNS
334 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
335 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
336 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
337 Group:          Development/Libraries
338 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
339
340 %description static
341 Static bind libraries.
342
343 %description static -l pl.UTF-8
344 Statyczne biblioteki binda.
345
346 %description static -l pt_BR.UTF-8
347 Bibliotecas estáticas para desenvolvimento DNS.
348
349 %description static -l ru.UTF-8
350 Статические библиотеки, необходимые для написания программ с
351 использованием BIND.
352
353 %description static -l uk.UTF-8
354 Статичні бібліотеки, необхідні для розробки програм з використанням
355 BIND.
356
357 %package -n openldap-schema-bind
358 Summary:        BIND schema for openldap
359 Summary(pl.UTF-8):      Schemat BIND dla openldap
360 Group:          Development/Libraries
361 Requires(post,postun):  sed >= 4.0
362 Requires:       openldap-servers
363 Requires:       sed >= 4.0
364 %if "%{_rpmversion}" >= "5"
365 BuildArch:      noarch
366 %endif
367
368 %description -n openldap-schema-bind
369 BIND schema for openldap.
370
371 %description -n openldap-schema-bind -l pl.UTF-8
372 Schemat BIND dla openldap.
373
374 %package -n python3-isc
375 Summary:        Python 3 ISC module - functions to support BIND utilities
376 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
377 Group:          Libraries/Python
378 Requires:       python3-modules
379
380 %description -n python3-isc
381 Python 3 ISC module containing functions to support BIND utilities.
382
383 %description -n python3-isc -l pl.UTF-8
384 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
385 BIND-a.
386
387 %prep
388 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
389 %patch0 -p1
390 %patch1 -p1
391 %patch2 -p1
392 %{?with_ldap:%patch3 -p1}
393 %patch4 -p1
394 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
395 %{?with_edns_cli:%patch5 -p0}
396 %patch6 -p0
397
398 %build
399 %{__libtoolize}
400 %{__aclocal}
401 %{__autoconf}
402 cp -f /usr/share/automake/config.* .
403 %configure \
404         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
405         --with-idn \
406         --with-libtool \
407         %{?with_ssl:--with-openssl} \
408         %{?with_ipv6:--enable-ipv6} \
409         %{?with_kerberos5:--with-gssapi} \
410         %{?with_sql:--with-dlz-postgres=yes} \
411         %{?with_sql:--with-dlz-mysql=yes} \
412         --with-dlz-bdb=no \
413         --with-dlz-filesystem=yes \
414         %{?with_ldap:--with-dlz-ldap=yes} \
415         %{?with_geoip:--with-geoip=yes} \
416         --with-dlz-odbc=no \
417         --with-dlz-stub=yes \
418         --enable-largefile \
419         %{!?with_epoll:--disable-epoll --disable-devpoll} \
420         %{!?with_static_libs:--enable-static=no} \
421         --enable-threads \
422         --enable-getifaddrs \
423         --enable-full-report \
424         %{__enable_disable seccomp} \
425         --with-python=%{__python3}
426
427 %{__make}
428 %{?with_hip:cd bind-hip/; %{__make}}
429
430 %{?with_tests:%{__make} test-force}
431
432 %install
433 rm -rf $RPM_BUILD_ROOT
434 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
435         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
436         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
437         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
438
439 %{__make} install \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
443 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
444 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
445 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
446
447 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
448 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
449 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
450 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
451 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
452 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
453 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
454 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
455 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
456 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
457
458 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
459 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
460 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
461 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
462
463 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
464
465 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
466 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
467
468 %if %{with ldap}
469 install -d $RPM_BUILD_ROOT%{schemadir}
470 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
471 %endif
472
473 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
474
475 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
476 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
477
478 # let rpm generate deps (workaround -m644 used for libs installation)
479 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
480
481 # we don't want Makefiles in documentation...
482 rm -rf _doc
483 cp -a doc _doc
484 %{__rm} _doc/misc/Makefile*
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %pre
490 if [ -f %{_sysconfdir}/named.boot ]; then
491         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
492         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
493         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
494 fi
495 %groupadd -g 58 named
496 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
497
498 %post
499 /sbin/chkconfig --add named
500 %service named restart
501 %systemd_post named.service
502
503 %preun
504 if [ "$1" = "0" ]; then
505         %service named stop
506         /sbin/chkconfig --del named
507 fi
508 %systemd_preun named.service
509
510 %postun
511 if [ "$1" = "0" ]; then
512         %userremove named
513         %groupremove named
514 fi
515 %systemd_reload
516
517 %post   libs -p /sbin/ldconfig
518 %postun libs -p /sbin/ldconfig
519
520 %post -n openldap-schema-bind
521 %openldap_schema_register %{schemadir}/dnszone.schema
522 %service -q ldap restart
523
524 %postun -n openldap-schema-bind
525 if [ "$1" = "0" ]; then
526         %openldap_schema_unregister %{schemadir}/dnszone.schema
527         %service -q ldap restart
528 fi
529
530 %triggerpostun -- %{name} < 7:9.4.2-2
531 /sbin/chkconfig named reset
532 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
533 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
534 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
535
536 %triggerpostun -- %{name} < 7:9.9.2.P2-2
537 %systemd_trigger named.service
538
539 %files
540 %defattr(644,root,root,755)
541 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
542 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
543
544 %{systemdunitdir}/named.service
545 %attr(754,root,root) /etc/rc.d/init.d/named
546 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
547 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
548 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
550
551 %attr(755,root,root) %{_sbindir}/ddns-confgen
552 %attr(755,root,root) %{_sbindir}/dnssec-*
553 %attr(755,root,root) %{_sbindir}/genrandom
554 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
555 %attr(755,root,root) %{_sbindir}/lwresd
556 %attr(755,root,root) %{_sbindir}/named
557 %attr(755,root,root) %{_sbindir}/named-*
558 %attr(755,root,root) %{_sbindir}/nsec3hash
559 %attr(755,root,root) %{_sbindir}/rndc
560 %attr(755,root,root) %{_sbindir}/rndc-confgen
561 %attr(755,root,root) %{_sbindir}/tsig-keygen
562
563 %{_mandir}/man5/named.conf.5*
564 %{_mandir}/man5/rndc.conf.5*
565 %{_mandir}/man8/ddns-confgen.8*
566 %{_mandir}/man8/dnssec-*.8*
567 %{_mandir}/man8/genrandom.8*
568 %{_mandir}/man8/isc-hmac-fixup.8*
569 %{_mandir}/man8/lwresd.8*
570 %{_mandir}/man8/named.8*
571 %{_mandir}/man8/named-*.8*
572 %{_mandir}/man8/nsec3hash.8*
573 %{_mandir}/man8/rndc.8*
574 %{_mandir}/man8/rndc-confgen.8*
575 %{_mandir}/man8/tsig-keygen.8*
576 %lang(ja) %{_mandir}/ja/man8/named*
577
578 %{systemdtmpfilesdir}/%{name}.conf
579
580 %attr(770,root,named) %dir %{_var}/lib/named
581 %attr(770,root,named) %dir %{_var}/lib/named/D
582 %attr(770,root,named) %dir %{_var}/lib/named/M
583 %attr(770,root,named) %dir %{_var}/lib/named/S
584 %attr(750,root,named) %dir %{_var}/lib/named/etc
585 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
586 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
587 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
588 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
589 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
590 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
591
592 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
593 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
594
595 %attr(770,root,named) %dir %{_var}/run/named
596 %attr(770,root,named) %dir %{_var}/run/lwresd
597
598 %files utils
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_bindir}/arpaname
601 %attr(755,root,root) %{_bindir}/delv
602 %attr(755,root,root) %{_bindir}/dig
603 %attr(755,root,root) %{_bindir}/host
604 %attr(755,root,root) %{_bindir}/named-rrchecker
605 %attr(755,root,root) %{_bindir}/mdig
606 %attr(755,root,root) %{_bindir}/nslookup
607 %attr(755,root,root) %{_bindir}/nsupdate
608 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
609 %{_mandir}/man1/arpaname.1*
610 %{_mandir}/man1/delv.1*
611 %{_mandir}/man1/dig.1*
612 %{_mandir}/man1/host.1*
613 %{_mandir}/man1/mdig.1*
614 %{_mandir}/man1/named-rrchecker.1*
615 %{_mandir}/man1/nslookup.1*
616 %{_mandir}/man1/nsupdate.1*
617
618 %lang(fi) %{_mandir}/fi/man1/host.1*
619
620 %lang(fr) %{_mandir}/fr/man1/host.1*
621
622 %lang(hu) %{_mandir}/hu/man1/host.1*
623
624 %lang(ja) %{_mandir}/ja/man1/dig.1*
625 %lang(ja) %{_mandir}/ja/man1/host.1*
626 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
627 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
628
629 %lang(pl) %{_mandir}/pl/man1/host.1*
630
631 %files libs
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.160
635 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libdns.so.169
637 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libirs.so.160
639 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libisc.so.166
641 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.160
643 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.160
645 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.160
647
648 %files devel
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/bind9-config
651 %attr(755,root,root) %{_bindir}/isc-config.sh
652 %attr(755,root,root) %{_libdir}/libbind9.so
653 %attr(755,root,root) %{_libdir}/libdns.so
654 %attr(755,root,root) %{_libdir}/libirs.so
655 %attr(755,root,root) %{_libdir}/libisc.so
656 %attr(755,root,root) %{_libdir}/libisccc.so
657 %attr(755,root,root) %{_libdir}/libisccfg.so
658 %attr(755,root,root) %{_libdir}/liblwres.so
659 %{_libdir}/libbind9.la
660 %{_libdir}/libdns.la
661 %{_libdir}/libirs.la
662 %{_libdir}/libisc.la
663 %{_libdir}/libisccc.la
664 %{_libdir}/libisccfg.la
665 %{_libdir}/liblwres.la
666 %{_includedir}/bind9
667 %{_includedir}/dns
668 %{_includedir}/dst
669 %{_includedir}/irs
670 %{_includedir}/isc
671 %{_includedir}/isccc
672 %{_includedir}/isccfg
673 %{_includedir}/lwres
674 %{_includedir}/pk11
675 %{_includedir}/pkcs11
676 %{_mandir}/man1/bind9-config.1*
677 %{_mandir}/man1/isc-config.sh.1*
678 %{_mandir}/man3/lwres*.3*
679
680 %if %{with static_libs}
681 %files static
682 %defattr(644,root,root,755)
683 %{_libdir}/libbind9.a
684 %{_libdir}/libdns.a
685 %{_libdir}/libirs.a
686 %{_libdir}/libisc.a
687 %{_libdir}/libisccc.a
688 %{_libdir}/libisccfg.a
689 %{_libdir}/liblwres.a
690 %endif
691
692 %if %{with ldap}
693 %files -n openldap-schema-bind
694 %defattr(644,root,root,755)
695 %{_datadir}/openldap/schema/dnszone.schema
696 %endif
697
698 %files -n python3-isc
699 %defattr(644,root,root,755)
700 %{py3_sitedir}/isc
701 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.105842 seconds and 3 git commands to generate.