]> git.pld-linux.org Git - packages/bind.git/blame_incremental - bind.spec
- rel 5; root zone updated
[packages/bind.git] / bind.spec
... / ...
CommitLineData
1# TODO
2# - apply http://www.caraytech.com/geodns/
3#
4# Conditional build:
5%bcond_without ssl # build without OpenSSL support
6%bcond_without ipv6 # build without IPv6 support
7%bcond_without ldap # build without LDAP support
8%bcond_without kerberos5 # build without kerneros5 support
9%bcond_without sql # build without SQL support
10%bcond_without static_libs # build without static libraries
11%bcond_without tests # perform tests
12%bcond_with edns_cli # build with the ability to use edns-client-subnet in dig
13%bcond_with hip # build with HIP RR support
14%if "%{pld_release}" == "ac"
15%bcond_with epoll # enable epoll support
16# there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17%ifarch %{x8664}
18%define with_epoll 1
19%endif
20%else
21%bcond_without epoll # disable epoll support
22%endif
23
24%define ver 9.8.1
25%if 1
26%define pverdot .P1
27%define pverdir -P1
28%else
29%define pverdot %{nil}
30%define pverdir %{nil}
31%endif
32Summary: BIND - DNS name server
33Summary(de.UTF-8): BIND - DNS-Namenserver
34Summary(es.UTF-8): BIND - Servidor de nombres DNS
35Summary(fr.UTF-8): BIND - serveur de noms DNS
36Summary(pl.UTF-8): BIND - serwer nazw DNS
37Summary(pt_BR.UTF-8): BIND - Servidor de nomes DNS
38Summary(ru.UTF-8): BIND - cервер системы доменных имен (DNS)
39Summary(tr.UTF-8): DNS alan adı sunucusu
40Summary(uk.UTF-8): BIND - cервер системи доменних імен (DNS)
41Summary(zh_CN.UTF-8): Internet 域名服务器
42Name: bind
43Version: %{ver}%{pverdot}
44Release: 5
45Epoch: 7
46License: BSD-like
47Group: Networking/Daemons
48Source0: ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49# Source0-md5: afa41f8203d50bedad65071f9b6f96d7
50Source1: named.init
51Source2: named.sysconfig
52Source3: named.logrotate
53Source4: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54# Source4-md5: 35b1dfaa12615c9802126ee833e0e7f7
55Source5: http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56# Source5-md5: 49fe799c6eca54ae227b22d57ebc1145
57Source6: %{name}-hip.tar.gz
58# Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
59Source7: ftp://rs.internic.net/domain/root.zone
60# Source7-md5: b5e38953f6b64856a0b624626968bed1
61Source8: %{name}-127.0.0.zone
62Source9: %{name}-localhost.zone
63Source10: %{name}-named.conf
64Source11: %{name}.tmpfiles
65Patch0: %{name}-time.patch
66Patch1: %{name}-link.patch
67Patch2: %{name}-pmake.patch
68Patch3: %{name}-sdb-ldap.patch
69Patch4: %{name}-ac-libs.patch
70Patch5: %{name}-edns-client-subnet.patch
71URL: https://www.isc.org/software/bind
72BuildRequires: autoconf >= 2.59
73BuildRequires: automake
74BuildRequires: bison
75BuildRequires: flex
76%{?with_kerberos5:BuildRequires: heimdal-devel}
77BuildRequires: idnkit-devel
78BuildRequires: libtool
79%{?with_hip:BuildRequires: libxml2-devel}
80%{?with_sql:BuildRequires: mysql-devel}
81%{?with_ldap:BuildRequires: openldap-devel}
82%{?with_ssl:BuildRequires: openssl-devel >= 0.9.8d}
83%{?with_sql:BuildRequires: postgresql-devel}
84BuildRequires: rpm >= 4.4.9-56
85BuildRequires: rpmbuild(macros) >= 1.268
86%{?with_sql:BuildRequires: unixODBC-devel}
87Requires(post,preun): /sbin/chkconfig
88Requires(postun): /usr/sbin/groupdel
89Requires(postun): /usr/sbin/userdel
90Requires(pre): /bin/id
91Requires(pre): /usr/bin/getgid
92Requires(pre): /usr/sbin/groupadd
93Requires(pre): /usr/sbin/useradd
94Requires(pre): fileutils
95Requires: %{name}-libs = %{epoch}:%{version}-%{release}
96Requires: psmisc >= 20.1
97Requires: rc-scripts >= 0.2.0
98Provides: group(named)
99Provides: nameserver
100Provides: user(named)
101Obsoletes: caching-nameserver
102Conflicts: %{name}-chroot
103Conflicts: kernel < 2.2.18
104Conflicts: logrotate < 3.8.0
105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107%define schemadir /usr/share/openldap/schema
108
109%description
110BIND (Berkeley Internet Name Domain) is an implementation of the DNS
111(Domain Name System) protocols. BIND includes a DNS server (named),
112which resolves host names to IP addresses, and a resolver library
113(routines for applications to use when interfacing with DNS). A DNS
114server allows clients to name resources or objects and share the
115information with other network machines. The named DNS server can be
116used on workstations as a caching name server, but is generally only
117needed on one machine for an entire network. Note that the
118configuration files for making BIND act as a simple caching nameserver
119are included in the caching-nameserver package.
120
121Install the bind package if you need a DNS server for your network. If
122you want bind to act a caching name server, you will also need to
123install the caching-nameserver package.
124
125%description -l de.UTF-8
126Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
127IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
128caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
129Recher des Netzwerks erforderlich.
130
131%description -l es.UTF-8
132Incluye el servidor de nombres (DNS), que se usa para traducir nombres
133para IP (y viceversa). Puede ser usado en estaciones de trabajo como
134un servidor de nombres caché, pero generalmente sólo hace falta en una
135máquina para toda la red.
136
137%description -l fr.UTF-8
138Contient le serveur de noms named, utilisé pour définir les
139traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
140utilisé sur les stations de travail comme serveur de nom en cache mais
141n'est souvent nécessaire que sur une machine pour un réseau entier.
142
143%description -l pl.UTF-8
144Pakiet ten zawiera demona named, który służy do zmieniania nazw
145komputerów na numery IP i odwrotnie. Może być on używany na stacjach
146roboczych jako bufor odwołań do serwisu nazw (caching name server),
147ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
148program na fragment sieci.
149
150%description -l pt_BR.UTF-8
151Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
152IP (e vice-versa). Pode ser usado em estações de trabalho como um
153servidor de nomes cache, mas geralmente só é necessário em uma máquina
154para toda a rede.
155
156%description -l ru.UTF-8
157BIND (Berkeley Internet Name Domain) является реализацией протоколов
158DNS (Domain Name System). BIND включает DNS сервер (named) и
159библиотеку "резолвера" (подпрограммы для приложений, через которые
160происходят обращения к DNS). DNS сервер named может быть использован
161на рабочих станциях как кеширующий сервер, но обычно запускается на
162одной машине в локальной сети и используется остальными машинами (этим
163достигается намного более эффективное кеширование).
164
165Конфигурационные файлы, настраивающие BIND на работу в режиме простого
166кеширующего сервера, включены в пакет caching-nameserver.
167
168%description -l tr.UTF-8
169Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
170kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
171isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
172için sadece bir makina üzerinde kurulur.
173
174%description -l uk.UTF-8
175BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
176(Domain Name System). BIND включає DNS сервер (named) та бібліотеку
177"резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
178сервер named може бути використаний на робочих станціях як кешируючий
179сервер, але звичайно запускається на одній машині в локальній мережі і
180використовується іншими (цим досягається більша ефективність
181використання кешу).
182
183Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
184кешируючого серверу, включені в пакет caching-nameserver.
185
186%package utils
187Summary: DNS utils - host, dig, dnsquery, nslookup
188Summary(de.UTF-8): DNS-Utils - Host, Dig, Dnsquery, Nslookup
189Summary(es.UTF-8): Utilitarios DNS - host, dig, dnsquery y nslookup
190Summary(fr.UTF-8): Utilitaires DNS - host, dig, dnsquery, nslookup
191Summary(pl.UTF-8): Narzędzia DNS - host, dig, dnsquery, nslookup
192Summary(pt_BR.UTF-8): Utilitários DNS - host, dig, dnsquery e nslookup
193Summary(ru.UTF-8): Утилиты для посылки запросов к серверам DNS
194Summary(tr.UTF-8): DNS araçları - host, dig, dnsquery, nslookup
195Summary(uk.UTF-8): Утиліти для надсилання запитів до серверів DNS
196Summary(zh_CN.UTF-8): Internet 域名服务器实用工具
197Group: Networking/Utilities
198Requires: %{name}-libs = %{epoch}:%{version}-%{release}
199Requires: iconv
200
201%description utils
202Bind-utils contains a collection of utilities for querying DNS (Domain
203Name Service) name servers to find out information about Internet
204hosts. These tools will provide you with the IP addresses for given
205host names, as well as other information about registered domains and
206network addresses.
207
208You should install bind-utils if you need to get information from DNS
209name servers.
210
211%description utils -l de.UTF-8
212Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
213Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
214Informationen über registrierte Domains und Netzwerk-Adressen.
215
216%description utils -l es.UTF-8
217Conjunto de utilitarios para consulta a servidores de nombres. Estas
218herramientas permiten la determinación de direcciones IP para nombres
219de máquinas informados y busca información sobre dominios registrados
220y direcciones de red.
221
222%description utils -l fr.UTF-8
223Ensemble d'utilitaires pour interroger les serveurs de noms et
224rechercher des hôtes. Ces outils vous permettent de déterminer les
225adresses IP pour des noms d'hôtes donnés, et trouver des informations
226sur les noms de domaine déclarés et les adresses réseau.
227
228%description utils -l pl.UTF-8
229Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
230serwerów nazw z innych domen w celu uzyskania informacji o komputerach
231i ich adresach IP.
232
233%description utils -l pt_BR.UTF-8
234Conjunto de utilitários para consulta a servidores DNS. Estas
235ferramentas permitem a determinação de endereços IP para nomes de
236máquinas informados e busca informações sobre domínios registrados e
237endereços de rede. Você deveria instalar este pacote se necessitar
238obter informações de servidores DNS.
239
240%description utils -l ru.UTF-8
241Набор утилит для генерации запросов к серверам имен (DNS) и поиска
242адресов машин. Эти утилиты позволяют определить IP-адрес по известному
243доменному имени (и наоборот) и другую информацию о зарегистрированных
244доменах и сетевых адресах.
245
246%description utils -l tr.UTF-8
247Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
248için kullanılan araçlar bulunmaktadır.
249
250%description utils -l uk.UTF-8
251Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
252адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
253доменним іменем та навпаки, а також іншу інформацію про зареєстровані
254домени та адреси.
255
256%package libs
257Summary: DNS libraries
258Summary(pl.UTF-8): Biblioteki DNS
259Summary(ru.UTF-8): Библиотеки, необходимые для bind
260Summary(uk.UTF-8): Бібліотеки, необхідні для bind
261Summary(zh_CN.UTF-8): Internet 域名服务器开发库
262Group: Libraries
263
264%description libs
265The bind-libs package contains all libraries required for running BIND
266and bind utils.
267
268%description libs -l pl.UTF-8
269Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
270lub programów z pakietu bind-utils.
271
272%description libs -l ru.UTF-8
273Библиотеки, необходимые для работы bind.
274
275%description libs -l uk.UTF-8
276Бібліотеки, необхідні для роботи bind.
277
278%package devel
279Summary: DNS development includes
280Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo DNS
281Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DNS
282Summary(pt_BR.UTF-8): Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
283Summary(ru.UTF-8): Хедеры и библиотеки разработчика для bind
284Summary(uk.UTF-8): Хедери та бібліотеки програміста для bind
285Group: Development/Libraries
286Requires: %{name}-libs = %{epoch}:%{version}-%{release}
287
288%description devel
289The bind-devel package contains all the include files and symlinks
290required for DNS (Domain Name Service) development for BIND.
291
292You should install bind-devel if you want to develop bind DNS
293applications. If you install bind-devel, you'll also need to install
294bind-libs.
295
296%description devel -l es.UTF-8
297Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
298para el bind.
299
300%description devel -l pl.UTF-8
301Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
302binda, lub kompilował kod źródłowy oprogramowania korzystającego z
303tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
304pakiet.
305
306%description devel -l pt_BR.UTF-8
307Todos os arquivos de cabeçalho e bibliotecas necessários para o
308desenvolvimento com o bind.
309
310%description devel -l ru.UTF-8
311Все хедеры и библиотеки, необходимые для написания программ с
312использованием BIND 9.x.x.
313
314%description devel -l uk.UTF-8
315Всі хедери та бібліотеки, необхідні для розробки програм з
316використанням BIND 9.x.x.
317
318%package static
319Summary: DNS static libs
320Summary(pl.UTF-8): Biblioteki statyczne DNS
321Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento DNS
322Summary(ru.UTF-8): Статические библиотеки разработчика для bind
323Summary(uk.UTF-8): Статичні бібліотеки програміста для bind
324Group: Development/Libraries
325Requires: %{name}-devel = %{epoch}:%{version}-%{release}
326
327%description static
328Static bind libraries.
329
330%description static -l pl.UTF-8
331Statyczne biblioteki binda.
332
333%description static -l pt_BR.UTF-8
334Bibliotecas estáticas para desenvolvimento DNS.
335
336%description static -l ru.UTF-8
337Статические библиотеки, необходимые для написания программ с
338использованием BIND.
339
340%description static -l uk.UTF-8
341Статичні бібліотеки, необхідні для розробки програм з використанням
342BIND.
343
344%package -n openldap-schema-bind
345Summary: BIND schema for openldap
346Summary(pl.UTF-8): Schemat BIND dla openldap
347Group: Development/Libraries
348Requires(post,postun): sed >= 4.0
349Requires: openldap-servers
350Requires: sed >= 4.0
351
352%description -n openldap-schema-bind
353BIND schema for openldap.
354
355%description -n openldap-schema-bind -l pl.UTF-8
356Schemat BIND dla openldap.
357
358%prep
359%setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
360%patch0 -p1
361%patch1 -p1
362%patch2 -p1
363%{?with_ldap:%patch3 -p1}
364%patch4 -p1
365%{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
366
367%{?with_edns_cli:%patch5 -p0}
368
369%build
370%{__libtoolize}
371%{__aclocal}
372%{__autoconf}
373cp -f /usr/share/automake/config.* .
374%configure \
375 CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
376 --with-idn \
377 --with-libtool \
378 %{?with_ssl:--with-openssl} \
379 %{?with_ipv6:--enable-ipv6} \
380 %{?with_kerberos5:--with-gssapi} \
381 %{?with_sql:--with-dlz-postgres=yes} \
382 %{?with_sql:--with-dlz-mysql=yes} \
383 --with-dlz-bdb=no \
384 --with-dlz-filesystem=yes \
385 %{?with_ldap:--with-dlz-ldap=yes} \
386 --with-dlz-odbc=no \
387 --with-dlz-stub=yes \
388 --enable-largefile \
389 %{!?with_epoll:--disable-epoll --disable-devpoll} \
390 %{!?with_static_libs:--enable-static=no} \
391 --enable-threads \
392 --enable-getifaddrs
393
394%{__make}
395%{?with_hip:cd bind-hip/; %{__make}}
396
397%{?with_tests:%{__make} test}
398
399%install
400rm -rf $RPM_BUILD_ROOT
401install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
402 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
403 $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
404 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
405
406%{__make} install \
407 DESTDIR=$RPM_BUILD_ROOT
408
409bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
410mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
411%{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
412
413cp -p bin/tests/named.conf EXAMPLE-CONFIG-named
414cp -p bin/tests/ndc.conf EXAMPLE-CONFIG-ndc
415install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/named
416cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/named
417cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/named
418cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
419cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
420cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
421cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
422mv $RPM_BUILD_ROOT/etc/bind.keys $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
423
424ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
425ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
426ln -sf %{_var}/lib/named/named.log $RPM_BUILD_ROOT%{_var}/log/named
427ln -sf %{_var}/lib/named/named.stats $RPM_BUILD_ROOT%{_var}/log/named.stats
428
429touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
430
431install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
432
433%if %{with ldap}
434install -d $RPM_BUILD_ROOT%{schemadir}
435cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
436%endif
437
438%{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
439
440rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
441echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
442
443# let rpm generate deps (workaround -m644 used for libs installation)
444chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
445
446# we don't want Makefiles in documentation...
447rm -rf _doc
448cp -a doc _doc
449rm -f _doc/rfc/rfc*
450rm -f _doc/misc/Makefile*
451
452%clean
453rm -rf $RPM_BUILD_ROOT
454
455%pre
456if [ -f %{_sysconfdir}/named.boot ]; then
457 cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
458 mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
459 echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
460fi
461%groupadd -g 58 named
462%useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
463
464%post
465/sbin/chkconfig --add named
466%service named restart
467
468%preun
469if [ "$1" = "0" ]; then
470 %service named stop
471 /sbin/chkconfig --del named
472fi
473
474%postun
475if [ "$1" = "0" ]; then
476 %userremove named
477 %groupremove named
478fi
479
480%post libs -p /sbin/ldconfig
481%postun libs -p /sbin/ldconfig
482
483%post -n openldap-schema-bind
484%openldap_schema_register %{schemadir}/dnszone.schema
485%service -q ldap restart
486
487%postun -n openldap-schema-bind
488if [ "$1" = "0" ]; then
489 %openldap_schema_unregister %{schemadir}/dnszone.schema
490 %service -q ldap restart
491fi
492
493%triggerpostun -- %{name} < 7:9.4.2-2
494/sbin/chkconfig named reset
495%{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
496%{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
497%{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
498
499%files
500%defattr(644,root,root,755)
501%doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
502%doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
503
504%attr(754,root,root) /etc/rc.d/init.d/named
505%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
506%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
507%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
508%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
509
510%attr(755,root,root) %{_sbindir}/arpaname
511%attr(755,root,root) %{_sbindir}/ddns-confgen
512%attr(755,root,root) %{_sbindir}/dnssec-*
513%attr(755,root,root) %{_sbindir}/genrandom
514%attr(755,root,root) %{_sbindir}/isc-hmac-fixup
515%attr(755,root,root) %{_sbindir}/lwresd
516%attr(755,root,root) %{_sbindir}/named
517%attr(755,root,root) %{_sbindir}/named-*
518%attr(755,root,root) %{_sbindir}/nsec3hash
519%attr(755,root,root) %{_sbindir}/rndc
520%attr(755,root,root) %{_sbindir}/rndc-confgen
521
522%{_mandir}/man1/arpaname.1*
523%{_mandir}/man5/named.conf.5*
524%{_mandir}/man5/rndc.conf.5*
525%{_mandir}/man8/ddns-confgen.8*
526%{_mandir}/man8/dnssec-*.8*
527%{_mandir}/man8/genrandom.8*
528%{_mandir}/man8/isc-hmac-fixup.8*
529%{_mandir}/man8/lwresd.8*
530%{_mandir}/man8/named.8*
531%{_mandir}/man8/named-*.8*
532%{_mandir}/man8/nsec3hash.8*
533%{_mandir}/man8/rndc.8*
534%{_mandir}/man8/rndc-confgen.8*
535%lang(ja) %{_mandir}/ja/man8/named*
536
537/usr/lib/tmpfiles.d/%{name}.conf
538
539%attr(770,root,named) %dir %{_var}/lib/named
540%attr(770,root,named) %dir %{_var}/lib/named/D
541%attr(750,root,named) %dir %{_var}/lib/named/M
542%attr(770,root,named) %dir %{_var}/lib/named/S
543%attr(750,root,named) %dir %{_var}/lib/named/etc
544%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
545%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
546%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
547%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
548%attr(660,named,named) %ghost %{_var}/lib/named/named.log
549%attr(660,named,named) %ghost %{_var}/lib/named/named.stats
550
551%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
552%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
553
554%attr(770,root,named) %dir %{_var}/run/named
555%attr(770,root,named) %dir %{_var}/run/lwresd
556
557%files utils
558%defattr(644,root,root,755)
559%attr(755,root,root) %{_bindir}/dig
560%attr(755,root,root) %{_bindir}/host
561%attr(755,root,root) %{_bindir}/nslookup
562%attr(755,root,root) %{_bindir}/nsupdate
563%{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
564%{_mandir}/man1/dig.1*
565%{_mandir}/man1/host.1*
566%{_mandir}/man1/nslookup.1*
567%{_mandir}/man1/nsupdate.1*
568
569%lang(fi) %{_mandir}/fi/man1/host.1*
570
571%lang(fr) %{_mandir}/fr/man1/host.1*
572
573%lang(hu) %{_mandir}/hu/man1/host.1*
574
575%lang(ja) %{_mandir}/ja/man1/dig.1*
576%lang(ja) %{_mandir}/ja/man1/host.1*
577%lang(ja) %{_mandir}/ja/man1/nslookup.1*
578%lang(ja) %{_mandir}/ja/man8/nsupdate.8*
579
580%lang(pl) %{_mandir}/pl/man1/host.1*
581
582%files libs
583%defattr(644,root,root,755)
584%attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
585%attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
586%attr(755,root,root) %{_libdir}/libdns.so.*.*.*
587%attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
588%attr(755,root,root) %{_libdir}/libisc.so.*.*.*
589%attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
590%attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
591%attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
592%attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
593%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
594%attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
595%attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
596
597%files devel
598%defattr(644,root,root,755)
599%attr(755,root,root) %{_bindir}/isc-config.sh
600%attr(755,root,root) %{_libdir}/libbind9.so
601%attr(755,root,root) %{_libdir}/libdns.so
602%attr(755,root,root) %{_libdir}/libisc.so
603%attr(755,root,root) %{_libdir}/libisccc.so
604%attr(755,root,root) %{_libdir}/libisccfg.so
605%attr(755,root,root) %{_libdir}/liblwres.so
606%{_libdir}/libbind9.la
607%{_libdir}/libdns.la
608%{_libdir}/libisc.la
609%{_libdir}/libisccc.la
610%{_libdir}/libisccfg.la
611%{_libdir}/liblwres.la
612%{_includedir}/bind9
613%{_includedir}/dns
614%{_includedir}/dst
615%{_includedir}/isc
616%{_includedir}/isccc
617%{_includedir}/isccfg
618%{_includedir}/lwres
619%{_mandir}/man1/isc-config.sh.1*
620%{_mandir}/man3/lwres*.3*
621
622%if %{with static_libs}
623%files static
624%defattr(644,root,root,755)
625%{_libdir}/libbind9.a
626%{_libdir}/libdns.a
627%{_libdir}/libisc.a
628%{_libdir}/libisccc.a
629%{_libdir}/libisccfg.a
630%{_libdir}/liblwres.a
631%endif
632
633%if %{with ldap}
634%files -n openldap-schema-bind
635%defattr(644,root,root,755)
636%{_datadir}/openldap/schema/dnszone.schema
637%endif
This page took 0.065718 seconds and 4 git commands to generate.