]> git.pld-linux.org Git - packages/bicyclerepair.git/blame - bicyclerepair.spec
- make test after building
[packages/bicyclerepair.git] / bicyclerepair.spec
CommitLineData
57cbe366 1
2#
3# todo:
4# - emacs, idle and vim subpackages
5#
6
c634a619 7# Conditional build:
8%bcond_without tests # disables testing
9
57cbe366 10
11%include /usr/lib/rpm/macros.python
12
13%define beta BETA3
14
15Summary: Python Refactoring Browser
16Name: bicyclerepair
17Version: 0.9
18Release: 0.%{beta}.1
19License: unknown
20Group: Development/Languages/Python
21Source0: http://dl.sourceforge.net/%{name}/%{name}-%{version}-%{beta}.tar.gz
0c3fb01d 22# Source0-md5: c8c22c2a8133a72aaf30b3d105fe7499
57cbe366 23URL: http://bicyclerepair.sourceforge.net/
24BuildRequires: python-modules >= 2.2.1
25BuildRequires: rpm-pythonprov
26%pyrequires_eq python-modules
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Bicycle Repair Man is the Python Refactoring Browser, helping Pythonistas
32everywhere glide over the gory details of refactoring their code. Watch him
33extract jumbled code into well ordered classes. Gasp, as he renames all
34occurrences of a method. Thank You, Bicycle Repair Man!
35
36%prep
37%setup -q -n %{name}-%{version}-%{beta}
38
39%build
40python setup.py build
c634a619 41%{?with_tests:python -O testall.py -v}
57cbe366 42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
47find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py -exec rm -f {} \;
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(644,root,root,755)
54%doc AUTHORS COPYING ChangeLog DESIGN NEWS README*
55%doc ide-integration/bike.vim
56#%attr(755,root,root) %{_bindir}/*
57%{py_sitedir}/*
This page took 0.033225 seconds and 4 git commands to generate.