]> git.pld-linux.org Git - packages/beryl-core.git/blobdiff - beryl-core.spec
- 0.1.9999.1
[packages/beryl-core.git] / beryl-core.spec
index 94672258e6e3fb44f57a02f2bb9b25764f565d0a..822ce986ca0d87b0bd20af06b1920f114bdd352a 100644 (file)
@@ -1,29 +1,30 @@
 #
-# TODO: python
-#
 # Conditional build:
-%bcond_with    beryl_mesa
+%bcond_with    beryl_mesa      # beryl-xgl statically linked with own libGL
 #
 Summary:       OpenGL window and compositing manager
 Summary(pl):   OpenGL-owy zarz±dca okien i sk³adania
 Name:          beryl-core
-Version:       0.1.3
+Version:       0.1.9999.1
 Release:       1
 Epoch:         1
 License:       MIT
 Group:         X11
 Source0:       http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 24caed8a8cb50fd30823a9ee182f85f4
-Source1:       http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
-# Source1-md5: c22765c2637846907ee6154b548151e9
+# Source0-md5: e7f65f7caf72ed7ec55f46468099f694
+#Source1:      http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
+# Source1-md5: 387d068091bc5c6fa28f6d754e1296d1
+Patch0:                %{name}-link.patch
+URL:           http://beryl-project.org/
+BuildRequires: GConf2-devel >= 2.0
+BuildRequires: OpenGL-GLX-devel
 BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+BuildRequires: automake >= 1:1.9
 BuildRequires: glib2-devel >= 2.0
-BuildRequires: intltool
+BuildRequires: intltool >= 0.35.0
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
-BuildRequires: python-modules >= 1:2.2
 BuildRequires: sed >= 4.0
 BuildRequires: startup-notification-devel >= 0.7
 BuildRequires: xorg-lib-libSM-devel
@@ -33,7 +34,9 @@ BuildRequires:        xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-proto-glproto-devel
 BuildRequires: xorg-util-makedepend
+Requires:      xorg-app-xvinfo
 Provides:      compiz
+Obsoletes:     compiz-quinnstorm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -60,16 +63,19 @@ dostarczaj
 %package devel
 Summary:       Header files for beryl
 Summary(pl):   Pliki nag³ówkowe dla beryla
-Group:         Development
+Group:         X11/Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      OpenGL-devel
+Requires:      OpenGL-GLX-devel
+Requires:      glib2-devel >= 2.0
 Requires:      libpng-devel
 Requires:      startup-notification-devel >= 0.7
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcomposite-devel >= 0.3
 Requires:      xorg-lib-libXdamage-devel
+Requires:      xorg-lib-libXinerama-devel
 Requires:      xorg-lib-libXrandr-devel
-Conflicts:     compiz-devel
+Requires:      xorg-proto-glproto-devel
+Obsoletes:     compiz-quinnstorm-devel
 
 %description devel
 Header files for beryl.
@@ -77,9 +83,24 @@ Header files for beryl.
 %description devel -l pl
 Pliki nag³ówkowe dla beryla.
 
+%package gconf
+Summary:       GConf settings plugin for beryl
+Summary(pl):   Wtyczka ustawieñ GConf dla beryla
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description gconf
+GConf settings plugin for beryl.
+
+%description gconf -l pl
+Wtyczka ustawieñ GConf dla beryla.
+
 %prep
 %setup -q %{?with_beryl_mesa: -a1}
-mv -f po/{es_AR,ar}.po
+%patch0 -p1
+
+mv -f po/{ca_ES,ca}.po
+mv -f po/{de_DE,de}.po
 mv -f po/{es_ES,es}.po
 mv -f po/{fr_FR,fr}.po
 mv -f po/{hu_HU,hu}.po
@@ -87,37 +108,51 @@ mv -f po/{it_IT,it}.po
 mv -f po/{ja_JP,ja}.po
 mv -f po/{ko_KR,ko}.po
 mv -f po/{pt_PT,pt}.po
+mv -f po/{ru_RU,ru}.po
 mv -f po/{sv_SE,sv}.po
+mv -f po/{uk_UA,uk}.po
+# sv_FI is identical to sv_SE
 
-    # NOTE: check the list ofter any upgrade!
+# NOTE: check the list after any upgrade!
 cat > po/LINGUAS <<EOF
-ar
+ca
+de
 es
+es_AR
 fr
 hu
 it
 ja
 ko
+nl
+pl
 pt_BR
 pt
+ru
 sv
+uk
 zh_CN
 zh_HK
 zh_TW
 EOF
 
 %build
-sed -i 's/bin_PROGRAMS = beryl beryl-settings-dump beryl-xgl/bin_PROGRAMS = beryl beryl-settings-dump/' src/Makefile.am
-autoreconf -v --install
 %{__glib_gettextize}
 %{__intltoolize} --automake
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 
 # bashisms inside
 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
 
 %configure \
        %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
-       --disable-static
+       --disable-static \
+       --enable-gconf
+
 %{__make}
 
 %install
@@ -126,6 +161,11 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
+
+# program removed
+rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
+
 %find_lang %{name}
 
 %clean
@@ -136,21 +176,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README TODO
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/*.so.*.*.*
+%doc AUTHORS README TODO
+%attr(755,root,root) %{_bindir}/beryl
+%attr(755,root,root) %{_libdir}/libberyldecoration.so.*.*.*
+%attr(755,root,root) %{_libdir}/libberylsettings.so.*.*.*
 %dir %{_libdir}/beryl
 %dir %{_libdir}/beryl/backends
-%attr(755,root,root) %{_libdir}/beryl/backends/*.so
-# XXX: check if needed (I don't see libltdl in BRs)
-%{_libdir}/beryl/backends/*.la
+%attr(755,root,root) %{_libdir}/beryl/backends/libini.so
 %{_datadir}/beryl
-%{_mandir}/man1/*
+%{_mandir}/man1/beryl.1*
+%if %{with beryl_mesa}
+%attr(755,root,root) %{_bindir}/beryl-xgl
+%{_mandir}/man1/beryl-xgl.1*
+%endif
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so
-%{_libdir}/*.la
+%attr(755,root,root) %{_libdir}/libberyldecoration.so
+%attr(755,root,root) %{_libdir}/libberylsettings.so
+%{_libdir}/libberyldecoration.la
+%{_libdir}/libberylsettings.la
 %{_includedir}/beryl
-%{_pkgconfigdir}/*.pc
+%{_pkgconfigdir}/beryl.pc
+%{_pkgconfigdir}/berylsettings.pc
+%{_pkgconfigdir}/libberyldecoration.pc
 %{_mandir}/man3/*.3*
+
+%files gconf
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.076584 seconds and 4 git commands to generate.