]> git.pld-linux.org Git - packages/beryl-core.git/blob - beryl-core.spec
- updated gettext BR
[packages/beryl-core.git] / beryl-core.spec
1 #
2 # Conditional build:
3 %bcond_with     beryl_mesa      # beryl-xgl statically linked with own libGL
4 #
5
6 %define         _beryl_mesa_version     0.1.99.2
7
8 Summary:        OpenGL window and compositing manager
9 Summary(pl.UTF-8):      OpenGL-owy zarządca okien i składania
10 Name:           beryl-core
11 Version:        0.2.1
12 Release:        2
13 Epoch:          1
14 License:        GPL v2+
15 Group:          X11
16 Source0:        http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
17 # Source0-md5:  895fe727d4396f6d51ffaf73cf8460d0
18 Source1:        http://releases.beryl-project.org/%{_beryl_mesa_version}/beryl-mesa-%{_beryl_mesa_version}.tar.bz2
19 # Source1-md5:  387d068091bc5c6fa28f6d754e1296d1
20 Patch0:         %{name}-link.patch
21 URL:            http://beryl-project.org/
22 BuildRequires:  GConf2-devel >= 2.0
23 BuildRequires:  OpenGL-GLX-devel
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake >= 1:1.9
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  libpng-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  startup-notification-devel >= 0.7
34 BuildRequires:  xorg-lib-libSM-devel
35 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
36 BuildRequires:  xorg-lib-libXdamage-devel
37 BuildRequires:  xorg-lib-libXinerama-devel
38 BuildRequires:  xorg-lib-libXrandr-devel
39 BuildRequires:  xorg-lib-libXrender-devel >= 0.8.4
40 BuildRequires:  xorg-proto-glproto-devel
41 BuildRequires:  xorg-util-makedepend
42 Requires:       xorg-app-xvinfo
43 Provides:       compiz
44 Obsoletes:      compiz-quinnstorm
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Beryl is an OpenGL compositing manager that use
49 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
50 to texture objects. It has a flexible plug-in system and it is
51 designed to run well on most graphics hardware.
52
53 This is an enhanced version of compiz, developed mainly by Quinnstorm.
54 Some parts were optimized for speed and there were added few
55 additional plugins and patches, delivering even more eyecandy.
56
57 %description -l pl.UTF-8
58 Beryl jest OpenGL-owym zarządcą składania, używającym rozszerzenia
59 GLX_EXT_texture_from_pixmap w celu wiązania przekierowanych okien do
60 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
61 by dobrze działać na większości kart graficznych.
62
63 To jest udoskonalona wersja compiza, tworzona głównie przez
64 Quinnstorma. Niektóre części zostały zoptymalizowane pod względem
65 prędkości oraz dodano kilka dodatkowych wtyczek i łatek,
66 dostarczających jeszcze więcej świecidełek.
67
68 %package devel
69 Summary:        Header files for beryl
70 Summary(pl.UTF-8):      Pliki nagłówkowe dla beryla
71 Group:          X11/Development/Libraries
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73 Requires:       OpenGL-GLX-devel
74 Requires:       glib2-devel >= 2.0
75 Requires:       libpng-devel
76 Requires:       startup-notification-devel >= 0.7
77 Requires:       xorg-lib-libSM-devel
78 Requires:       xorg-lib-libXcomposite-devel >= 0.3
79 Requires:       xorg-lib-libXdamage-devel
80 Requires:       xorg-lib-libXinerama-devel
81 Requires:       xorg-lib-libXrandr-devel
82 Requires:       xorg-lib-libXrender-devel >= 0.8.4
83 Requires:       xorg-proto-glproto-devel
84 Obsoletes:      compiz-quinnstorm-devel
85
86 %description devel
87 Header files for beryl.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe dla beryla.
91
92 %package gconf
93 Summary:        GConf settings plugin for beryl
94 Summary(pl.UTF-8):      Wtyczka ustawień GConf dla beryla
95 Group:          Libraries
96 Requires:       %{name} = %{epoch}:%{version}-%{release}
97
98 %description gconf
99 GConf settings plugin for beryl.
100
101 %description gconf -l pl.UTF-8
102 Wtyczka ustawień GConf dla beryla.
103
104 %prep
105 %setup -q %{?with_beryl_mesa: -a1}
106 %patch0 -p1
107
108 mv -f po/{de_DE,de}.po
109 mv -f po/{hu_HU,hu}.po
110 mv -f po/{pt_PT,pt}.po
111 mv -f po/{sv_SE,sv}.po
112 mv -f po/{uk_UA,uk}.po
113
114 # NOTE: check the list after any upgrade!
115 cat > po/LINGUAS <<EOF
116 ca
117 cs
118 de
119 es
120 es_AR
121 fr
122 hu
123 it
124 ja
125 ko
126 nl
127 pl
128 pt_BR
129 pt
130 ru
131 sv
132 uk
133 zh_CN
134 zh_HK
135 zh_TW
136 EOF
137
138 %build
139 %{__glib_gettextize}
140 %{__intltoolize} --automake
141 %{__libtoolize}
142 %{__aclocal}
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146
147 # bashisms inside
148 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
149
150 %configure \
151         %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
152         %{?with_beryl_mesa:--enable-xgl} \
153         --disable-static \
154         --enable-gconf
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
165
166 # program removed
167 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
168
169 %find_lang %{name}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS README TODO
180 %attr(755,root,root) %{_bindir}/beryl
181 %attr(755,root,root) %{_libdir}/libberyldecoration.so.*.*.*
182 %attr(755,root,root) %{_libdir}/libberylsettings.so.*.*.*
183 %dir %{_libdir}/beryl
184 %dir %{_libdir}/beryl/backends
185 %attr(755,root,root) %{_libdir}/beryl/backends/libini.so
186 %{_datadir}/beryl
187 %{_mandir}/man1/beryl.1*
188 %if %{with beryl_mesa}
189 %attr(755,root,root) %{_bindir}/beryl-xgl
190 %{_mandir}/man1/beryl-xgl.1*
191 %endif
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libberyldecoration.so
196 %attr(755,root,root) %{_libdir}/libberylsettings.so
197 %{_libdir}/libberyldecoration.la
198 %{_libdir}/libberylsettings.la
199 %{_includedir}/beryl
200 %{_pkgconfigdir}/beryl.pc
201 %{_pkgconfigdir}/berylsettings.pc
202 %{_pkgconfigdir}/libberyldecoration.pc
203 %{_mandir}/man3/*.3*
204
205 %files gconf
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.075447 seconds and 3 git commands to generate.