]> git.pld-linux.org Git - packages/belr.git/commitdiff
- added static patch (fix both shared+static build in cmake) auto/th/belr-4.5.15-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 16 Jun 2021 18:20:15 +0000 (20:20 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 16 Jun 2021 18:20:15 +0000 (20:20 +0200)
- removed outdated pc patch

belr-pc.patch [deleted file]
belr-static.patch [new file with mode: 0644]

diff --git a/belr-pc.patch b/belr-pc.patch
deleted file mode 100644 (file)
index 1ef96a9..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- belr-0.1.3-0/belr.pc.in.orig       2016-10-19 17:22:25.000000000 +0200
-+++ belr-0.1.3-0/belr.pc.in    2019-06-02 20:53:27.903631254 +0200
-@@ -1,9 +1,9 @@
- # This is a comment
- prefix=@CMAKE_INSTALL_PREFIX@
--Name:  @PROJECT_NAME@
-+Name: @PACKAGE_NAME@
- Description: Belr is Belledonne Communications' language recognition library
- Version: @PROJECT_VERSION@
- Libs: -L@CMAKE_INSTALL_FULL_LIBDIR@ -lbelr
--Libs.private: @LIBS_PRIVATE@
-+Libs.private: @BCTOOLBOX_LIBS@
- Cflags: -I@CMAKE_INSTALL_FULL_INCLUDEDIR@
diff --git a/belr-static.patch b/belr-static.patch
new file mode 100644 (file)
index 0000000..178ba70
--- /dev/null
@@ -0,0 +1,27 @@
+--- belr-4.5.15/src/CMakeLists.txt.orig        2020-10-22 16:31:51.000000000 +0200
++++ belr-4.5.15/src/CMakeLists.txt     2021-06-15 21:41:34.307278254 +0200
+@@ -44,13 +44,20 @@
+ endif()\r
\r
+ if(ENABLE_STATIC)\r
+-      add_library(belr STATIC ${BELR_HEADER_FILES} ${BELR_SOURCE_FILES_C} ${BELR_SOURCE_FILES_CXX})\r
+-      set_target_properties(belr PROPERTIES OUTPUT_NAME belr)\r
+-      target_link_libraries(belr PUBLIC ${LIBS})\r
+-      target_include_directories(belr INTERFACE\r
++      add_library(belr-static STATIC ${BELR_HEADER_FILES} ${BELR_SOURCE_FILES_C} ${BELR_SOURCE_FILES_CXX})\r
++      set_target_properties(belr-static PROPERTIES OUTPUT_NAME belr)\r
++      target_link_libraries(belr-static PUBLIC ${LIBS})\r
++      target_include_directories(belr-static INTERFACE\r
+               $<INSTALL_INTERFACE:include>\r
+               $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include>\r
+       )\r
++install(TARGETS belr-static EXPORT ${EXPORT_TARGET_NAME}Targets\r
++      RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}\r
++      LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}\r
++      ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}\r
++      FRAMEWORK DESTINATION Frameworks\r
++      PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE\r
++)\r
+ endif()\r
+ if(ENABLE_SHARED)\r
+       add_library(belr SHARED ${BELR_HEADER_FILES} ${BELR_SOURCE_FILES_C} ${BELR_SOURCE_FILES_CXX})\r
This page took 0.177713 seconds and 4 git commands to generate.