]> git.pld-linux.org Git - packages/belr.git/blame - belr.spec
- new; using autotools as cmake doesn't produce .pc file
[packages/belr.git] / belr.spec
CommitLineData
6e8c327a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Belledonne Communications' language recognition library
6Summary(pl.UTF-8): Biblioteka rozpoznawania języków Belledonne Communications
7Name: belr
8Version: 0.1.3
9Release: 1
10License: GPL v2+
11Group: Libraries
12Source0: https://linphone.org/releases/sources/belr/%{name}-%{version}.tar.gz
13# Source0-md5: 91dc921d48db2b8337bab56996fe8800
14Patch0: %{name}-pc.patch
15URL: https://linphone.org/
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake
18BuildRequires: bctoolbox-devel >= 0.0.3
19BuildRequires: libstdc++-devel >= 6:4.7
20BuildRequires: libtool >= 2:2
21BuildRequires: pkgconfig
22Requires: bctoolbox >= 0.0.3
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Belr is Belledonne Communications' language recognition library. It
27aims at parsing any input formatted according to a language defined by
28an ABNF grammar, such as the protocols standardized at IETF.
29
30It is based on finite state machine theory and heavily relies on
31recursivity from an implementation standpoint.
32
33%description -l pl.UTF-8
34Belr to biblioteka do rozpoznawania języków Belledonne Communications.
35Jej celem jest analiza dowolnego wejścia sformatowanego zgodnie z
36językiem zdefiniowanym przez gramatykę ABNF, np. protokołów
37standaryzowanych przez IETF.
38
39Biblioteka jest oparta na teorii automatów skończonych, implementacja
40znacząco wykorzystuje rekusywność.
41
42%package devel
43Summary: Header files for belr library
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki belr
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: libstdc++-devel >= 6:4.7
48
49%description devel
50Header files for belr library.
51
52%description devel -l pl.UTF-8
53Pliki nagłówkowe biblioteki belr.
54
55%package static
56Summary: Static belr library
57Summary(pl.UTF-8): Statyczna biblioteka belr
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60
61%description static
62Static belr library.
63
64%description static -l pl.UTF-8
65Statyczna biblioteka belr.
66
67%prep
68%setup -q -n %{name}-%{version}-0
69%patch0 -p1
70
71%build
72%{__libtoolize}
73%{__aclocal} -I m4
74%{__autoconf}
75%{__autoheader}
76%{__automake}
77%configure \
78 --disable-silent-rules \
79 %{?with_static_libs:--enable-static}
80
81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
88
89%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbelr.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
99%doc NEWS README.md
100%attr(755,root,root) %{_bindir}/belr-parse
101%attr(755,root,root) %{_libdir}/libbelr.so.*.*.*
102%attr(755,root,root) %ghost %{_libdir}/libbelr.so.0
103
104%files devel
105%defattr(644,root,root,755)
106%attr(755,root,root) %{_libdir}/libbelr.so
107%{_includedir}/belr
108%{_pkgconfigdir}/belr.pc
109
110%if %{with static_libs}
111%files static
112%defattr(644,root,root,755)
113%{_libdir}/libbelr.a
114%endif
This page took 0.128252 seconds and 4 git commands to generate.