]> git.pld-linux.org Git - packages/belle-sip.git/commitdiff
- updated to 1.4.1 auto/th/belle-sip-1.4.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 17 May 2015 19:30:35 +0000 (21:30 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 17 May 2015 19:30:35 +0000 (21:30 +0200)
- removed obsolete use_after_free patch

belle-sip.spec
use_after_free.patch [deleted file]

index c5af332b5c4bfc77377b6602445bb0cabb0faa9f..350ab07be75723047f24a4f0b278728c6acbd964 100644 (file)
@@ -1,3 +1,4 @@
+# TODO: tunnel? (BR: pkgconfig(tunnel))
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static libraries
@@ -6,21 +7,20 @@
 Summary:       SIP (RFC3261) object-oriented implementation in C
 Summary(pl.UTF-8):     Implementacja SIP (RFC3261) w C
 Name:          belle-sip
-Version:       1.3.0
-Release:       3
+Version:       1.4.1
+Release:       1
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
-# Source0-md5: ae9e8be12f62552a5376edd66b0265d9
+# Source0-md5: c6460e294e77bd0646b7eda7fbe21523
 Patch0:                antlr_jar.patch
-Patch1:                use_after_free.patch
 URL:           http://www.linphone.org/
 %{?with_tests:BuildRequires:   CUnit >= 2.0}
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: java-antlr3 >= 3.2
 BuildRequires: jre
-BuildRequires: libantlr3c-devel >= 3.2
+BuildRequires: libantlr3c-devel >= 3.4
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2
 BuildRequires: polarssl-devel >= 1.2
@@ -62,7 +62,6 @@ Statyczna biblioteka %{name}.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
diff --git a/use_after_free.patch b/use_after_free.patch
deleted file mode 100644 (file)
index f8df560..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-commit 2ba6eb597c2a4a99a24e3c354341fb7bb8d0d700
-Author: Jehan Monnier <jehan.monnier@linphone.org>
-Date:   Mon Jun 2 16:32:15 2014 +0200
-
-    Change BELLE_SIP_SET_STRING macro to allow code  like obj_set_value(obj,obj_get_value(obj))
-
-diff --git a/src/belle_sip_internal.h b/src/belle_sip_internal.h
-index b6d39f1..66a5023 100644
---- a/src/belle_sip_internal.h
-+++ b/src/belle_sip_internal.h
-@@ -286,11 +286,12 @@ BELLESIP_INTERNAL_EXPORT unsigned int belle_sip_random(void);
-               return obj->attribute;\
-       }\
-       void object_type##_set_##attribute (object_type##_t* obj,const char* value) {\
--              if (obj->attribute != NULL) belle_sip_free((void*)obj->attribute);\
-+              const char* previous_value = obj->attribute;  /*preserve if same value re-asigned*/ \
-               if (value) {\
-                       obj->attribute=belle_sip_strdup(value); \
-               } else obj->attribute=NULL;\
--      }
-+              if (previous_value != NULL) belle_sip_free((void*)previous_value);\
-+}
- /*#define GET_SET_STRING_PARAM_NULL_ALLOWED(object_type,attribute) \
-       GET_STRING_PARAM2(object_type,attribute,attribute) \
-       void object_type##_set_##func_name (object_type##_t* obj,const char* value) {\
This page took 0.08801 seconds and 4 git commands to generate.