]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- updated for final 3.0.0
[packages/beecrypt.git] / beecrypt.spec
index 9a10917376f415bfb5c738b833c88ce99699f373..a37a164d993280526eb6166aadd3e8159f4608d7 100644 (file)
@@ -1,22 +1,27 @@
+#
+# Conditional build:
+# _with_javaglue
+#
+%include       /usr/lib/rpm/macros.python
+%define                snap 20030610
 Summary:       The BeeCrypt Cryptography Library
+Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       2.1.0
-Release:       1
+Version:       3.0.0
+Release:       0.%{snap}.1
+Epoch:         2
 License:       LGPL
-Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
-Source0:       http://www.virtualunlimited.com/download/%{name}-%{version}.tar.gz
-#BuildRequires:        autoconf
-#BuildRequires:        automake
-#BuildRequires:        libtool
-URL:           http://beecrypt.virtualunlimited.com/
-Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Group:         Libraries
+#Source0:      http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
+Source0:       ftp://distfiles.pld-linux.org/src/%{name}-%{version}pre.%{snap}.tar.gz
+# Source0-md5: c8659b0005a19606a7e182ff09eb10c2
+Patch0:                %{name}-opt.patch
+Patch1:                %{name}-python.patch
+URL:           http://sourceforge.net/projects/beecrypt/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BeeCrypt is an open source cryptography library that contains highly
@@ -27,78 +32,92 @@ ElGamal.
 %description -l pl
 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
-szyfrowania m.in. : Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
+szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 
 %package devel
 Summary:       The BeeCrypt Cryptography Library - development files
+Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name} = %{version}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
 
+%description devel -l pl
+Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
+
 %package static
 Summary:       The BeeCrypt Cryptography Library - static library
+Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name}-devel = %{version}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
 
+%description static -l pl
+Biblioteka statyczna BeeCrypt.
+
+%package -n python-beecrypt
+Summary:       Python interface to BeeCrypt library
+Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}
+%pyrequires_eq python
+
+%description -n python-beecrypt
+The python-beecrypt package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by BeeCrypt libraries.
+
+%description -n python-beecrypt -l pl
+Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
+Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
+
 %prep
-%setup -q
+%setup  -q -n %{name}-%{version}pre
+%patch0 -p1
+%patch1 -p1
 
 %build
-#rm -f missing
-#libtoolize --copy --force
-#aclocal
-#autoconf
-#automake -a -c
-%configure2_13 \
-       --enable-static \
-       --%{?debug:en}%{!?debug:dis}able-debug
+rm -f missing
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --with%{?!_with_javaglue:out}-javaglue \
+       --with-cpu=%{_target_cpu} \
+       --with-arch=%{_target_cpu}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf AUTHORS BENCHMARKS BUGS CONTRIBUTORS ChangeLog NEWS README
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc BUGS* NEWS* README*
+%doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc AUTHORS* BENCHMARKS* CONTRIBUTORS* ChangeLog*
-%attr(755,root,root) %{_libdir}/lib*.la
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_includedir}/beecrypt
+%{_libdir}/lib*.so
+%{_libdir}/lib*.la
+%{_includedir}/*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
+
+%files -n python-beecrypt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/*.so
This page took 0.121861 seconds and 4 git commands to generate.