]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- no need for /usr/lib64 to be used... it kills the package on alpha
[packages/beecrypt.git] / beecrypt.spec
index 9bb20a8869c73fd08a611fab59478c8c66896e45..881c0703450aa78f57ce35ea7f4e6dc534b189cb 100644 (file)
@@ -1,16 +1,25 @@
+#
+# Conditional build:
 # _with_javaglue
-%define                snap 20030516
+#
+%include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
 Version:       3.0.0
-Release:       0.%{snap}.1
+Release:       1
 Epoch:         2
 License:       LGPL
-Group:         Development/Libraries
-Source0:       http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
-Patch0:                %{name}-from_rpm.patch
+Group:         Libraries
+Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
+# Source0-md5: 18f20c22443f85bd4e285925b56198d9
+Patch0:                %{name}-opt.patch
+Patch1:                %{name}-python.patch
+Patch2:                %{name}-lib64_fix.patch
 URL:           http://sourceforge.net/projects/beecrypt/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+BuildRequires: libtool
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -28,7 +37,7 @@ szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 Summary:       The BeeCrypt Cryptography Library - development files
 Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
@@ -40,7 +49,7 @@ Biblioteka kryptograficzna BeeCrypt - pliki dla programist
 Summary:       The BeeCrypt Cryptography Library - static library
 Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
@@ -48,9 +57,27 @@ The BeeCrypt Cryptography Library - static library.
 %description static -l pl
 Biblioteka statyczna BeeCrypt.
 
+%package -n python-beecrypt
+Summary:       Python interface to BeeCrypt library
+Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
+Group:         Development/Languages/Python
+Requires:      %{name} = %{epoch}:%{version}
+%pyrequires_eq python
+
+%description -n python-beecrypt
+The python-beecrypt package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by BeeCrypt libraries.
+
+%description -n python-beecrypt -l pl
+Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
+Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
+
 %prep
-%setup  -q -n %{name}-%{version}pre
+%setup  -q
 %patch0 -p1
+%patch1 -p1
+%patch2
 
 %build
 rm -f missing
@@ -60,23 +87,31 @@ rm -f missing
 %{__autoheader}
 %{__automake}
 %configure \
-       --with%{?!_with_javaglue:out}-javaglue
+       --with%{?!_with_javaglue:out}-javaglue \
+       --with-cpu=%{_target_cpu} \
+       --with-arch=%{_target_cpu}
 %{__make}
 
+%{__make} -C python
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__make} install -C python \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc README* CONTRIBUTORS AUTHORS BUGS NEWS 
+%doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
@@ -88,3 +123,7 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
+
+%files -n python-beecrypt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/*.so
This page took 0.112511 seconds and 4 git commands to generate.