]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- documentation generated with doxygen
[packages/beecrypt.git] / beecrypt.spec
index 8fea6b954bc43b8c1f5e62a75bb0aeadf33d5ac2..7d55be80007679eda4f331d159de358a09fdf54b 100644 (file)
@@ -1,29 +1,34 @@
 #
+# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
 # Conditional build:
 %bcond_with    javaglue        # build with Java support
 %bcond_without python          # don't build python module
 #
-%include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.1.0
+Version:       4.0.0
 Release:       2
 Epoch:         2
 License:       LGPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 1472cada46e2ab9f532f984de9740386
+# Source0-md5: f19e060ecc4fc23d8f1268e1b145614f
 Patch0:                %{name}-opt.patch
-Patch1:                %{name}-python.patch
-Patch2:                %{name}-lib64_fix.patch
+Patch1:                %{name}-lib64_fix.patch
+Patch2:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+BuildRequires: doxygen
 BuildRequires: libtool
+%if %{with python}
+BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        specflags_alpha         "-mno-explicit-relocs"
+%define                specflags_alpha          -mno-explicit-relocs 
 
 %description
 BeeCrypt is an open source cryptography library that contains highly
@@ -40,7 +45,7 @@ szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 Summary:       The BeeCrypt Cryptography Library - development files
 Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
@@ -52,7 +57,7 @@ Biblioteka kryptograficzna BeeCrypt - pliki dla programist
 Summary:       The BeeCrypt Cryptography Library - static library
 Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
@@ -64,7 +69,7 @@ Biblioteka statyczna BeeCrypt.
 Summary:       Python interface to BeeCrypt library
 Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
 Group:         Development/Languages/Python
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 %pyrequires_eq python
 
 %description -n python-beecrypt
@@ -77,48 +82,49 @@ Pakiet python-beecrypt zawiera modu
 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2
+%patch2 -p1
+
+# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
+# makes it (and thus rpm) depending on libstdc++ which is unacceptable
+%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
 
 %build
-rm -f missing
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       --without-cplusplus \
        --with%{!?with_javaglue:out}-javaglue \
        --with-cpu=%{_target_cpu} \
        --with-arch=%{_target_cpu} \
        --with-pic \
        --with%{!?with_python:out}-python
-%{__make} \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir}
+%{__make}
 
 %if %{with python}
-%{__make} -C python \
-       pylibdir=%{py_libdir}
+%{__make} -C python
 %endif
 
+doxygen
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}
 
 %{__make} install \
-       libaltdir=%{_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with python}
 %{__make} install -C python \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -132,6 +138,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%doc docs/html/*
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/*
This page took 0.091265 seconds and 4 git commands to generate.