]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- rel 3
[packages/beecrypt.git] / beecrypt.spec
index bc3c1d406008bc08a78e0b4025aed26c8b0b67e4..1cdb29d822723dce180bdad545d1398812b4444f 100644 (file)
@@ -2,31 +2,26 @@
 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
 #
 # Conditional build:
-%bcond_without java    # build with Java support
+%bcond_without java            # build with Java support
 %bcond_with    javac           # use javac instead of gcj
 %bcond_without python          # don't build python module
-%bcond_without doc             # don't build documentation
 %bcond_without static_libs     # don't build static libraries
 #
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl.UTF-8):     Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       4.1.2
-Release:       6
+Version:       4.2.1
+Release:       3
 Epoch:         2
-License:       LGPL
+License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 820d26437843ab0a6a8a5151a73a657c
-Patch0:                %{name}-opt.patch
-Patch1:                %{name}-lib64_fix.patch
-Patch2:                %{name}-ac_python.patch
+Source0:       http://dl.sourceforge.net/project/beecrypt/beecrypt/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 8441c014170823f2dff97e33df55af1e
+Patch0:                %{name}-ac.patch
+Patch1:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-%if %{with doc}
-BuildRequires: doxygen
-%endif
 %if %{with java} && !%{with javac}
 %ifarch i586 i686 athlon pentium3 pentium4 %{x8664}
 BuildRequires: jdk
@@ -35,10 +30,6 @@ BuildRequires:       gcc-java
 BuildRequires: libgcj-devel
 %endif
 %endif
-%if %{with doc}
-BuildRequires: ghostscript
-BuildRequires: graphviz
-%endif
 %if %{with java} && %{with javac}
 BuildRequires: jdk
 %endif
@@ -49,16 +40,14 @@ BuildRequires:      python-modules
 BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: rpmbuild(macros) >= 1.213
-%if %{with doc}
-BuildRequires: tetex-dvips
-BuildRequires: tetex-format-latex
-BuildRequires: tetex-latex-dstroke
-# note: this is incorrect place, it should be somewhere in tetex packages
-BuildRequires: tetex-metafont
-%endif
+Obsoletes:     beecrypt-doc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                specflags_alpha          -mno-explicit-relocs
+%define                specflags_alpha         -mno-explicit-relocs
+%define                specflags_pentium2      -mmmx
+%define                specflags_pentium3      -mmmx -msse
+%define                specflags_pentium4      -mmmx -msse -msse2
+%define                specflags_athlon        -mmmx
 
 %description
 BeeCrypt is an open source cryptography library that contains highly
@@ -95,17 +84,6 @@ The BeeCrypt Cryptography Library - static library.
 %description static -l pl.UTF-8
 Biblioteka statyczna BeeCrypt.
 
-%package doc
-Summary:       Development documentation for BeeCrypt
-Summary(pl.UTF-8):     Dokumentacja programisty dla biblioteki BeeCrypt
-Group:         Documentation
-
-%description doc
-Development documentation for BeeCrypt.
-
-%description doc -l pl.UTF-8
-Dokumentacja programisty dla biblioteki BeeCrypt.
-
 %package java
 Summary:       BeeCrypt Java glue library
 Summary(pl.UTF-8):     Biblioteka łącząca BeeCrypt z Javą
@@ -164,13 +142,10 @@ bibliotekę BeeCrytp.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
-# only html docs
-%{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
 
 %build
 %{__libtoolize}
@@ -179,27 +154,14 @@ bibliotekę BeeCrytp.
 %{__autoheader}
 %{__automake}
 %configure \
+       --disable-openmp \
        %{?with_javac:ac_cv_have_gcj=no} \
+       %{!?with_static_libs:--disable-static} \
        --without-cplusplus \
        --with%{!?with_java:out}-java \
-       --with-cpu=%{_target_cpu} \
-       %{!?with_static_libs:--enable-static=no} \
-%ifarch %{x8664}
-       --with-arch=x86_64 \
-%else
-       --with-arch=%{_target_cpu} \
-%endif
-       --with-pic \
-       --with%{!?with_python:out}-python
-%{__make}
+       %{!?with_python:--without-python}
 
-%if %{with python}
-%{__make} -C python
-%endif
-
-%if %{with doc}
-doxygen
-%endif
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -208,16 +170,11 @@ install -d $RPM_BUILD_ROOT/%{_lib}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with python}
-%{__make} install -C python \
-       DESTDIR=$RPM_BUILD_ROOT
-%endif
-
-mv -f $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
-ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libbeecrypt.so.*.*.*) \
+mv -f $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so.* $RPM_BUILD_ROOT/%{_lib}
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libbeecrypt.so.*.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so
 
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+%{?with_python:%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -232,6 +189,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
 %attr(755,root,root) /%{_lib}/libbeecrypt.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libbeecrypt.so.7
 
 %files devel
 %defattr(644,root,root,755)
@@ -249,6 +207,7 @@ rm -rf $RPM_BUILD_ROOT
 %files java
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libbeecrypt_java.so.7
 
 %files java-devel
 %defattr(644,root,root,755)
@@ -262,14 +221,8 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %endif
 
-%if %{with doc}
-%files doc
-%defattr(644,root,root,755)
-%doc docs/html
-%endif
-
 %if %{with python}
 %files -n python-beecrypt
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/*.so
+%attr(755,root,root) %{py_sitedir}/_bc.so
 %endif
This page took 0.069238 seconds and 4 git commands to generate.