]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- added -ac_python.patch - fix for python sitedir path
[packages/beecrypt.git] / beecrypt.spec
index ba88413cb03f2a475133053cc0d1c3a2dea17144..0c6eb587fa8e6ef261002be72be1f0153b0c7257 100644 (file)
@@ -1,30 +1,33 @@
 #
+# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
 # Conditional build:
 %bcond_with    javaglue        # build with Java support
 %bcond_without python          # don't build python module
 #
-%include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.1.0
-Release:       3
+Version:       4.0.0
+Release:       1
 Epoch:         2
 License:       LGPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 1472cada46e2ab9f532f984de9740386
+# Source0-md5: f19e060ecc4fc23d8f1268e1b145614f
 Patch0:                %{name}-opt.patch
-Patch1:                %{name}-python.patch
-Patch2:                %{name}-lib64_fix.patch
+Patch1:                %{name}-lib64_fix.patch
+Patch2:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
+%if %{with python}
 BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        specflags_alpha         "-mno-explicit-relocs"
+%define                specflags_alpha          -mno-explicit-relocs 
 
 %description
 BeeCrypt is an open source cryptography library that contains highly
@@ -78,48 +81,47 @@ Pakiet python-beecrypt zawiera modu
 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2
+%patch2 -p1
+
+# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
+# makes it (and thus rpm) depending on libstdc++ which is unacceptable
+%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
 
 %build
-rm -f missing
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       --without-cplusplus \
        --with%{!?with_javaglue:out}-javaglue \
        --with-cpu=%{_target_cpu} \
        --with-arch=%{_target_cpu} \
        --with-pic \
        --with%{!?with_python:out}-python
-%{__make} \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir}
+%{__make}
 
 %if %{with python}
-%{__make} -C python \
-       pylibdir=%{py_libdir}
+%{__make} -C python
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}
 
 %{__make} install \
-       libaltdir=%{_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with python}
 %{__make} install -C python \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.170989 seconds and 4 git commands to generate.