]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
fd2a126c668e7ea08e90ecd25de5edb00c39b269
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 %bcond_with     javaglue        # build with Java support
4 %bcond_without  python          # don't build python module
5 #
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        4.0.0
10 Release:        1
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
15 # Source0-md5:  f19e060ecc4fc23d8f1268e1b145614f
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-lib64_fix.patch
18 URL:            http://sourceforge.net/projects/beecrypt/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 %{?with_python:BuildRequires:   python-devel}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         specflags_alpha          -mno-explicit-relocs 
26
27 %description
28 BeeCrypt is an open source cryptography library that contains highly
29 optimized C and assembler implementations of many well-known
30 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
31 ElGamal.
32
33 %description -l pl
34 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
35 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
36 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
37
38 %package devel
39 Summary:        The BeeCrypt Cryptography Library - development files
40 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
41 Group:          Development/Libraries
42 Requires:       %{name} = %{epoch}:%{version}-%{release}
43
44 %description devel
45 The BeeCrypt Cryptography Library - development files.
46
47 %description devel -l pl
48 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
49
50 %package static
51 Summary:        The BeeCrypt Cryptography Library - static library
52 Summary(pl):    Biblioteka statyczna BeeCrypt
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
55
56 %description static
57 The BeeCrypt Cryptography Library - static library.
58
59 %description static -l pl
60 Biblioteka statyczna BeeCrypt.
61
62 %package -n python-beecrypt
63 Summary:        Python interface to BeeCrypt library
64 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
65 Group:          Development/Languages/Python
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 %pyrequires_eq  python
68
69 %description -n python-beecrypt
70 The python-beecrypt package contains a module which permits applications
71 written in the Python programming language to use the interface
72 supplied by BeeCrypt libraries.
73
74 %description -n python-beecrypt -l pl
75 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
76 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82
83 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
84 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
85 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --without-cplusplus \
95         --with%{!?with_javaglue:out}-javaglue \
96         --with-cpu=%{_target_cpu} \
97         --with-arch=%{_target_cpu} \
98         --with-pic \
99         --with%{!?with_python:out}-python
100 %{__make}
101
102 %if %{with python}
103 %{__make} -C python
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %if %{with python}
113 %{__make} install -C python \
114         DESTDIR=$RPM_BUILD_ROOT
115 %endif
116
117 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %{_libdir}/lib*.la
134 %{_includedir}/*
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/lib*.a
139
140 %if %{with python}
141 %files -n python-beecrypt
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{py_sitedir}/*.so
144 %endif
This page took 0.036366 seconds and 2 git commands to generate.