]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
f66fd929337cd9c29b84ff31a4d0cc8d8656ac07
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.1.1
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  b412cb2a692f689bfcd43f29733c3039
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 Patch2:         %{name}-ac_python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  doxygen
24 BuildRequires:  ghostscript
25 BuildRequires:  libtool
26 BuildRequires:  libgcj-devel
27 %if %{with python}
28 BuildRequires:  python-devel
29 BuildRequires:  python-modules
30 %endif
31 BuildRequires:  tetex-dvips
32 BuildRequires:  tetex-format-latex
33 BuildRequires:  tetex-latex-dstroke
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         specflags_alpha          -mno-explicit-relocs 
37
38 %description
39 BeeCrypt is an open source cryptography library that contains highly
40 optimized C and assembler implementations of many well-known
41 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
42 ElGamal.
43
44 %description -l pl
45 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
46 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
47 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
48
49 %package devel
50 Summary:        The BeeCrypt Cryptography Library - development files
51 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
52 Group:          Development/Libraries
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54
55 %description devel
56 The BeeCrypt Cryptography Library - development files.
57
58 %description devel -l pl
59 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
60
61 %package static
62 Summary:        The BeeCrypt Cryptography Library - static library
63 Summary(pl):    Biblioteka statyczna BeeCrypt
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
66
67 %description static
68 The BeeCrypt Cryptography Library - static library.
69
70 %description static -l pl
71 Biblioteka statyczna BeeCrypt.
72
73 %package doc
74 Summary:        Development documentation for BeeCrypt
75 Summary(pl):    Dokumentacja programisty dla biblioteki BeeCrypt
76 Group:          Documentation
77
78 %description doc
79 Development documentation for BeeCrypt.
80
81 %description doc -l pl
82 Dokumentacja programisty dla biblioteki BeeCrypt.
83
84 %package -n python-beecrypt
85 Summary:        Python interface to BeeCrypt library
86 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
87 Group:          Development/Languages/Python
88 Requires:       %{name} = %{epoch}:%{version}-%{release}
89 %pyrequires_eq  python
90
91 %description -n python-beecrypt
92 The python-beecrypt package contains a module which permits applications
93 written in the Python programming language to use the interface
94 supplied by BeeCrypt libraries.
95
96 %description -n python-beecrypt -l pl
97 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
98 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
107 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
108 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
109 # only html docs
110 %{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
111
112 %build
113 %{__libtoolize}
114 %{__aclocal}
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --without-cplusplus \
120         --with%{!?with_javaglue:out}-javaglue \
121         --with-cpu=%{_target_cpu} \
122         --with-arch=%{_target_cpu} \
123         --with-pic \
124         --with%{!?with_python:out}-python
125 %{__make}
126
127 %if %{with python}
128 %{__make} -C python
129 %endif
130
131 doxygen
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %if %{with python}
140 %{__make} install -C python \
141         DESTDIR=$RPM_BUILD_ROOT
142 %endif
143
144 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
155 %attr(755,root,root) %{_libdir}/lib*.so.*.*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/lib*.so
160 %{_libdir}/lib*.la
161 %{_includedir}/*
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/lib*.a
166
167 %files doc
168 %defattr(644,root,root,755)
169 %doc docs/html/*
170
171 %if %{with python}
172 %files -n python-beecrypt
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{py_sitedir}/*.so
175 %endif
This page took 0.054894 seconds and 2 git commands to generate.