]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- seems like broken python deps on ftp. rel 2 and rebuild to see what happens
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 # _with_javaglue
4 #
5 %include        /usr/lib/rpm/macros.python
6 Summary:        The BeeCrypt Cryptography Library
7 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
8 Name:           beecrypt
9 Version:        3.1.0
10 Release:        2
11 Epoch:          2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
15 # Source0-md5:  1472cada46e2ab9f532f984de9740386
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-python.patch
18 Patch2:         %{name}-lib64_fix.patch
19 URL:            http://sourceforge.net/projects/beecrypt/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define specflags_alpha         "-mno-explicit-relocs"
26
27 %description
28 BeeCrypt is an open source cryptography library that contains highly
29 optimized C and assembler implementations of many well-known
30 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
31 ElGamal.
32
33 %description -l pl
34 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
35 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
36 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
37
38 %package devel
39 Summary:        The BeeCrypt Cryptography Library - development files
40 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
41 Group:          Development/Libraries
42 Requires:       %{name} = %{epoch}:%{version}
43
44 %description devel
45 The BeeCrypt Cryptography Library - development files.
46
47 %description devel -l pl
48 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
49
50 %package static
51 Summary:        The BeeCrypt Cryptography Library - static library
52 Summary(pl):    Biblioteka statyczna BeeCrypt
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{epoch}:%{version}
55
56 %description static
57 The BeeCrypt Cryptography Library - static library.
58
59 %description static -l pl
60 Biblioteka statyczna BeeCrypt.
61
62 %package -n python-beecrypt
63 Summary:        Python interface to BeeCrypt library
64 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
65 Group:          Development/Languages/Python
66 Requires:       %{name} = %{epoch}:%{version}
67 %pyrequires_eq  python
68
69 %description -n python-beecrypt
70 The python-beecrypt package contains a module which permits applications
71 written in the Python programming language to use the interface
72 supplied by BeeCrypt libraries.
73
74 %description -n python-beecrypt -l pl
75 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
76 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
77
78 %prep
79 %setup  -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2
83
84 %build
85 rm -f missing
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         --with%{?!_with_javaglue:out}-javaglue \
93         --with-cpu=%{_target_cpu} \
94         --with-arch=%{_target_cpu} \
95         --with-python
96 %{__make}
97
98 %{__make} -C python
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__make} install -C python \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
118 %attr(755,root,root) %{_libdir}/lib*.so.*.*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/lib*.so
123 %{_libdir}/lib*.la
124 %{_includedir}/*
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.a
129
130 %files -n python-beecrypt
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.085133 seconds and 3 git commands to generate.