]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- fix specflags (quotation here is buggy)
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # Conditional build:
3 %bcond_with     javaglue        # build with Java support
4 %bcond_without  python          # don't build python module
5 #
6 %include        /usr/lib/rpm/macros.python
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        3.1.0
11 Release:        3
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  1472cada46e2ab9f532f984de9740386
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-python.patch
19 Patch2:         %{name}-lib64_fix.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 %{?with_python:BuildRequires:   python-devel}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define specflags_alpha          -mno-explicit-relocs 
28
29 %description
30 BeeCrypt is an open source cryptography library that contains highly
31 optimized C and assembler implementations of many well-known
32 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
33 ElGamal.
34
35 %description -l pl
36 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
37 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
38 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
39
40 %package devel
41 Summary:        The BeeCrypt Cryptography Library - development files
42 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
43 Group:          Development/Libraries
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45
46 %description devel
47 The BeeCrypt Cryptography Library - development files.
48
49 %description devel -l pl
50 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
51
52 %package static
53 Summary:        The BeeCrypt Cryptography Library - static library
54 Summary(pl):    Biblioteka statyczna BeeCrypt
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
57
58 %description static
59 The BeeCrypt Cryptography Library - static library.
60
61 %description static -l pl
62 Biblioteka statyczna BeeCrypt.
63
64 %package -n python-beecrypt
65 Summary:        Python interface to BeeCrypt library
66 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
67 Group:          Development/Languages/Python
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69 %pyrequires_eq  python
70
71 %description -n python-beecrypt
72 The python-beecrypt package contains a module which permits applications
73 written in the Python programming language to use the interface
74 supplied by BeeCrypt libraries.
75
76 %description -n python-beecrypt -l pl
77 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
78 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
79
80 %prep
81 %setup  -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2
85
86 %build
87 rm -f missing
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --with%{!?with_javaglue:out}-javaglue \
95         --with-cpu=%{_target_cpu} \
96         --with-arch=%{_target_cpu} \
97         --with-pic \
98         --with%{!?with_python:out}-python
99 %{__make} \
100         libaltdir=%{_libdir} \
101         pylibdir=%{py_libdir}
102
103 %if %{with python}
104 %{__make} -C python \
105         pylibdir=%{py_libdir}
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_libdir}
111
112 %{__make} install \
113         libaltdir=%{_libdir} \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %if %{with python}
117 %{__make} install -C python \
118         libaltdir=%{_libdir} \
119         pylibdir=%{py_libdir} \
120         DESTDIR=$RPM_BUILD_ROOT
121 %endif
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
132 %attr(755,root,root) %{_libdir}/lib*.so.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/lib*.so
137 %{_libdir}/lib*.la
138 %{_includedir}/*
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/lib*.a
143
144 %if %{with python}
145 %files -n python-beecrypt
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{py_sitedir}/*.so
148 %endif
This page took 0.067585 seconds and 3 git commands to generate.