]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- BR: tetex-metafont (should be somewhere in tetex-*, not here)
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 #
4 # Conditional build:
5 %bcond_without  javaglue        # build with Java support
6 %bcond_with     javac           # use javac instead of gcj
7 %bcond_without  python          # don't build python module
8 #
9 Summary:        The BeeCrypt Cryptography Library
10 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
11 Name:           beecrypt
12 Version:        4.1.2
13 Release:        1
14 Epoch:          2
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://heanet.dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
18 # Source0-md5:  820d26437843ab0a6a8a5151a73a657c
19 Patch0:         %{name}-opt.patch
20 Patch1:         %{name}-lib64_fix.patch
21 Patch2:         %{name}-ac_python.patch
22 URL:            http://sourceforge.net/projects/beecrypt/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  doxygen
26 %if %{with javaglue} && !%{with javac}
27 BuildRequires:  gcj
28 %endif
29 BuildRequires:  ghostscript
30 BuildRequires:  graphviz
31 %if %{with javaglue} && %{with javac}
32 BuildRequires:  jdk
33 %endif
34 BuildRequires:  libtool
35 BuildRequires:  libgcj-devel
36 %if %{with python}
37 BuildRequires:  python-devel
38 BuildRequires:  python-modules
39 %endif
40 BuildRequires:  tetex-dvips
41 BuildRequires:  tetex-format-latex
42 BuildRequires:  tetex-latex-dstroke
43 # note: this is incorrect place, it should be somewhere in tetex packages
44 BuildRequires:  tetex-metafont
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         specflags_alpha          -mno-explicit-relocs 
48
49 %description
50 BeeCrypt is an open source cryptography library that contains highly
51 optimized C and assembler implementations of many well-known
52 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
53 ElGamal.
54
55 %description -l pl
56 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
57 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
58 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
59
60 %package devel
61 Summary:        The BeeCrypt Cryptography Library - development files
62 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
63 Group:          Development/Libraries
64 Requires:       %{name} = %{epoch}:%{version}-%{release}
65
66 %description devel
67 The BeeCrypt Cryptography Library - development files.
68
69 %description devel -l pl
70 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
71
72 %package static
73 Summary:        The BeeCrypt Cryptography Library - static library
74 Summary(pl):    Biblioteka statyczna BeeCrypt
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
77
78 %description static
79 The BeeCrypt Cryptography Library - static library.
80
81 %description static -l pl
82 Biblioteka statyczna BeeCrypt.
83
84 %package doc
85 Summary:        Development documentation for BeeCrypt
86 Summary(pl):    Dokumentacja programisty dla biblioteki BeeCrypt
87 Group:          Documentation
88
89 %description doc
90 Development documentation for BeeCrypt.
91
92 %description doc -l pl
93 Dokumentacja programisty dla biblioteki BeeCrypt.
94
95 %package java
96 Summary:        BeeCrypt Java glue library
97 Summary(pl):    Biblioteka ³±cz±ca BeeCrypt z Jav±
98 Group:          Libraries
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description java
102 BeeCrypt Java glue library.
103
104 %description java -l pl
105 Biblioteka ³±cz±ca BeeCrypt z Jav±.
106
107 %package java-devel
108 Summary:        Development files for BeeCrypt Java glue library
109 Summary(pl):    Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112 Requires:       %{name}-java = %{epoch}:%{version}-%{release}
113
114 %description java-devel
115 Development files for BeeCrypt Java glue library.
116
117 %description java-devel -l pl
118 Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±.
119
120 %package java-static
121 Summary:        BeeCrypt Java glue static library
122 Summary(pl):    Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±
123 Group:          Development/Libraries
124 Requires:       %{name}-java-devel = %{epoch}:%{version}-%{release}
125
126 %description java-static
127 BeeCrypt Java glue static library.
128
129 %description java-static -l pl
130 Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±.
131
132 %package -n python-beecrypt
133 Summary:        Python interface to BeeCrypt library
134 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
135 Group:          Development/Languages/Python
136 Requires:       %{name} = %{epoch}:%{version}-%{release}
137 %pyrequires_eq  python-libs
138
139 %description -n python-beecrypt
140 The python-beecrypt package contains a module which permits applications
141 written in the Python programming language to use the interface
142 supplied by BeeCrypt libraries.
143
144 %description -n python-beecrypt -l pl
145 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
146 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
147
148 %prep
149 %setup -q
150 %patch0 -p1
151 %patch1 -p1
152 %patch2 -p1
153
154 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
155 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
156 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
157 # only html docs
158 %{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
159
160 %build
161 %{__libtoolize}
162 %{__aclocal}
163 %{__autoconf}
164 %{__autoheader}
165 %{__automake}
166 %configure \
167         %{?with_javac:ac_cv_have_gcj=no} \
168         --without-cplusplus \
169         --with%{!?with_javaglue:out}-javaglue \
170         --with-cpu=%{_target_cpu} \
171         --with-arch=%{_target_cpu} \
172         --with-pic \
173         --with%{!?with_python:out}-python
174 %{__make}
175
176 %if %{with python}
177 %{__make} -C python
178 %endif
179
180 doxygen
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT
187
188 %if %{with python}
189 %{__make} install -C python \
190         DESTDIR=$RPM_BUILD_ROOT
191 %endif
192
193 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %post   java -p /sbin/ldconfig
202 %postun java -p /sbin/ldconfig
203
204 %files
205 %defattr(644,root,root,755)
206 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
207 %attr(755,root,root) %{_libdir}/libbeecrypt.so.*.*.*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libbeecrypt.so
212 %{_libdir}/libbeecrypt.la
213 %{_includedir}/beecrypt
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libbeecrypt.a
218
219 %if %{with javaglue}
220 %files java
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
223
224 %files java-devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so
227 %{_libdir}/libbeecrypt_java.la
228
229 %files java-static
230 %defattr(644,root,root,755)
231 %{_libdir}/libbeecrypt_java.a
232 %endif
233
234 %files doc
235 %defattr(644,root,root,755)
236 %doc docs/html/*
237
238 %if %{with python}
239 %files -n python-beecrypt
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{py_sitedir}/*.so
242 %endif
This page took 0.048951 seconds and 3 git commands to generate.