]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- fix python sitedir path - distutils.sysconfig.get_python_lib() points at
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.0.0
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  f19e060ecc4fc23d8f1268e1b145614f
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 URL:            http://sourceforge.net/projects/beecrypt/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 %{?with_python:BuildRequires:   python-devel}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         specflags_alpha          -mno-explicit-relocs 
27
28 %description
29 BeeCrypt is an open source cryptography library that contains highly
30 optimized C and assembler implementations of many well-known
31 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
32 ElGamal.
33
34 %description -l pl
35 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
36 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
37 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
38
39 %package devel
40 Summary:        The BeeCrypt Cryptography Library - development files
41 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
42 Group:          Development/Libraries
43 Requires:       %{name} = %{epoch}:%{version}-%{release}
44
45 %description devel
46 The BeeCrypt Cryptography Library - development files.
47
48 %description devel -l pl
49 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
50
51 %package static
52 Summary:        The BeeCrypt Cryptography Library - static library
53 Summary(pl):    Biblioteka statyczna BeeCrypt
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
56
57 %description static
58 The BeeCrypt Cryptography Library - static library.
59
60 %description static -l pl
61 Biblioteka statyczna BeeCrypt.
62
63 %package -n python-beecrypt
64 Summary:        Python interface to BeeCrypt library
65 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
66 Group:          Development/Languages/Python
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 %pyrequires_eq  python
69
70 %description -n python-beecrypt
71 The python-beecrypt package contains a module which permits applications
72 written in the Python programming language to use the interface
73 supplied by BeeCrypt libraries.
74
75 %description -n python-beecrypt -l pl
76 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
77 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
85 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
86 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --without-cplusplus \
96         --with%{!?with_javaglue:out}-javaglue \
97         --with-cpu=%{_target_cpu} \
98         --with-arch=%{_target_cpu} \
99         --with-pic \
100         --with%{!?with_python:out}-python
101 %{__make}
102
103 %if %{with python}
104 %{__make} -C python
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %if %{with python}
114 %{__make} install -C python \
115         DESTDIR=$RPM_BUILD_ROOT
116 %endif
117
118 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
129 %attr(755,root,root) %{_libdir}/lib*.so.*.*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/lib*.so
134 %{_libdir}/lib*.la
135 %{_includedir}/*
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/lib*.a
140
141 %if %{with python}
142 %files -n python-beecrypt
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{py_sitedir}/*.so
145 %endif
This page took 0.04752 seconds and 3 git commands to generate.