]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
2a72b4146565714eabcda9e87a4433f35d11c98e
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.1.0
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  073e224bdb27de411c2450717e9aa94c
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 Patch2:         %{name}-ac_python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  doxygen
24 BuildRequires:  libtool
25 %if %{with python}
26 BuildRequires:  python-devel
27 BuildRequires:  python-modules
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         specflags_alpha          -mno-explicit-relocs 
32
33 %description
34 BeeCrypt is an open source cryptography library that contains highly
35 optimized C and assembler implementations of many well-known
36 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
37 ElGamal.
38
39 %description -l pl
40 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
41 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
42 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
43
44 %package devel
45 Summary:        The BeeCrypt Cryptography Library - development files
46 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description devel
51 The BeeCrypt Cryptography Library - development files.
52
53 %description devel -l pl
54 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
55
56 %package static
57 Summary:        The BeeCrypt Cryptography Library - static library
58 Summary(pl):    Biblioteka statyczna BeeCrypt
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
61
62 %description static
63 The BeeCrypt Cryptography Library - static library.
64
65 %description static -l pl
66 Biblioteka statyczna BeeCrypt.
67
68 %package -n python-beecrypt
69 Summary:        Python interface to BeeCrypt library
70 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
71 Group:          Development/Languages/Python
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73 %pyrequires_eq  python
74
75 %description -n python-beecrypt
76 The python-beecrypt package contains a module which permits applications
77 written in the Python programming language to use the interface
78 supplied by BeeCrypt libraries.
79
80 %description -n python-beecrypt -l pl
81 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
82 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
91 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
92 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --without-cplusplus \
102         --with%{!?with_javaglue:out}-javaglue \
103         --with-cpu=%{_target_cpu} \
104         --with-arch=%{_target_cpu} \
105         --with-pic \
106         --with%{!?with_python:out}-python
107 %{__make}
108
109 %if %{with python}
110 %{__make} -C python
111 %endif
112
113 doxygen
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %if %{with python}
122 %{__make} install -C python \
123         DESTDIR=$RPM_BUILD_ROOT
124 %endif
125
126 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %doc docs/html/*
142 %attr(755,root,root) %{_libdir}/lib*.so
143 %{_libdir}/lib*.la
144 %{_includedir}/*
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/lib*.a
149
150 %if %{with python}
151 %files -n python-beecrypt
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{py_sitedir}/*.so
154 %endif
This page took 0.07566 seconds and 2 git commands to generate.