]> git.pld-linux.org Git - packages/beecrypt.git/blob - beecrypt.spec
- doxygen needs ghostscript,tetex-dvips,tetex-format-latex,tetex-latex-dstroke
[packages/beecrypt.git] / beecrypt.spec
1 #
2 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3 # Conditional build:
4 %bcond_with     javaglue        # build with Java support
5 %bcond_without  python          # don't build python module
6 #
7 Summary:        The BeeCrypt Cryptography Library
8 Summary(pl):    Biblioteka kryptograficzna BeeCrypt
9 Name:           beecrypt
10 Version:        4.1.0
11 Release:        1
12 Epoch:          2
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
16 # Source0-md5:  073e224bdb27de411c2450717e9aa94c
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-lib64_fix.patch
19 Patch2:         %{name}-ac_python.patch
20 URL:            http://sourceforge.net/projects/beecrypt/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  doxygen
24 BuildRequires:  ghostscript
25 BuildRequires:  libtool
26 %if %{with python}
27 BuildRequires:  python-devel
28 BuildRequires:  python-modules
29 %endif
30 BuildRequires:  tetex-dvips
31 BuildRequires:  tetex-format-latex
32 BuildRequires:  tetex-latex-dstroke
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags_alpha          -mno-explicit-relocs 
36
37 %description
38 BeeCrypt is an open source cryptography library that contains highly
39 optimized C and assembler implementations of many well-known
40 algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
41 ElGamal.
42
43 %description -l pl
44 BeeCrypt jest open sourcow± bibliotek±, która zawiera wysoko
45 zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
46 szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
47
48 %package devel
49 Summary:        The BeeCrypt Cryptography Library - development files
50 Summary(pl):    Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53
54 %description devel
55 The BeeCrypt Cryptography Library - development files.
56
57 %description devel -l pl
58 Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
59
60 %package static
61 Summary:        The BeeCrypt Cryptography Library - static library
62 Summary(pl):    Biblioteka statyczna BeeCrypt
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
65
66 %description static
67 The BeeCrypt Cryptography Library - static library.
68
69 %description static -l pl
70 Biblioteka statyczna BeeCrypt.
71
72 %package doc
73 Summary:        Development documentation for BeeCrypt
74 Summary(pl):    Dokumentacja programisty dla biblioteki BeeCrypt
75 Group:          Documentation
76
77 %description doc
78 Development documentation for BeeCrypt.
79
80 %description doc -l pl
81 Dokumentacja programisty dla biblioteki BeeCrypt.
82
83 %package -n python-beecrypt
84 Summary:        Python interface to BeeCrypt library
85 Summary(pl):    Pythonowy interfejs do biblioteki BeeCrypt
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88 %pyrequires_eq  python
89
90 %description -n python-beecrypt
91 The python-beecrypt package contains a module which permits applications
92 written in the Python programming language to use the interface
93 supplied by BeeCrypt libraries.
94
95 %description -n python-beecrypt -l pl
96 Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
97 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104
105 # --with-cplusplus or building (even empty) *.cxx into libbeecrypt
106 # makes it (and thus rpm) depending on libstdc++ which is unacceptable
107 %{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
108 # only html docs
109 %{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --without-cplusplus \
119         --with%{!?with_javaglue:out}-javaglue \
120         --with-cpu=%{_target_cpu} \
121         --with-arch=%{_target_cpu} \
122         --with-pic \
123         --with%{!?with_python:out}-python
124 %{__make}
125
126 %if %{with python}
127 %{__make} -C python
128 %endif
129
130 doxygen
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %if %{with python}
139 %{__make} install -C python \
140         DESTDIR=$RPM_BUILD_ROOT
141 %endif
142
143 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
154 %attr(755,root,root) %{_libdir}/lib*.so.*.*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/lib*.so
159 %{_libdir}/lib*.la
160 %{_includedir}/*
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
165
166 %files doc
167 %defattr(644,root,root,755)
168 %doc docs/html/*
169
170 %if %{with python}
171 %files -n python-beecrypt
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{py_sitedir}/*.so
174 %endif
This page took 0.08371 seconds and 3 git commands to generate.