]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- fix duplicate %descriptions
[packages/beagle.git] / beagle.spec
index 1faf75439c47c050d499c359cdfcbf1f041fde24..db9ba36de707266bde72dff11d147361f09c8b43 100644 (file)
@@ -1,6 +1,7 @@
 #
 # TODO:
 #       - kill bashisms in crawl stuff
+#      - mozilla extension?
 #
 %include       /usr/lib/rpm/macros.mono
 #
 %bcond_without gsf             # build without libgsf support
 %bcond_without gui             # don't build GNOME based GUI
 %bcond_without python          # don't build python libraries
-%bcond_with    epiphany        # build epiphany extension
+%bcond_without epiphany        # don't build epiphany extension
 %bcond_with    sqlite3         # use sqlite3 instead of sqlite2
 #
-%if %{without gui}
+%if !%{with gui}
 %undefine      with_evolution
 %endif
 #
 Summary:       Beagle - An indexing subsystem
 Summary(pl):   Beagle - podsystem indeksuj±cy
 Name:          beagle
-Version:       0.2.4
-Release:       2
+Version:       0.2.14
+Release:       1
 License:       Various
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
-# Source0-md5: bd915b5f7de56c91dae2c26121c586fa
+# Source0-md5: c3eeccdafc030a7d283bf85b75f5c0bb
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-crawl.patch
 Patch2:                %{name}-kill_exec_a.patch
-Patch3:                %{name}-filtertiff.patch
+Patch3:                %{name}-configure.patch
 URL:           http://beaglewiki.org/Main_Page
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
-%{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.10.2}
-%{?with_galago:BuildRequires:  dotnet-galago-sharp-devel}
-BuildRequires: dotnet-gmime-sharp-devel >= 2.1.19
-%{?with_gsf:BuildRequires:     dotnet-gsf-sharp-devel >= 0.7}
+BuildRequires: chmlib-devel
+%{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.11.1}
+%{?with_galago:BuildRequires:  dotnet-galago-sharp-devel >= 0.5.0}
+BuildRequires: dotnet-gmime-sharp-devel >= 2.2.3
+%{?with_gsf:BuildRequires:     dotnet-gsf-sharp-devel >= 0.8.1}
 #BuildRequires:        dotnet-gst-sharp-devel
-BuildRequires: dotnet-gtk-sharp2-devel >= 2.3.90
-%{?with_epiphany:BuildRequires:        epiphany-devel >= 1.8}
-BuildRequires: gtk+2-devel >= 2:2.6.0
-%{?with_apidocs:BuildRequires: gtk-doc}
-BuildRequires: libexif-devel >= 0.5.0
-BuildRequires: librsvg-devel
+BuildRequires: dotnet-gtk-sharp2-devel >= 2.10.0
+%if %{with epiphany} 
+BuildRequires: epiphany-devel >= 2.16.1
+%endif
+BuildRequires: gtk+2-devel >= 2:2.10.6
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.7}
+BuildRequires: libexif-devel >= 0.6.13
+BuildRequires: librsvg-devel >= 1:2.16.0
 BuildRequires: libpng-devel
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.6.19
-BuildRequires: mono-csharp >= 1.1.13.4
+BuildRequires: libxml2-devel >= 1:2.6.26
+BuildRequires: mono-csharp >= 1.1.16.1
 # not used atm
 #BuildRequires:        mozilla-devel
-%{?with_python:BuildRequires:  python-pygtk-devel}
+%{?with_python:BuildRequires:  python-pygtk-devel >= 2.10.3}
 BuildRequires: pkgconfig
 BuildRequires: perl-XML-Parser
 BuildRequires: python-devel
@@ -61,21 +65,22 @@ BuildRequires:      sqlite3-devel >= 3.3.4
 BuildRequires: sqlite-devel
 %endif
 BuildRequires: wv-devel >= 1.2.1
+BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: zip
 # GUI BRs
 %if %{with gui}
-BuildRequires: dotnet-gtk-sharp2-gnome-devel >= 2.3.90
-BuildRequires: gnome-vfs2-devel
-BuildRequires: libgnome-devel
+BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
+BuildRequires: gnome-vfs2-devel >= 2.16.1
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      dotnet-gmime-sharp >= 2.1.19
+Requires:      dotnet-gmime-sharp >= 2.2.3
 %if %{with sqlite3}
 Requires:      sqlite3
 %else
 Requires:      sqlite
 %endif
-ExcludeArch:   alpha i386 sparc sparc64
+ExclusiveArch: %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
+ExcludeArch:    i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -121,6 +126,18 @@ Beagle static libraries.
 %description static -l pl
 Statyczne biblioteki Beagle.
 
+%package apidocs
+Summary:       libbeagle API documentation
+Summary(pl):   Dokumentacja API libbeagle
+Group:         Documentation
+Requires:      gtk-doc-common
+
+%description apidocs
+libbeagle API documentation.
+
+%description apidocs -l pl
+Dokumentacja API libbeagle.
+
 %package crawl-system
 Summary:       Beagle crawl system
 Summary(pl):   System przeszukuj±cy beagle-crawl
@@ -140,21 +157,33 @@ Summary:  Beagle Evolution backend
 Summary(pl):   Backend Beagle dla Evolution
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-Requires:      dotnet-evolution-sharp >= 0.10.2-4
-Requires:      evolution
+Requires:      dotnet-evolution-sharp >= 0.11.1
+Requires:      evolution >= 2.8.0
 
-%description
+%description evolution
 Beagle Evolution backend.
 
 %description evolution -l pl
 Backend Beagle dla Evolution.
 
+%package thunderbird
+Summary:       Beagle Mozilla Thunderbird backend
+Summary(pl):   Backend Beagle dla Mozilli Thunderbird
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+
+%description thunderbird
+Beagle Mozilla Thunderbird backend.
+
+%description thunderbird -l pl
+Backend Beagle dla Mozilli Thunderbird.
+
 %package -n epiphany-extension-beagle
 Summary:       Epiphany extension - beagle
 Summary(pl):   Rozszerzenie dla Epiphany - beagle
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-Requires:      epiphany-extensions
+Requires:      epiphany-extensions >= 2.16.1
 
 %description -n epiphany-extension-beagle
 Epiphany extension that allows Beagle to index every page the user
@@ -179,23 +208,36 @@ Wi
 
 %package search-gui
 Summary:       GNOME based Beagle GUI
-Summary(pl):   Bazowane na GNOME GUI dla Beagle
+Summary(pl):   Oparty na GNOME graficzny interfejs dla Beagle
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
-Requires:      gtk+2 >= 2:2.6.0
+Requires:      gtk+2 >= 2:2.10.6
 
 %description search-gui
 GNOME based Beagle GUI.
 
 %description search-gui -l pl
-Bazowane na GNOME GUI dla Beagle.
+Oparty na GNOME graficzny interfejs dla Beagle.
+
+%package startup
+Summary:       Automatic startup integration for Beagle
+Summary(pl):   Integracja funkcji automatycznego startu Beagle
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     beagle-gnome
+
+%description startup
+Automatic session startup integration for Beagle.
+
+%description startup -l pl
+Integracja funkcji automatycznego startu Beagle.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p0
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -216,14 +258,14 @@ Bazowane na GNOME GUI dla Beagle.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
+install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        pythondir=%{py_sitedir}
 
 # Kill useless files
-rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
+rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
 
 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
@@ -267,8 +309,10 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/*.exe
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/Backends
-%{_libdir}/%{name}/Filters
-%{_libdir}/%{name}/*.dll*
+%dir %{_libdir}/%{name}/Filters
+%{_libdir}/%{name}/*.dll
+%{_libdir}/%{name}/*.dll.config
+%{_libdir}/%{name}/Filters/*.dll
 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
 %{_mandir}/man*/*
 
@@ -281,35 +325,43 @@ fi
 %attr(755,root,root) %{_libdir}/*.so
 %{_includedir}/libbeagle
 %{_libdir}/*.la
-%{?with_apidocs:%{_gtkdocdir}/beagle}
 %{_pkgconfigdir}/*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/*.a
 
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_gtkdocdir}/beagle
+%endif
+
 %files crawl-system
 %defattr(644,root,root,755)
-%attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
+%attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
 %dir %{_sysconfdir}/beagle
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
-%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
+%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
 %attr(755,root,root) %{_sbindir}/*
-%attr(755,root,root) %{_libdir}/beagle-crawl-system
 
 %if %{with evolution}
 %files evolution
 %defattr(644,root,root,755)
-%{_libdir}/%{name}/Backends/Evolution*
+%{_libdir}/%{name}/Backends/Evolution*.dll
 %endif
 
+%files thunderbird
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/Backends/Thunderbird*.dll
+
 %if %{with epiphany}
 %files -n epiphany-extension-beagle
 %defattr(644,root,root,755)
 %doc epiphany-extension/README
-%attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
-%{_libdir}/epiphany/1.8/extensions/*.xml
+%attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
+%{_libdir}/epiphany/2.16/extensions/*.xml
 %endif
 
 %if %{with python}
@@ -321,10 +373,16 @@ fi
 %if %{with gui}
 %files search-gui
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/beagle-search
+%attr(755,root,root) %{_bindir}/beagle-contactviewer
 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
+%attr(755,root,root) %{_bindir}/beagle-search
 %attr(755,root,root) %{_bindir}/beagle-settings
 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
 %{_pixmapsdir}/*.png
 %{_desktopdir}/*.desktop
 %endif
+
+%files startup
+%defattr(644,root,root,755)
+%{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
+%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.054306 seconds and 4 git commands to generate.