]> git.pld-linux.org Git - packages/bcm5820.git/commitdiff
- old RH fixes
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Sep 2007 21:24:54 +0000 (21:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bcm5820-link.patch -> 1.1
    bcm5820-log.patch -> 1.1
    bcm5820-noclear.patch -> 1.1

bcm5820-link.patch [new file with mode: 0644]
bcm5820-log.patch [new file with mode: 0644]
bcm5820-noclear.patch [new file with mode: 0644]

diff --git a/bcm5820-link.patch b/bcm5820-link.patch
new file mode 100644 (file)
index 0000000..1b0073d
--- /dev/null
@@ -0,0 +1,26 @@
+--- bcm5820-1.81/ubslib/Makefile.Linux.jj      Fri Feb 22 17:33:06 2002
++++ bcm5820-1.81/ubslib/Makefile.Linux Fri Aug 23 08:33:46 2002
+@@ -46,13 +46,9 @@ LIBNAME=
+ RM = /bin/rm
+ RMFLAGS = -f
+-ifeq ($(shell `echo uname -a` | grep -i " ia64 "),$(shell `echo uname -a`))
+-  LINUXIA64= -lgcc_s
+-endif
+-
+ # to build shared library
+ SHRCFLAGS = -O2 -ansi -pedantic -fPIC -c $(INCLUDES) -w $(DBGFLAGS)
+-SHRLDFLAGS = -shared $(LINUXIA64) 
++SHRLDFLAGS = -shared -Wl,-soname=$(SHRBINNAME).0
+ SHRCFLAGS += $(BCM_OEM_DEFINES) -DUSER_APPLICATION
+@@ -96,7 +92,7 @@ CNPKCS11OBJ = \
+ endif
+ $(SHRBINNAME): $(SHROBJSUBSEC) $(LIBNAME) $(CNPKCS11OBJ)
+-      $(ECHO) $(LD) -o $(SHRBINNAME) $(CNPKCS11OBJ)  $(SHRLDFLAGS) $(SHROBJSUBSEC) \
++      $(ECHO) $(CC) -o $(SHRBINNAME) $(CNPKCS11OBJ)  $(SHRLDFLAGS) $(SHROBJSUBSEC) \
+               $(LIBNAME)
+ clean:
diff --git a/bcm5820-log.patch b/bcm5820-log.patch
new file mode 100644 (file)
index 0000000..128fe6c
--- /dev/null
@@ -0,0 +1,14 @@
+--- bcm5820-1.81/snmp/get5820stats.log Fri Feb 22 17:33:06 2002
++++ bcm5820-1.81/snmp/get5820stats     Tue Mar 12 18:39:19 2002
+@@ -9,8 +9,10 @@
+    exit 0
+ fi
++# Debug code?
++LOGFILE=`mktemp /tmp/passtest.log.XXXXXX`
+ if [ "$1" = "-s" ]; then
+-  echo $* >> /tmp/snmpstats.log
++  echo $* >> $LOGFILE
+   exit 0
+ fi
diff --git a/bcm5820-noclear.patch b/bcm5820-noclear.patch
new file mode 100644 (file)
index 0000000..d8cabfd
--- /dev/null
@@ -0,0 +1,64 @@
+Add a -n option which inhibits screen clearing when we're not in loop mode.
+--- ./stats/stats.c    2002-11-04 16:15:45.000000000 -0500
++++ ./stats/stats.c    2002-11-04 16:15:38.000000000 -0500
+@@ -72,7 +72,8 @@
+   key_mode     = 0x0002,\r
+   ssl_mode     = 0x0004,\r
+   loop_mode    = 0x0100,\r
+-  verbose_mode = 0x0200\r
++  verbose_mode = 0x0200,\r
++  clear_mode   = 0x8000\r
+ };\r
\r
\r
+@@ -194,7 +195,8 @@
+   \r
+   int i;\r
+   \r
+-  system("clear");\r
++  if(control_word & (clear_mode | loop_mode))\r
++    system("clear");\r
+   stats_printHeaderSimple(control_word);\r
+   \r
+   if(current_device == num_devices)\r
+@@ -220,7 +222,8 @@
+   \r
+   int i;\r
+   \r
+-  system("clear");\r
++  if(control_word & (clear_mode | loop_mode))\r
++    system("clear");\r
+   stats_printHeaderVerbose(control_word);\r
+   \r
+   if(current_device == num_devices)\r
+@@ -357,6 +360,7 @@
+   printf("\t-v\t\tVerbose mode. Show more detailed statistics information\n\t\t\tincluding rate information.\n\n");\r
+   printf("\t-s [num]\tShow statistics for specified device only. Default is\n\t\t\tall devices.\n\n");\r
+   printf("\t-c\t\tShow statistics for crypto operations. Default is key\n\t\t\toperations only.\n\n");\r
++  printf("\t-n\t\tAvoid clearing the screen when not in loop mode.\n\n");\r
+   printf("\t-h\t\tDisplay usage information.\n\n");\r
+ }\r
\r
+@@ -384,10 +388,11 @@
+   interval   = 3;\r
+   control_word  = 0;\r
+   control_word |= key_mode;\r
++  control_word |= clear_mode;\r
+   \r
+   bzero(prev_stats, sizeof(ubsec_stats_t));\r
\r
+-  while ((c = getopt(argc, argv, "LlVvS:s:I:i:CcDdKkHh?")) != -1) {\r
++  while ((c = getopt(argc, argv, "LlVvS:s:I:i:CcDdKknHh?")) != -1) {\r
+     switch (c) {\r
+     case 'L':\r
+     case 'l':\r
+@@ -420,6 +425,9 @@
+       control_word &= (control_word & ~crypto_mode);\r
+       control_word |= key_mode;\r
+       break;\r
++    case 'n':\r
++      control_word &= (control_word & ~clear_mode);\r
++      break;\r
+     case 'H':\r
+     case 'h':\r
+     case '?':\r
This page took 0.107888 seconds and 4 git commands to generate.